Ubuntu 21.10 on the Framework Laptop

Just upgraded mine to 21.10. I’m having tons of issues with it. So far, it has broken my Files and Settings icon. Restarting and logging off takes much, much longer than when it had 21.04. All tasks take much longer, so opening up terminal takes a couple of minutes for it to actually start up. My browser takes much longer to open, and apps like the Software manager, Spotify, and Discord don’t even open at all anymore. Even powering off takes nearly 5 minutes now.

I personally haven’t had any trackpad issues, however. If anyone has any fix for this, please let me know.

Substantial edit: Ok, now I’m having the touchpad issues

1 Like

Thank you for experimenting. I think I will hold off, until better reports come in.

I’ve just done a fresh install of 20.10 and am transferring files over as I type. I plan to write up the experience over the weekend.


Fresh install of 21.10 and working great out-of-the-box.
Bluetooth is completely functional.
I haven’t seen the “stuttering” that some others are seeing so didn’t need to disable PSR. (See [Warning] Ubuntu 21.10 Wayland issues] post for more details and workaround if you have it.)
I =did= have a problem where trackpad clicks stopped working during the install. Annoying to have to use keyboard, especially the disk partitioning, but in the end I’m pretty happy that everything is just working.
Too bad I couldn’t get Manjaro to keep bluetooth up – but at least not that hard to kick Gnome to the curb in Ubuntu and get Cinnamon running. ;o)

1 Like

Spoke too soon – after a reboot bluetooth didn’t work again.
I tried the 5.14.15, 5.12.19 and 5.12.4 kernels all with the same results - bluetooth picks up and drops my mouse every second forever.
Guess I just use Windows for a while.

i fixed a lot of my ubuntu 21.10 issues (mostly the freezing input) by updating my kernel parameters.
edit (as root) /etc/default/grub
and add i915.enable_psr=0
find the line and update it so it looks like this:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash i915.enable_psr=0"

then as root run

Then reboot.

Should tie things over until a kernel patch fixes what ever is happening.



Just got my Batch 4 DIY today, installed Ubuntu 21.10 and I’m very pleasantly surprised how well everything is working. Running i3wm, not noticing much in the way of stuttering thats been mentioned here, but good to know there is a workaround if it starts.

The only things that doesnt seem to have worked out of the box is the fingerprint reader and bluetooth.

Running kernel 5.13.0-20-generic and the AX210 Intel WiFi worked just fine but the Bluetooth doesn’t seem to But I don’t really use Bluetooth anyway.

Edit: Actually, I take that back, the bluetooth does seem to work in Gnome, just not in i3wm so its probably just configuration on my end.

Overall very happy!

I initially installed Ubuntu 21.04 and then immediately upgraded to 21.10. Initially my track-pad clicks weren’t registering, the fingerprint reader wasn’t working, and the laptop screen never recovered from being closed or sleeping (stayed black). I was able to fix my track-pad issues by moving to kernel 5.14.14-051414-generic. I still haven’t fixed the hibernate/sleep issue (I disable Blank Screen and Auto Suspension) or the fingerprint reader issue but all-in-all I’m satisfied with my current setup.

I’m waiting for my Batch 5 DIY edition. I just created my Ubuntu 21.10 USB stick. I haven’t seen any updates on these issues in a couple weeks. How are things? Ubuntu all good?

The OS works good. I update it almost every day but the fingerprint reader still doesn’t show up. Im not sure if hibernation or going into standby are still an issue as I disable these particular features in my laptop.

1 Like

You should:

Disable PSR in grub config
Enable deep sleep in grub config
We aware that fingerprinter reader doesn’t work out of the box

But everything else is a-okay.

Sweet, thanks. So, sounds like a little hit on battery life and resume speed, but otherwise good. Thanks!

I use Ubuntu 21.10 without any major problem, expect for a subsecond pointer freezing from time to time. Wayland works great. The fingerprint sensor can be enabled by following the very same procedure that was written for 21.04

I suppose that the pointer freezing is a matter of upping the priority of wayland.

I didn’t have to compile anything (im running 21.10). Ubuntu devs have a new libfprint package out on launchpad for version 1.94.1 that hasn’t hot mainstream yet.

Download new libfprint binary:

…and install:

sudo dpkg -i libfprint-2-2_1.94.1+tod1-0ubuntu2_amd64.deb

After a reboot (didnt confirm if this was even needed) I was able to go to settings and enable/enroll fingerprints just fine.


I can confirm that a reboot was not needed. :slight_smile:

Also, the new binary worked for me; I’ve been trying to get this working in Ubuntu for a while (it’s working on Fedora in my other partition just fine).

I did have to register a different print than in Fedora though, otherwise it threw an error.

just upgraded from 21.04 where i built the fingerprint libraries from source and enrolled. upgraded the linux kernel to 5.14.21-051421-generic after the 21.10 upgrade and things have been very smooth. bluetooth working fine and the fingerprint has persisted through upgrades. no wake from sleep issues AFIAK.

noticed the pointer freezing right after the upgrade since that bumped my kernel from to since moving to 5.14.21, it’s been fine (haven’t had to disable PSR in grub).

i haven’t messed around too much outside of the manual install of the fingerprint libraries so it’s been a pretty clean install from the beginning. hoping that i can stay on 22.04 LTS for duration once that comes out since the laptop feels like it’s in a good place right now.

one thing i did notice in 21.04 that is fixed in 21.10 is using Tweaks. occasionally, i’d have issues with Tweaks being applied after restarts and it would sometimes cause me to have to reboot a couple of times. 21.10 ships with an Extensions app that renders Tweaks obsolete and it seems to be better.

have had this setup for a day at this point so will report back if i do run into any issues.

I just installed 21.10. Cursor freezes intermittently with Unity on Wayland but NOT with Cinnamon on X.

I’m not sure whether it’s Unity or Wayland that’s causing the issue but Unity is a hot mess of an unusable interface anyway, not sure why it’s the default.

The only issue I’m having with Cinnamon/X is sometimes when new windows/menus popup they show up in bands but it’s not that frequent. I posted another thread about it.

I’m pretty sure Unity is basically dead and gone from Ubuntu: the default Ubuntu interface for the last several versions and definitely for 21.10 is just Gnome 3 with a couple extensions.

I haven’t had cursor freezing issues, but I do have panel self-refresh disabled.

Is there a keyboard backlight brightness control in Ubuntu 21.10? There is no slider in the power settings for it on my laptop. I’m not seeing a way to turn on the backlight. Thanks in advance.

fn + spacebar works for me