Ubuntu 21.10 on the Framework Laptop

I’m pretty sure Unity is basically dead and gone from Ubuntu: the default Ubuntu interface for the last several versions and definitely for 21.10 is just Gnome 3 with a couple extensions.

I haven’t had cursor freezing issues, but I do have panel self-refresh disabled.

Is there a keyboard backlight brightness control in Ubuntu 21.10? There is no slider in the power settings for it on my laptop. I’m not seeing a way to turn on the backlight. Thanks in advance.

fn + spacebar works for me


That’s brilliant, Chris_Eden. Why didn’t I know that? (rhetorical question)

@Dave_Olson - It’s the one fn combination that I keep forgetting. Until you jogged my memory. Thanks :slight_smile:

Nixingit, I just renamed this thread’s name “Ubuntu 21.10” to “Ubuntu 21.10 on the Framework Laptop”, aligning the naming style with other thread such as Ubuntu 21.04 on the Framework Laptop . Hope you like it.

I just wanted to add my experience to this thread, in case it helps people. I received my batch 6 laptop on the 30th of December and decided to install Ubuntu 20.10 on it instead of the 20.04 other people propose. It was globally a favorable choice, here is a summary of the problems I’ve encountered:


  • Lag in the mouse. As expected, I had a lag in my mouse pointer. I’ve fixed it by changing the kernel. This was not a easy task but it wasn’t complicated either. I finally managed to install kernel 5.14.21 after figuring out I need to download 4 files and not just one… Also, I had to disable secure boot in the Bios to change my kernel.
  • Hard click on the touch pad didn’t work. This finally wasn’t a Ubuntu problem, it’s a mechanical problem that can also happen on windows. I fixed it by “forcing” my keypad to behave. Long press, hard press, everywhere, multiple times. It slowly came to life. I’ve also disable the PS/2 option in the Bios, don’t know if it helped.


  • Deep sleep. It seems people are having problems with deep sleep. I did the proposed change in grub, and my battery life seems reasonable. I have little experience so far however as I’ve own this laptop only for 3 days so little experience.
  • HDMI sound was not working out of the box. This is mostly my fault not being knowledgeable enough in Ubuntu, however when I’ve connected my laptop to my TV, the sound was still coming from the laptop, it didn’t move by default to the TV. I had to go to setting - sound to manually select HDMI output. Once it’s done for the first time, it seems to become the official default when connecting to my TV.
  • I haven’t figure out what the problem is yet, but people are complaining about the picture quality from my camera when using Zoom. I’ve improved it by selecting HD in the zoom camera setting, but it’s still not crisp. I’ll have to investigate more.

So so far so good. I’m happy I chose Ubuntu 20.10. Boot time is phenomenal. everything is smooth now. Problems were relatively easy to fix.

MAJOR: One line fix in your grub file.

You can leave the kernel, you can leave secure boot and you can leave ps/2 enabled.

Same, see above link, fixed as well.

No idea about HDMI audio or zoom quality.

I hope this helps you out.


Just reporting my experience with Ubuntu 21.10 - clean install (batch 4 DIY, 32gB, TN850 WD Black, latest 3.07 BIOS/SSD firmware, 5.13.0-25-generic kernel after upgrades).

  • I am using a plain GNOME desktop (installed via the vanilla-gnome-session package, then login choosing “GNOME” in the bottom right corner (gear) of login screen. This is closer to the Debian desktop I am used to.
  • Fingerprint reader just works
  • Deep sleep is already enabled by default (no GRUP editing needed)
  • No mouse lag after i915.enable_psr fix in GRUB
  • No trackpad problems - edit right click is not configured by default, fix in GNOME tweaks.
  • Good HiDPI default settings, I’ve adjusted scaling on external monitor and fonts (with Tweaks).
  • < 24h battery drain in suspend, I haven’t tackled this
  • No issues with Wifi/BT, but I am using an older card which I knew worked (Intel Dual Band Wireless-AC 3168NGW)
1 Like

I just updated from 21.04 to 21.10 with no problem detected.

I am running Ubuntu Studio, which is based on Kubuntu, so I have KDE Plasma instead of Gnome and Xorg instead of Wayland. Kernel is 5.13.0-23-lowlatency (the studio functions prefer lowlatency). I do not use Bluetooth nor the fingerprint reader, and I haven’t tested sound yet. Touchpad response is totally good so far.

What kernel are you using?

I’m enjoying 21.10 on my Batch 6 DIY, but I have a question that, hopefully, this group can answer. Bluetooth is working well. I have a Bluetooth trackball that works great, and a Sonos Move speaker that also working like a champ. When I try to use my Sony WF-1000XM3 ear buds, they connect via Bluetooth but aren’t recognized as an audio device. Is there a library or something that I’m missing? How can I figure that out?

What kernel are you using @Dave_Olson? I think there’s a regression in kernel 5.13 for Bluetooth

Thanks for the reply.

I’m on 5.13.0-23 generic. That’s a recent update from 5.13.0-22 generic. I’m not seeing the Bluetooth controller failing to start from a warm boot bug described in the thread you linked. Both wifi and Bluetooth are working well with my AX210. It’s leading me to think that my problem is more likely a missing codec or library or something like that, but I’m a complete novice with Ubuntu Bluetooth audio.

1 Like

I’ve turned the first post into a wiki post. Feel free to add issues and workarounds directly there.

Also, somewhat unexpectedly, the fingerprint reader does seem to work in Ubuntu 21.10 after updating all packages.

Has anyone successfully upgraded the 21.10 install to another kernel? When I try to do this, I get the following error on reboot:
Error: can’t find command ‘hwmatch’
Error: file /boot/vmlinuz-5.15.6-051506-generic has invalid signature
I’ve tried both 5.15.6 and 5.14.21, signatures verified.
I know some people have these kernels installed, but I believe they were installed in 21.04 and then upgraded to 21.10.
Note: I had this problem with a previous 21.10 install. I wanted to repartition anyway, so I repartitioned and then reinstalled. I originally thought it was an issue with the boot sector but apparently not – or at least rewriting the boot sector didn’t fix it.

The problem was with secure boot; disabling it boots fine. Now to figure out how to upgrade the kernel with secure boot enabled.

One could sign the new kernel modules as described here.

However, shouldn’t the kernel modules already be signed by Canonical?

I can’t comment on the published article because it won’t let me login through google. Can this be fixed? It doesn’t recognize my login otherwise.

I saw someone here has already mentioned it here but since it hasn’t been added to the main article and it could affect the experience of future novice Linux users here’s the comment I wanted to add:
As a Linux novice, I had a bit of trouble following Step 4 as it’s missing details that would have saved me some hours. I tried #sudo edit /etc/default/grub# but that didn’t give the same workable window as pictured and the keys were not typing normally. I do think this needs specified to enter the commands #sudo nano /etc/default/grub# to make any changes and save it under a new name as grub2 (I assume based on the statement “Then as root run ‘update-grub2’” that it wanted me to change the name to grub2) then #sudo update-grub2# before #sudo reboot#.
Thanks for putting this article up, it was really helpful.

I gave Ubuntu 21.10 a shot over the weekend and it was a fairly painless setup, but ended up going back to Windows 11. My issues were mostly with Wayland/Xorg being weird with display scaling. VS Code under Wayland was blurry due to some older version of Electron. Xorg had some screen tearing issues. I also had some issues with video decode in web browsers not using the GPU. Youtube would use AV1 on Chrome for example. Firefox I could get VP9.

There are likely workarounds for all of that I just couldn’t be bothered to find them at the time.