Ubuntu 22.04 on the Framework Laptop 13

This - Automated post-install setup of Ubuntu 20.04 and 22.04 on the Framework - has now been updated to handle fresh installs of Ubuntu 22.04 as well as upgrades from 20.04. The latter is especially important since there are some changes that are no longer needed on 22.04.


If you use any form of docking station i would highly discourage using the auto-tune function. It will put the usb devices on a 5sec sleep timer.

Good to know! I don’t use a docking station at the moment, but my mouse which uses a USB dongle, is freezing a few secs after login. If I remove and re-insert, it’s fine for the rest of my session. I might try disabling the powertop command and see if that influences it.
Otherwise, a week in and so far so good! Really enjoying the upgrades/tweaks in 22.04 (from 20.04).

This release is shaping up to be fabulous!


I’m having issues setting up hibernation for 22.04. I followed a few guides that I found that say to use a swapfile to suspend then hibernate. When I try to test hibernate using “sudo systemctl hibernate” it works but it immediately wakes back up and goes to the lock screen. Also the laptop does not seem to be suspending when I close the lid, the screen stays on. Tips?

Hi all,
I started with 20.04 (what I had on a USB stick from before), and managed to get the wifi (non vPro) working using the workarounds referred to here Ubuntu 20.04.4 LTS on the Framework Laptop
then I did an in-place upgrade to 22.04 using do-dist-upgrade, and ha ha joke’s on me wifi is now just not working at all.

ip link shows a wlp interface, but it never goes UP.

What did I mess up? The iwlwifi-ty-a0-gf-a0.pnvm file is in place in /lib/firmware, different from the patched one from the 20.04 update

What else can I try here?

ETA: kernel 5.15.0-25, and I’ve run this Automated post-install setup of Ubuntu 20.04 and 22.04 on the Framework several times.

ETA2: I decided to nuke it from orbit and just did a fresh reinstall of 22.04 daily and things work out of the box, so yay!



Yay for getting it working even if it was the hard way. If you had WiFi working on Ubuntu 20.04 with latest updates, then probably it wasn’t the formula’s workaround fault. Upon upgrading to 5.13 via regular updates on 20.04 WiFi breaks due to the workaround. At that point you have to either disable it manually and restore the firmware file or rerun the formula which will do that for you. Since you had it working in order to do the upgrade, one or the other likely happened. If the firmware file was in place post-upgrade, then the workaround was disabled since all it does is remove it on every startup. So both pieces of evidence point to a problem elsewhere. Given that the interface was present also lends credibility to that hypothesis. My guess is something else dun fucked up. :sweat_smile: What exactly, we’ll never know since all the evidence was vaporized upon nuke detonation. With all that said, if I see other reports of the same problem, I’ll investigate. I have completed about 10 test upgrades and 2 for-real upgrades on machines that were salted with the formula and didn’t see any issues but as always, mileage varies and “works for me” doesn’t mean there are no defects.

1 Like

I’ve converted the first post to a Wiki post, now that 22.04 is out.


It’s out!! Go and grab it!
Ubuntu 22.04 LTS (Jammy Jellyfish)

1 Like

After updating, my WiFi stopped working. Tried a few things that didn’t work then updated the BIOS and that solved the WiFi problem. However, another issue that I was running into while trying to get hibernate working popped up again. When waking after suspend (I’m using suspend-then-hibernate), the OS will eventually freeze up. I have to reboot to get it out of this state. Dropping into tty opens a black screen that slowly displays a bunch of ext4-fs errors. The way I solved this previously seemed to be removing mem_sleep_default=deep from the grub config, which I added following this guide, and leaving resume and resume_offset. My grub config wasn’t modified during the update to 22.04, so I’m not entirely sure what’s going. From Googling, it seems that I might be a kernel issue. I’m gonna try a clean install of 22.04 tonight to see if I can right the ship.

Anyone get the airpods working with 22.04? I’m not sure if it’s specific to the airpods or if other bluetooth sound devices don’t work either.

I’m running Fedora 35 but initially could not pair my Airpods Pro with my Framework notebook.
Somewhere in the depths of the internet I found a hint that led to success.

I had to edit /etc/bluetooth/main.conf and change the option
ControllerMode=dual to ControllerMode=bredr

A restart later I could successfully pair my Airpods to my Framework.
Could that work as well using Ubuntu?


@Sven_Hiller That fixed my issue. HERO. Thank you so much.

1 Like

Who can update the Framework guide with this added?


What does ControllerMode=bredr mean? Could it affect other Bluetooth use cases negatively? If so then it might belong to an Airpods guide and not the general Ubuntu one.

If you word it correctly, it should belong to the Ubuntu guide.

e.g. If you are experiencing issue with bluetooth pairing, modifying the ControllerMode parameter might help address this. Possible parameter values are dual, bredr and le.

1 Like

FWIW, the OEM kernel in Ubuntu 22.04 is 5.17 and the doc page calls out newer drivers and fixes as differences from the generic kernel:

  1. Additional device drivers, e.g. i915 drivers to support new Intel graphics, iwlwifi to support new wireless cards or new Realtek card reader.

I’ve been running it for a few weeks now with no problems whatsoever. I don’t know if it brought any improvements or not. Anecdotally I think Black Mesa crashes less often on it but it could be just snake oil.

If you want it:

sudo apt install linux-oem-22.04
1 Like

There’s also this for all of the Linux DJs and robotics engineers around here. I haven’t tested it yet because this warning got me scared :sweat_smile::

**You will not be able to revert to your original kernel after enabling real-time.**

After upgrading to 22.04, nearly everything worked, with the major exception of the USB ports. They supply power, but don’t recognize or mount devices plugged into them, and “discover usb” doesn’t help.