WiFi no longer works after upgrade to Ubuntu 22.04

Hi, I upgraded to 22.04 last night, and this morning when I turned my laptop on, I wasn’t able to connect to wifi anymore. At first, nm-applet would have wifi greyed out, but now it’s not showing up at all. All I’ve tried is running this automated post upgrade script including the section on wifi (though, I didn’t run this script after I installed 21.10, so I didn’t have to disable the workaround). Does anyone have any ideas on what I can do to get this working again?


In case anyone else runs into this, I got it resolved by updating my BIOS.

1 Like

Yeah, the post-install script doesn’t do anything for WiFi unless you’re coming from very old 20.04. Also it’s interesting that you’re looking for nm-applet because I don’t think it’s used in Ubuntu 22.04. Certainly isn’t running on mine.

It’s not, I installed it manually cause it’s what I’m used to. I was running i3-gaps with some amateurish rice, so I didn’t have a lot of gnome tools available. I’m running into some new issues now. I just installed 22.04 from scratch, and was actually just gonna comment on your post install post to see if you had any insight. Gonna go ahead and comment there, so we can have any solutions documented there, though I’m really leaning towards downgrading back to 21.10 at this point.

Hey I have a similar issue with my WiFi described here :

Updating the bios only worked until I rebooted, is it still working for you ?


1 Like

I’m having the same issue with my Wifi as well, after the same upgrade. The connection drops at random intervals while I’m working. Usually turning aeroplane mode on and off again fixes it, but occasionally this doesn’t work. Mostly posting this so I see further updates if they’re made, but happy to post logs etc. if that’s useful.

1 Like

I was holding off on updating my bios but I was a bit worried that I might drain my battery on 3.06 and run into issues so I finally updated my dual boot Windows 10 install with drivers (that I originally thought contained the BIOS updated) and then the bios update itself. I rebooted into Ubuntu 22.04 which had been working well before then. I think wireless worked the first time in Ubuntu but the second time I suddenly discovered that my wireless device was no longer recognized: there is no device to turn on any more.

  • secure boot is NOT enabled
  • the wireless device IS enabled in the BIOS settings.
  • lspci shows Network controller: Intel Corporation Wi-Fi 6 AX210/AX211/AX411 160MHz (rev 1a)

I don’t have a solution to the wifi problem you are seeing but the following may help.
My Bios is 3.07, running Ubuntu 22.04 which installed with no issues and is running fine. I upgraded from 21.10.


1 Like

I connected an ethernet cord started what I expected to be a lengthy troubleshooting session this morning. As it turns out, I started in Windows 10 first and finished installing the latest update to Windows 10 - version 21H2. After it requested a reboot I rebooted to Windows to make sure everything worked, turned off the computer and this time booted into Ubuntu 22.04 - and the Wifi icon showed up and connected automatically to my home network! I just rebooted again to see if it would stick and it still appears to be working correctly. I speculate that perhaps because I updated the BIOS/UEFI from Windows that Windows set some flag (it seems to keep promoting itself in the boot order, for example) in the UEFI settings. And/or it updated some setting on the hardware itself.

This is all very weird and smells funny. :sweat_smile:

I also just upgraded to Ubuntu Studio 22.04 Jammy Jellyfish. It has KDE Plasma. I don’t see wireless at all in the network widget on the panel, only wired network. lspci shows the Intel driver.

The geeks on https://app.element.io/#/room/#ubuntu:libera.chat solved the wireless problem for me. I had to install

sudo apt install backport-iwlwifi-dkms

even though dkms was already installed. The installation put a new kernel module into the system. After a reboot things were cool.

It looks like this was not a KDE Plasma problem but a problem of the wrong module.

FWIW, I had a crash in the middle of my upgrade to 22.04, got things going again with a recovery boot using the dpkg recovery option. It’s possible that the problem was due to that recovery not being quite complete.

1 Like

Oh, thank you thank you @Michael_O_Donnell. I’ve been scouring the internet trying to figure out how to even troubleshoot this and going into so many different rabbit holes, trying all kinds of random stuff. And this worked instantly.

For me, there was a separate issue with libssl that meant apt upgrade wasn’t working for a few months. So I think when I recently fixed that issue, the WiFi conked out on a restart. I was so confused because it still worked on Fedora.

Hi all,

I have a new 12th Generation DIY model and I’m trying to install Ubuntu Studio 22.04 onto it. When booting off the live disk I see nothing at all for networking. No wifi, no wired connection. The Networks applet says “Disconnected” and has a red X on it. Without any connection to the internet I can’t even try the backport installation that @Michael_O_Donnell suggested. Anybody have any ideas here? I’ve restarted a couple of times but that doesn’t seem to help.

I also dug out an Ubuntu Studio 20.04 Livedisk, and the applet there also says “No network devices available”

lspci lists only one network controller: “Intel Corporation Device 2725 (rev1a)” No mention of a wireless controller.

My wifi module came preinstalled. Maybe incorrectly? There isn’t some hardware switch that I bumped by accident, is there?


For anyone dealing with this.

  • Ubuntu (GNOME) Are you able to create a connection to WiFi using this from the terminal:

Did this work? If not, please try:

  • Try booting to a Live USB of 22.04 as the card works fine on a clean installation.
  • If the Live USB is working, I’d strongly consider a clean installation as the most reliable solution.

Hi @Matt_Hartley

I haven’t actually installed Ubuntu Studio yet because of the lack of internet; everything I’m doing is on Live USB. I have no wifi on my Ubuntu Studio 22.04 Live USB, nor on my Ubuntu Studio 20.04 Live USB.

Ubuntu Studio 22.04 doesn’t have nm presinstalled and I can’t download it from the repositories without internet. Running nm-connection-editor in Ubuntu Studio 20.04 returns this:

** Message: 03:51:34.040: Cannot save connection due to error: Invalid setting Wi-Fi:802-11-wireless.ssid: property is missing

Bluetooth works. Unfortunately I was a silly whatsit and forgot to order an ethernet expansion card.

Have not tested Ubuntu Studio myself. I will create a USB and test the live environment over the weekend. If I do find it’s behaving differently that the tested Ubuntu 22.04 and 22.10 releases, I know the Ubuntu Studio Project Lead, old friend of mine. So I can ask about this if I can duplicate.

Under normal circumstances, I’d have you test Ubuntu 22.04 and 22.10. But with you lacking Internet at the moment, I’ll simply circle back to testing out Ubuntu Studio myself and make a reminder for this thread.

Thank you very much, Matt. Greetings to Erich, I’ve never met him but I really appreciate the way he has poured himself into Ubuntu Studio and kept it thriving.
I tried downloading Ubuntu 22.04 over the weekend (on another laptop) but my connection wasn’t good enough and the download failed. I’ll try again tonight, as the internet is usually better at 3 AM.
I also plan to buy an ethernet expansion card, but since I’m overseas it could take me a while to find someone stateside who can bring it out for me.

1 Like

Sounds like a plan. :slight_smile:

I finally got Ubuntu downloaded. Wifi works fine on the Ubuntu 22.04 Live USB, so this seems to be a problem with Ubuntu Studio. Probably the dkms kernel module issue that @Michael_O_Donnell mentions above?

I then installed Ubuntu Studio without a wifi connection and after rebooting, the wifi works (despite having done nothing with the dkms module). We’ll see how long it lasts.

1 Like