Ubuntu 24.04 on the Framework Laptop 16

Okay, if this won’t even get to BIOS with the dGPU installed, something isn’t correct and you will want to open a support ticket.

You will want to get this into a support ticket as that is where I review stuff like this due to staffing and available cycles.

Hello,
Just want to share my experience with F16 batch 15 after 1 week of using it…

Ubuntu 24.04 has introduced a bug in latest kernel update 6.8.35 basically machine
will fail to properly wake up from suspend mode (encrypted drive) it can’t be shutdown/restarted quickly as it complains of being unable to access disk trying to write a log file with “filesystem read only” messages flash this goes on for 20 mins until it eventually turns off.

Initially, I didn’t want to use Ubuntu as my dislike for Ubuntu way of doing things so Mint was my first choice but installer froze at partitioning so I did install Ubuntu in the end.

Updating bios was another SNAFU, instruction to use USB boot disk ended up with ruined USB drive, however Ubuntu’s own firmware installer did precisely just that (so please update your instruction as in version 24.04 one can just use firmware updater to update bios) It set up everything properly and bios update went in smoothly after reboot…

Tracking down issue with waking up from suspend read only file system confirmed that no problem existed in 6.8.31 kernel but I had enough of Ubuntu by then…

So totally unsupported Mabox Linux 24.05 is now running like a charm with both Manjaro kernels 6.6.x and 6.9.2-1 with the latter running most of the time!
No issues with touch pad, no issues with anything really, it just works!

Arch wiki about Framework laptop puts official instructions/guides to shame which is disappointing ideed should be he first port of call for anyone setting up Framework laptop with Linux OS.

B/R

I tried installing on my new FW16 but had some problems with some program windows flashing and doing strange things sometimes (did a fresh install, no upgrade)
Went back to 22.04 and no problems with this version.

Just gonna wait until 24.04.01 point release.

Just installed Ubuntu 24.04 on my Batch 19 Framework16 and everything seems to be working perfectly with one exception: the open file dialog does not work correctly in either Firefox or Brave, but does work in Chrome. Is anyone else seeing this?

The open file dialog comes up with no problem when needed (e.g. you are trying to import a certificate), but if you double click on a file or click the open button, the dialog disappears but the file is not uploaded. I am currently forced to use Chrome because of this, which is not my preferred choice.

Possibly this is an Ubuntu bug, but I couldn’t find anything on the Ubuntu forums about it, which I would expect to if it was impacting everyone because Firefox is the default browser.

I would be curious to know if any other Framework16 users have seen this problem. If you are running Ubuntu 24.04 on a Framework16, are you able to open files in Firefox?

In case it is relevant, I’m using internal graphics, no GPU, and I did a fresh install of Ubuntu 24.04 from a live USB.

EDIT: As suggested by Paul Kelly, I removed snap following the instructions at https://linuxconfig.org/uninstalling-snapd-on-ubuntu and reinstalled Firefox and Brave and this completely solved the problem.

Sounds like a snap problem. I went with Ubuntu 24.04 too, but found that life was better after I nuked snapd from the system. I reinstalled Firefox & Brave using traditional packages from Mozilla and Brave repositories. My particular problem was KeePassXC integration doesn’t work through the isolation that the snap package imposes on Firefox.

Ubuntu really doesn’t make it easy to switch away from snap, I probably would have been better off changing to a snap-free distribution like mint or Pop!_OS.

2 Likes

Thank you so much, removing snap completely solved my problem!

As a longtime Pop/OS user I had no idea Canonical had done this. I wanted to try out Ubuntu 24.04 because of all the good things I had heard about it’s performance on the Framework16, but I will be switching back to Pop/OS as soon as they release their version 24.04 (looking foward to Cosmic but even without it I find Pop/OS to be a huge improvement over Ubuntu, and not just for System76 machines).

1 Like