UMA_Game_Optimized in bios negative effects?

Are there any downsides to setting UMA_Game_Optimized in the bios?

Lowered battery life or something?

I do game maybe 25% of the time, but don’t want to negatively affect the rest of my experience

The negative effect is less RAM available for the system. Depending how on the amount of RAM you have left and depending your workflow this may or may not have an impact.

Personally I keep it in game mode. I have 32gb of RAM. In game mode I have 27-28gb left and they are enough for my use cases.

But if for example you end up in a low available RAM scenario this might increase the amount of swapping/paging or the amount of reads from disk due to less available memory for cache, thus ending in a higher disk usage and eventually slightly higher energy consumption. Though I think this are edge scenarios

Game optimized is a bad name for the feature IMO.

The CPU and GPU in the system both need ram in order to function. On many computers there is separate ram dedicated to the CPU and GPU, however the Framework laptops use unified memory. Unified memory is dynamically allocated between the CPU and GPU depending on where it’s needed.

The problem is that some programs (mainly older games) when they launch will check how much ram is allocated to the GPU, and upon seeing almost no ram allocated to the GPU will throw an error about the GPU not having enough ram and refusing to run (because the program doesn’t understand that more memory will be allocated when it is actually needed).

UMA_Game_Optimized will enforce a minimum amount of ram (a couple gigs) allocated to the GPU. This means that when a program checks how much ram is allocated to the GPU it sees a couple gigs and doesn’t freak out.

The downside to UMA_Game_Optimized is that permanently allocating some ram to the GPU results in that ram not being available to the CPU if you run a program that needs a lot of CPU ram.

My advice is to test and see if any of the programs you use throw errors about not enough GPU RAM (aka VRAM). If that happens you should enable UMA_Game_Optimized, otherwise leave it off.

7 Likes

Thanks for the informative answer!

1 Like