Upper right port only accepts charge, no data

Hi there!

FW 12th gen i7-1260P

For some time now upper-right port only accepts charge, and cannot connect any USB devices. It can detect them, but no connection can be established (device descriptor read/64, error -71)

I’ve tried boot drives from UEFI, and it can’t see them there either — so not an OS bug.

Swapped in other cards — nope.

Removed card, and plugged in directly — nothing.

Tried full mobo reset — no luck there as well.

Checked shielding tape on the port — it is attached properly.

I am thinking of doing a hardware side inspection.
Can someone knowledgeable guide me through the process of debugging such an issue?
I can do small pitch soldering if required (I’ve successfully done an HDMI card rework).

Have you updated to one of the Beta BIOS versions?

Nope. Can I do that from fwupdmgr?

edit: found instructions, in progress
edit: 3.08 is not yet available on linux, I guess. current one is 3.06
edit: dug a bit deeper, updated to 3.08. no luck, same errors.

I will try downgrading to 3.04 a bit later. Didn’t find any update files for it.