USB-C expansion cards dying from ESD?

I noticed a problem with my setup. I have a laptop connected through USB-C to the monitor - both for video and charging.

I noticed that sometimes when I touch the laptop, I get an electrostatic discharge. This obviously goes through USB-C and monitor. In case of a bigger discharge, it may make my monitor to blink for a moment.

However, after a few such events, weird things start to happen:

  • after wake-up from sleep, laptop will not recognize external display until I re-attach the cable and/or restart the monitor
  • laptop will start to suddenly turn off at night (I see abnormal shutdowns in windows log)
  • I’m pretty certain at this point that my old WD SN850 SSD died due to this

After this happens - I have to start using another USB-C expansion card, which works just fine (even in the same slot), but the corrupted one will keep giving me the above symptoms.

Has anyone else noticed that?

1 Like

Aren’t the usb-c cards just dumb pass through connectors? Pretty sure there is no circuitry on those esd could fry so that sounds very weird.

Also normal levels of esd on a closed case should not be able to kill internal components like an ssd.

Just to confirm, you’re talking about these?

Those are just a passive pass-through. Just wires / circuit board copper traces connecting a female usb-c port on the outside to a male usb-c on the inner side. There is nothing to be damaged by ESD.

Double checked, there are a couple of small smd capacitors inside the usb-c expansion-cards. Between ground and vbus / power.

Yes I’m certain that it’s not the slot itself that starts to behave erratic - it’s the specific USB-C expansion card.

I tried moving it to another slot and it still behaves erratic.

I had one expansion card broken and just swapped it out for another one. It worked fine for over a month, but now after a few not very big discharges - it started to do the same thing.

I have the skills the replace the caps. Is there a specification/schematic somewhere I can find?

You could replace the caps but that doesn’t really solve the source of the issue.

Framework has a github with some information

What powers your monitor? Does it have a ground pin on the plug?
I know the Framework power adapter has a ground pin but many other usb-c power supplies do not.

I have a Lenovo P27h10 powered through stock power adapter - and yes it’s grounded, I’m measuring a dead short between Framework’s case screw and ground pin in the power socket.

I just measured the caps - they appear to be 38 nF in the unused one, and 36 & 30 respectively in broken ones.

But if they are damaged, it’s probably something else.

1 Like

Now this is interesting!

There are two caps - C3 and C4 (C7 and C8 are not populated).

On the broken boards - one side of them is connected to ground.
On the new one - it isn’t!

1 Like

Are we excluding the more likely possibility of the type-c socket in the wonky card being damaged or dirty?

The artifacts right when the esd happens might just be rf, this also happens with some of my screens when I use my bug zapper.

What do you mean, the boards have a different design?
On the boards I’ve seen pictures of the ground side of the caps go right to a ground plane through multiple vias.

C7 and C8 not being populated seems normal. Every picture I’ve seen appears as such.

Broken card:

Brand new out-of-the-box:

I made sure that the caps were discharged before measuring, and that I have a good electrical contact on both.

1 Like

0ohms to ground on both sides of the cap?!

0ohms to ground on both sides of the cap?!

No - only on the side that is further away from the port. The caps seem to behave normally, at least to multimeter.

Another symptom of this difference between the dead and good board is that I’m measuring 0 ohms between shields of two USB ports on the broken board - and there’s no connection on the good board.

I believe arching occurs between the laptop-side USB shield and the grounding on the PCB because the clearance is very low. And for some reason - this shorted something on the board permanently, but I can’t seem to find anything visually.

More interesting findings:

  • Framework power supply’s ground pin is deliberately not shorted to USB-C shield - it has 1 MOmh resistance - I believe it’s to prevent such ESDs
  • my monitor’s USB-C is shorted to ground (as it probably should be)

My suggestion to the Framework team: since you can’t control how other manufacturers ground their ports - you should opt to have 1 MOhm internally on the motherboard between the shield and the board’s ground - and not on the power supply, because that alone doesn’t help with ESDs if someone has their monitor connected.

The workaround I’ve been using after the first USB-C fried was to first ground myself to USB port on my other PC to discharge myself before I’m working on the laptop. This worked well for the expansion card, until I forgot to do it a few times. Now I have two fried boards.

1 Like

Still kinda skeptical if the esd is the actual cause of the problem. Humans are so good at pattern recognition they sometimes see connections where there aren’t. Esd damaging traces or solder-points is a lot less likely than that same damage occurring due to mechanical damage.

Still kinda skeptical if the esd is the actual cause of the problem. Humans are so good at pattern recognition they sometimes see connections where there aren’t. Esd damaging traces or solder-points is a lot less likely than that same damage occurring due to mechanical damage.

Well I won’t defend this theory by all means. For sure I have 2 boards that have a short that doesn’t occur on a new one. I rarely disconned my laptop, as it’s sitting at my desk 95% of the time, so I’d be surprised with mechanical failure. However - this might be some other factor that I don’t know about.

I’ve send a message to the support team and hopefully this will reach Framework’s engineering team and maybe somebody can look at it.


Yeah that’s definitely cursed and should be looked into.

I’d be really surprised if it actually was the esd but something is definitely fucky. ESD ate my homework XD.

Ok so I got a reply from Framework Support. Since I’ve bought Framework using freight forwarder company and it’s outside of their supported countries list - they won’t give a sh*t about my research and just go ahead and close the case.


Well that sucks but them’s the rules I guess.

Would still love to find out what went wrong here.

I think your case is worth investigating regardless your current country, especially with the clues you discovered (I know Framework can’t provide warranty services).

I had Type-C port related issues as well previously. The Type-C passthrough card’s PCB you posted also looks different to one I opened up before, a few components aren’t populated on the PCB I saw.

I chimed in on FW’s discord hoping to get the attention of someone from FW.