Using Fingerprint Reader for login

Using Fedora 35 with KDE. I can run fprintd and enroll my 1 finger and can verify it. But I can’t figure out how to actually use it for my login. Everything I’ve read says it should be in my user section in system settings but it isn’t there. I tried in GNOME as well and didn’t see it there either.

Tried search for my problem but couldn’t figure it out.

1 Like

Have you installed the fprintd-pam package? You might also have to tell PAM to use the fprintd module, but that might also be done by the package in the post-install phase?

Thanks, did have fprintd-pam installed. But yea ended up finding out how to add them manually to some of the pam files. Also reinstalled fedora and that time it got it working right away when I enrolled again. Works with lock and sudo without me having to do anything.

Don’t have the fingerprint reader going for the user login though since I’m not sure if its possible to make it so the fingerprint auth will login kwallet too.

Still not showing up in KDE settings but I don’t think KDE has released it in there UI yet.

If it doesn’t, kwallet should just prompt for your password anyway, so there’s no harm in trying (ftr, I don’t think it will since the wallets aren’t really updated to deal with non-password authentication as far as I’m aware).

Can you explain the process you took in more detail?

SSDM (the KDE login manager) does not support login by fingerprint out of the box and requires blank password to be entered first.

However there’s hope: https://github.com/sddm/sddm/pull/1220
Unfortunately it takes ages for that PR to be merged.

Please vote and react in that thread to make it happen.