Virtual Reality on the Framework 16

Hey all! Has anyone gotten any VR headsets to work with their Framework 16 laptops yet using the 7700s module? I just tried my Valve Index, and sadly using the USB-c to DP expansion card plugged into the GPU, LTT style, doesn’t seem to work for me. In fact, it doesn’t work at all in Adrenaline’s hybrid graphics mode, and when I try it in SmartAccess Graphics mode, it crashes the laptop. I wonder if it might be a driver thing, as I’ve confirmed using other hardware that my Valve Index works, and my USB-c->DP expansion card does work LTT style for a flatscreen monitor. Or possibly the expansion card isn’t built for VR connections; I intend to try another USB-c->DP adapter when I get my hands on it. But the hardware should be there, since it’s a direct connection to the GPU using the back connector, right?

Anyone else had any luck in this regard?


I have not tried this out personally since my laptop has not arrived. But I think I have some info that may help.
A few weeks back, AMD released driver version 24.1.1 for my 7900xt. I own a Rift s that has been working on my PC but not official supported. After this specific driver update, my headset started functioning very strangely. This is the link to the original post.
My guess is that this is an AMD issue aswell as a valve issue. If you can, I would try rolling back the driver to the latest version of 23 (if that is possible). If you can’t, I would wait for a driver update and try it again.
As to why this isn’t working right now, my guess is the Rx 7700s driver does not have the so-called “handshake” instruction set for Windows applications to detect the headset, or it’s broken in a way that it is unable to do so properly.

This is all speculation, so take this with a grain of salt.


I think you might be correct about the handshaking thing. Framework is getting custom drivers from AMD according to the version name in the Adrenaline software, and I did wonder if maybe the capability isn’t there on the software level yet. Like you, my RTX3070 desktop has had spotty VR support depending on drivers and SteamVR version. And the 3070 should be fully vr ready, too! Unfortunately, there’s only one set of drivers publicly available for the FW16 right now, so I guess if we’re right I’ll have to wait for a bit. Still, curious if anyone else has had any luck.

Sounds terrible that it doesn’t just work. Needing a “handshake” makes it sound like artificial limitations, requiring that the GPU maker and the headset maker both give their blessing.

When I get my laptop, I’ll let you know if I have any luck with my rift s

It’s not really an artificial limitation companies block but more of an additional feature. Companies more or less have to add drivers/instruction sets for headsets to work since their operation is so different from regular displays. You are right tho, It does suck that it isn’t a feature that is standard in software support.


Just chiming in here to say that I’m eager to get VR working too - just received my F16 today :partying_face:


would love to hear how it goes

Same, I’ll try to run it with my Index once my Batch 5 is here. Currently struggling to get SteamVR running on Hyprland (RX 6800XT in my desktop), will try it again once Plasma 6 releases tomorrow (both X11 and Wayland) and see if the issues were due to Hyprland.

1 Like

Ok, I’ve had a chance to test it out using the GPU’s USB-C port. SteamVR on Windows, with a Valve Index.
Unfortunately, no dice. As you’d expect, the headset’s USB devices load up just fine, but display output simply doesn’t work.

SteamVR correctly detects that it’s running on a laptop, and claims “Laptops might require special setup”. (True, but hardly specific :grin:)
That prompt has an option for “Reset Headset”, which hard-locked the Framework 16 both times I tried it, requiring a hard shutdown.

So, I think we will have to wait and hope for the Framework/AMD partnership to give us a response.

(And, team, if you’re reading - I work in the VR industry, specifically on wireless PCVR - I have a keen interest in getting the Framework 16 to be demo-ready!)


Yup, step-for-step exactly what happened to me. Note that if you disable the MUX switch by using AMD Adrenaline’s hybrid graphics mode, you can smash that “reset headset” button all day and it won’t hardlock your laptop… but it still won’t run. So it really does seem like a driver issue to me. I’ve tested both with the framework-branded drivers in the driver bundle and the most recent GPU drivers from AMD’s Adrenaline: “AMD Windows Driver Version

Guess the software compatibility isn’t there yet. I hope it is soon.


Follow-up after a little daydreaming!

I thought perhaps that it might work if I configured SteamVR to run in “extended display” mode instead of direct mode. The logic being - before direct mode existed, all VR HMDs exposed themselves as regular displays to Windows, and output was managed through a fullscreen window on that display…

Sadly not. I booted SteamVR up with the Index’s USB connected (but no DisplayPort) and went into the developer settings to disable direct mode. After doing that, SteamVR restarted and the laptop immediately locked up.

This is really interesting! The fact it locks up even without the HMD’s DisplayPort connection makes me think it’s a genuine driver bug/missing implementation rather than something more complicated. Couldn’t expand on my reasoning beyond “I feel it in the wind” :innocent:

Interestingly the laptop isn’t completely locked up in this state. It does periodically update the display, but never recovers. Eventually it does reset itself.

So, nothing terribly useful learned. Ah well.

1 Like

Damn, I was really wanting to use the FW16 for VR… although I’ve currently got a quest 2, hopefully thay should work through the link cable? Since it’s not a direct display output and it’s supposed to go through just usb-c hopefully it will work, plus I’ve got wireless to try if that doesn’t.

As a side note - have you tried plugging the index into the USB4 ports instead of the one on the GPU? Since it’s not a direct display there’s a chance it doesn’t need to be plugged into the GPU… not sure. Could be worth a try.

1 Like

Yeah, VR via USB cable, or wirelessly - should work just fine!

Nerd Stuff

For those methods, whatever the GPU renders is encoded to video before being sent out over “regular USB” or via a network interface.
Both options route via the CPU first, so it’s much less “special” and is therefore well-tested and highly compatible.

For the Framework 16’s GPU, there’s a lot special going on… First, USB-C on a GPU. That’s not terribly new, given VirtualLink exists. Ah, but actually, it’s no longer in active use. VirtualLink was killed not too long ago…
So, whatever AMD/Framework has done to output video through the GPU module’s USB-C port is likely “brand new”. That likely means fringe functionality like “direct mode for VR” is either not implemented, or not well-tested, if at all.

It was always a long shot for GPU-out PCVR to work on the Framework 16 out-of-the-box.

And unfortunately, with the Index, you’ve got DisplayPort and USB-A to plug in. I’ve been using the Framework DisplayPort to USB-C card for all my tests - in the back of the GPU module. It doesn’t (and I didn’t expect it to) work when plugged into the mainboard :smiling_face_with_tear:

1 Like

The GPU (and all ports on the FW) outputs video via USB-C DP Alt-mode, which isn’t anything particularly new.

I’d also urge any interested parties to try running the VR setup under a Linux host machine to rule out any OS-specific weirdness (or, to establish there may be a hardware or firmware issue)

1 Like

That’s very unfortunate. Hopefully that’s something that can be fixed with drivers down the line? I suppose you could try a usb-c to display-port cable, but that shouldn’t really be any different than running it through the expansion card.

Once I get my hands on it I can try my old vive on linux, but that won’t be for a while. And in my experience steamvr generally works worse on linux than windows.

I’ve had the opposite experience with the Valve Index, on Windows we’ve had frequent crashes and performance issues while on Linux it’s been fairly stable. I ordered a DisplayPort expansion card and I apparently got my FW16 in today. I’ll try VR out this weekend to see if I can get it running.

Nice! I have yet to get VR running on Linux, but I also only ran Hyprland until Plasma 6 released today.

Would like to help with testing, but Batch 5 is still out there.

Fun fact for anyone interested: I was able to get VR running, not through the 7700S, but through USB using a thunderbolt 3 eGPU dock. Felt kinda cursed to be putting Nvidia GTX 1070 drivers on an all-AMD system, but it did work.

Sure hope we hear something soon about VR support for the Radeon card, though. My plan was to sell the eGPU to recoup the cost of the new laptop. :sweat_smile: