What Linux have you settled with?

Huh I can’t even get sudo to ask for fingerprints (which is fine), I only have lockscreen fingerprints that don’t unlock the keyring. Maybe it’s an Arch/GNOME thing I don’t understand

@Paulie420 That’s honestly probably true. I think it’s more having hardware on my machine that I can’t use. Even if I would end up typing in my password most of the time anyway, haha.

It’s good to know I’m not missing all that much though!

This is likely because your GTK_SCALE or DPI variables or gsettings aren’t set to tell it that you are on a HiDPI screen or the gnome-settings-manager isn’t launching to tell things what to use.

Note they have a mention of things for Wayland (from this section and a little before it).



New Framework user checking in. Just got my machine yesterday and finally had a chance to install today. Pop_OS! 21.04 installed without a hitch – WiFi, Sound, Bluetooth, etc. all work. I y haven’t tried to get the fingerprint reader working, but I’m only mildly interested in that so will probably not bother for a while.

Display – I was worried a little about display scaling but the OS automatically setup HiDPI mode – to my eyes it looks great!

Battery life – no data yet on this but I did a standard install of TLP.

So far I’m super pleased with the machine. Good keyboard feel, awesome screen, and very snappy with a Gen4 NVME drive and 32Gb RAM!


Great; glad it went well on the first go!

Do you scale at all? I set my Fedora to 1.25x and… I think I like it?? What did you set yours to?

. . . . . . . . . .

1 Like

I kept the Pop_OS defaults, which xrdb is telling me has resulted in 192 DPI.

UI elements are reasonably sized. I have decreased default font sizes a bit in my terminal and editors.

I initially had Ubuntu 21.04 on mine, since my Framework laptop arrived a couple of days before 21.10 was officially released. I noticed that the trackpad would occasionally glitch in 21.04, but an external mouse worked perfectly. When 21.10 was released I did a clean install onto the laptop but this turned out to be a bad move. With 21.10 the entire system occasionally locked up. So I decided to give OpenSUSE Tumbleweed a spin and it works pretty well, after some initial hick-ups. At first I installed it with the GNOME desktop environment, and coming from GNOME 3/Ubuntu 20.04 that I normally use, the newer GNOME 4 interface was a little hard for me to get used to. So I did another fresh install of OpenSUSE, this time using the KDE desktop environment. I think this one is the default for OpenSUSE and it works pretty well. The only gripes I have with OpenSUSE are that I have to type my password FOUR TIMES to get to a fully booted, logged in, and working state. For some reason GRUB is on an encrypted partition so I have to unlock it with my password, then once I select OpenSUSE Tumbleweed from the boot menu I once again have to enter my password to decrypt another partition. Then I enter my password to log in, then I enter it a final time to unlock the keyring/wallet so I can use WiFi networks. But after jumping through those hoops the system is perfectly stable and fast. It was pretty easy to get my preferred C programing environment set up (clang + CLion). And I’m surprised that vanilla minecraft runs so well. I’m getting near 120fps at native resolution with my 1185G7. My SSD is a 2TB 980 Pro and I’ve got 64GB of RAM installed. :slight_smile:


As posted above, I’ve been running Pop!_OS so far on my framework, but I just did a test drive of Fedora 35 beta running from a USB drive and boy was it snappy!

Everything worked out of the box, though I did have to enable fractional scaling with a single command line call:

gsettings set org.gnome.mutter experimental-features "['scale-monitor-framebuffer']"

I found that video playback on youtube was smoother and I wasn’t seeing screen tearing issues that were nagging me on Pop_OS.

Once Fedora 35 is officially released I think I’ll be move over to that OS as my daily driver on my Framework.


So less than a week ago I wrote that I was planning for Manjaro, but now at the eleventh hour (Framework charged my credit card today!) after much deep thinking, I’m having a serious change of heart and looking at Debian Stable. The idea of setting things up once, and having it run without fuss for two or more years, is suddenly very appealing… I should spend more time working than tinkering and fixing. I’ve seen very little mention of Debian Stable here on the forum, but then I realized that Bullseye comes with the 5.10 kernel which (with the unofficial “non-free” firmware) should support the WiFi card out-of-the-box, right? I don’t care about Bluetooth or the fingerprint reader.

This is what Manjaro does to me, my current Manjaro setup has been running for years.


I’ve been using Mint for years and have always come back after test-driving other systems. It makes life easy enough that I would rather wait for Mint LTS to catch up to framework than switch flavors. Fortunately, it sounds like Mint has been installed with few issues, so I have no hesitation there.

I am considering getting two USB-C drives to swap HDDs and OSes, so kids can run windows without me worrying about them losing/messing my data. Probably a dumb idea, but the concept of running my OS off a thumb drive is neat (and more feasible than running off a USB-A dongle sticking out the side, waiting to get broken off).


You’re going to keep me reconsidering this. :crazy_face: I got spooked by the issues that immediately hit all the Ubuntu users with their 21.10 update, along with various reviews on Distrowatch in which people described reinstalling Manjaro after something broke every six months or so.

However, as noted earlier, I personally did run Arch (ArchBang) on a laptop for a couple years without any major issues.

I’m considering NixOS for the Framework. Steep learning curve but the easy rollback means that you can never break it permanently.

Nah, don’t believe that hype. When it comes to drivers or kernel NixOS isn’t special.

I hated having to run garbage collection and that files didn’t have a timestamp, that the PATH was miles long, that you couldn’t possibly know the location of any system file because there’s a hash involved and so on and so on.


I just installed Debian Bullseye. I had to do an offline install using the full image, then upgrade to the backported 5.14 kernel to get the wifi working (required disabling secureboot). Netinstall should be okay if you use an ethernet adapter then upgrade the kernel after as well. It also needs the nonfree intel package of course. Even with the ‘unoficial’ nonfree firmware netinstall image, the wifi wasnt working for me without backporting the kernel.

1 Like

This statement is very odd to me. I don’t think that people generally use NixOS because the drivers or kernel are special but because of the other features like easy to share, declarative build/development environments.

I don’t mean to imply that you don’t have good reason to dislike the distro, just seems unusual to point out drivers and kernel when those aren’t really that distro’s distinguishing features.

Your other points are more compelling IMO although I don’t think NixOS intends for you to have to interact with the full path very often especially since it changes from derivation to derivation. By that I don’t mean you didn’t have to deal with the long path names to accomplish your tasks just that it isn’t the way the OS intends for you to have to do that.


Out of curiosity, what issues are you referring to? My 21.10 upgrade (from 21.04) was pretty smooth aside from a few GNOME extensions that were out of date and a minor animation change when switching desktops that was easily disabled.

In 21.10, looks like people are reporting issues with audio, trackpad, and intermittent freezing. I think I’ve seen issues with wifi too, but I can’t find the right thread/post at the moment. I’m sure everything is fixable, but it’s certainly not “setting things up once, and having it run without fuss for two or more years.”

1 Like

What I meant is that if you have problems with those you won’t be able to fix the problem by rolling back.

There’s also the fact that some things do depend on the running kernel, for example CUDA. So the promise of perfect reproducibility is broken on things like that.

I used Nix for a while and to me, well, it sucked.

The derivation system isn’t great either by the way :slight_smile:

I’m using Fedora 34 (upgrading to 35 when it releases) and I’m happy to say that everything is working. I initially had to connect a USB Ethernet adapter after the installation and run a sudo dnf update -y to get the latest packages so the wifi would work, but ever since then it’s been awesome.