What to do about blue POST code blinks

My brand new Framework 13 has been running perfectly fine plugged into power as a full-time work computer for two weeks. Today I shut it down, unplugged it from power, and suddenly it won’t boot.

I’m getting all greens on the first 12 blinks, then the orange blink, and code 00010111 (0=blue,1=green). How can my whole system just suddenly barf after two weeks of perfect operation?

I tried resetting the mainboard and that didn’t seem to help at all.

You need to ask support. Since you still have warranty, this is the way to go with hardware problems anyway.

3 Likes

Yeah, for the latter codes, after the orange blink, you should really contact support. That part is not straightforward to interpret.

That should be 17 in hexadecimal. Might be an issue with initialization of video. But even if accurate, it’s not particularly useful, still need support to troubleshoot.

1 Like

Opps, just noticed. Seems you may have your code wrong?
It’s Blue=1, Green=0

1 Like

Right on, I had the numbers backwards, it’s 11101000, or 0xE8 it looks like.

I have contacted support, I don’t think there is any documentation on what these post codes mean?

Post codes are here: Framework Laptop port80 codes · GitHub

1 Like

And I find that list useless. It’s a bunch of defines that will eventually be used in code somewhere. Does each section represent 1 bit? Some sections have a large number of defines.

Is each section related to one bit?

My 11th Gen batch 1 has been perfectly useful and yet, I recently noticed that is has some blue flashes. BBGBBGGG if I have captured it correctly?

Should I be worried?

Correction, perhaps a little less useless, the hazards of doing everything on a phone means I didn’t see the document has a left - right scroll. Perhaps it is more valuable after all !

If that code translates to 0x27, it seems to a signal that boot devices were found.
The alternate, 0xd8, I don’t see in the list.

Just want to report back that support asked me to submit several photos and videos and then asked me to use an external HDMI connection to debug the display (which makes zero sense, as the display always worked fine), so I took matters into my own hands and replaced the SSD, which resolved the issue.

Everyone here should know that the Framework-supplied SSDs (at least some models of them) have known issues. I replaced it with a Samsung 970 Evo Plus that I bought locally and the laptop has been running perfectly since then (it runs 24/7 as my work laptop/server).

1 Like