Wi-Fi Suddenly Stopped Working

The Wifi on my computer stopped working from on second to the next tonight. For context, I’m running Ubuntu 22.04.1 and I verified that I have the 3.10 BIOS. I had issues with my wifi in the past which was resolved by disabling IPv6 and I just verified that it is still disabled. It still recognizes all of the available networks and if I select one it will say that it is connected to the selected network. However, the wireless icon does not appear in the upper right corner of the screen only the network symbol with three squares in a triangle shape with lines between them (I can post a pic if this description is to vague). I tried searching other topics a bit but didn’t find anything that helped. Any idea of what could be causing this and how to fix it?

1 Like

Did your system download a new kernel or something, or some other packages?

Maybe running into some wifi compatibility issue after these patches?:

1 Like

I don’t think anything had been downloaded just before the wifi stopped working, but I wouldn’t say it’s impossible. What’s the best way to check for the patches and get rid of them or fix them if they are there?



Does it came back when rebooting?

I have had trouble with it on Fedora 36 (booting from 256Gb expension card), on some boot I have wifi, on others not…

I have saved this link, to try the suggested fix, but haven’t have time to do so…
Arch bug intel AX210

Maybe you’ll have luck with it :crossed_fingers:

Hey @Cleber! Thanks for chiming in. Unfortunately, rebooting the computer does not solve the problem. Nor does toggling wifi and airplane mode off and on. But I’ll try out your link and see what happens!

@Second_Coming @Cleber I tried removing /lib/firmware/iwlwifi-ty-a0-gf-a0-6{6,7,8},71 from my computer as suggested by Cleber’s link, but the problem still seems to persist. The only other thing I can think is to try downloading the Linus Torvad’s patch referenced in Second_Coming’s link. Short of that, does anyone have any other suggestions? Is my next best bet to reach out to Framework support?

Just a quick update, I went ahead a reached out the Framework support and they suggested using a live USB of another Linux distro to try to isolate the issue. I tried with Fedora and the wifi was working perfectly fine there. So it seems the issue is with Ubuntu. I asked support how I should proceed. But while I wait for their response, I figured I’d see if anyone here has any suggestions too.

I received my framework on Friday and using Mint, I have the same wifi issues… intermittent. The weird thing is I can spin up the wifi tethering on my phone and it works fine, but won’t connect to my Unifi access points.

1 Like

@Raymond_Sundland oh that is weird. I can’t even connect that way. I’m still talking to support. If we finally find a solution, I’ll report back!

Got home from work… laptop not connecting to wifi… and then take the laptop out to the end of the yard, and with barely any signal, it connects immediately. It’s so weird.

1 Like

Ok, I am now convinced the issue is that the drivers can’t handle multiple APs sharing the same SSID in a mesh design. Right now, I can see my wireless network “WLAN” 3 times within the browser of a fresh Ubuntu installation (as opposed to Mint before).

I just had to re-enter the passphrase for this SSID although it’s already saved… I browse to the list of wireless networks and 3 WLAN entries in the table… i.e. each AP in the mesh.

Connection issues are probably, without researching how clients authenticate to a given AP, attempting to connect to one AP and SSID and doing some type of BSSID verification when doing that.

1 Like

So I tried reverting to an older kernel, but the only ones available to me are from 5.15 and from what I’ve read you have to go back to 5.13 to correct the issues with wifi. I also tried buying an adapter for a network cable hoping that with a wired connection I could update the kernel. But even with physical connection I can’t access the Internet. I thought I could download an update on another computer, load on a USB drive to install it on my laptop. But everything I found on that seemed to say I’d have to download from another computer running Ubuntu which I don’t have. I’m starting to feel like I’m running out of options. Does anyone have any other suggestions for me to finally fix this?

Grrrr mind’s stopped too. Ubuntu 22.04 It was working fine then just stopped after a resume. Rebooting, cold restart, suspend-resume nothing works, lots of kernel errors about Intel wifi. Tried 5.15.0-50 and 5.15.0-52 kernels

1 Like

@artfulrobot I feel your pain. Mine is still down as well. I tried doing an offline update using these instructions:

But apt-offline keeps giving me errors. So I’m not sure if it didn’t install properly or if I’m not using it properly.

Now I’m trying to back up my system using an app called Timeshift which supposedly backs up all your settings and applications:

If that works I’ll try reinstalling the OS.

Good luck on your end. And please post an update here if you find an workable solutions.

Well, don’t want to speak too soon, but my WiFi started working again…

Time shift sounds good but also sounds like you need a working system to start with?

I might try downloading an older kernel to try if it reoccurs.

Oh you’re so lucky @artfulrobot! I managed to update my kernel but still no wifi. I was trying to install an older kernel but haven’t had any luck with it yet. Do you happen to know how to do it?

Well I’ve learnt that 5.15 is basically the kenel for Ubuntu 22.04. So no 5.13 access easily.

However, I’ve done

sudo apt install linux-image-6.0.0-1006-oem linux-image-generic-hwe-22.04

as these seem to be the next one and the earliest one available in the ubuntu repos right now.

I’ve done this to see if it helps if the problem happens again. I’m afraid I’m not willing to try to make it happen again to find out!

PS. [edit] I did this by attaching a USB-C dock providing ethernet and plugged in.