WiFi stopped working on ubuntu 22.04


WiFi was working well for a few month with ubuntu 21.10 on my framework DIY.

Recently I made a clean install of ubuntu 22.04, At first WiFi was working well.
After a reboot or hibernate it stopped working.

I tried the post_install scripts from @lightrush without success

I also tried booting ubuntu 22 from a usb key and WiFi didn’t work there either.

Finally I tried to update my bios as mentioned here
It seems that it was already up to date (3.07), but the updater still installed something, and after a reboot the WiFi worked again, until next reboot / hibernate.

Can you help me understand and fix this situation ?


1 Like

You probably want to move this in the Linux category. Also post some logs. E.g. /var/log/dmesg, /var/log/syslog, /var/log/kern.log.

Thanks !

(It’s me who created an issue on your repo)

Unfortunately I chose to reinstall ubuntu 21.10 because I was also having issue with vagrant with ubuntu 22.04 :confused:

That’s cool, but you’d be in a similar position several months from now when 21.10 support ends. Alternatively you could also go 20.04 LTS which is supported till 2025. 20.04 LTS is essentially a problem-free affair. In any case, if you end up upgrading later and still have this problem, revive this thread.

1 Like

I’m having the same issue with my Wifi as well, after the same upgrade. The connection drops at random intervals while I’m working. Usually turning aeroplane mode on and off again fixes it, but occasionally this doesn’t work. Mostly posting this so I see further updates if they’re made, but happy to post logs etc. if that’s useful.

Have also added a similar post to another thread linked to here.

Perhaps check the following from the Arch Framework wiki

Intel Wi-Fi 6E AX210 reset/ low throughput / "Microcode SW error"

Under high stress, Wi-Fi device restarts and network speeds become abysmally slow or non-responsive until disconnecting and reconnecting to WiFi network.[9]

This issue has been observed by owners of other manufacturers’ laptops (not just framework). [10]

Disabling IEEE 802.11ax seems to be a suitable workaround for the time being. [11]

The fix (on Arch) being


options iwlwifi disable_11ax=Y

I had this implemented in the automated post-install setup but I dropped it upon upgrading to kernel 5.13 as I haven’t experienced any issues since then. If someone can confirm disabling ax resolves the problem indeed, I’d readd it.

The method for Arch should work on Ubuntu as well. Just run update-initramfs -u after adding the file and then reboot.

I upgraded to 22.04 again, and one more time the wifi stopped working after a few days.
After reseting the bios to default settings the wifi started working again \o/