Windows 11 2022 (22H2) Rollout

You should be able to download it from Microsoft here: [Link]. This can get you an ISO as well as run the upgrade assistant. If you run Setup from the ISO (not boot - run directly!), it should upgrade you to the most current version of Windows 11, 22H2.
I’m excited about tabbled File Explorer. But I want the Windows 10 Start Menu back.

1 Like

I hit check for updates and got offered it on my 12th gen. So far so good.

I’ve not had it offered yet on my i7-1260p but windows will ramp up the rollout percentage over the next few weeks.

Known issues are here
The below table may change if Microsoft discover any more issues…

Summary Originating update Status Last updated
Compatibility issues with Intel Smart Sound Technology drivers and Windows 11
Windows 11 devices with the affected Intel SST driver might receive an error with a blue screen. N/A Mitigated External 2022-09-22
17:40 PT
Copying files/shortcuts using Group Policy Preferences might not work as expected
Files or shortcuts might not copy or copy as zero-byte files when using Group Policy Preferences on client devices. N/A Confirmed 2022-09-22
16:49 PT
KB5012170 might fail to install and you might receive a 0x800f0922 error
Security update for Secure Boot DBX might fail to install. N/A Investigating 2022-09-20
10:06 PT

sit tight it will arrive eventually if it has not been offered yet!

Anyone tried the 22H2 already? Are there any known bugs? Do you recommend upgrading or waiting for a while?

My 11th gen Framework got the official 22H2 update over the weekend, not enough usage yet to really give an opinion but so far I have not had any issues doing regular things (email, streaming, gaming, remote to work etc.)

I just got 22H2 on my work desktop as well and one annoyance I didn’t notice on my laptop is that M$ took this opportunity (the update) to change a bunch of default applications to what they think the defaults should be and not what I previously set!

Upgraded on Saturday.
No major show-stoppers. In theory I like the window management features. I still don’t like the Start Menu. I haven’t tried the taskbar spillover features yet, but I will soon enough (it’s a Monday, but we’re also doing a major multi-department move, which means I’m doing less work-specific activity).
One barrier to upgrading was a generic “You’re not ready yet” prompt. I checked the panther logs and quickly figured out it was the print to PDF/XPS drivers and removed them, which fixed things up for me.
I also ran a data recovery on an SD card and found no problems with accessing the disk device directly. HWMonitor seems to work as expected. I also didn’t suspend bitlocker, and it seemed to behave without requiring the key, and the fingerprint reader also worked as expected.

One of the feature notes is better OneDrive integration, but I’m not sure what that means.

I don’t like how it handles switching power modes now; it seems you need to open the configuration panel item to do that. That might be annoying for power-conscious Framework owners.

1 Like

I think my laptop is having sleep issues after upgrading. I am not completely sure, but it seems to fully hibernate really quickly after being closed.

I checked the settings. I haven’t changed the power plan, and both closing the lid and pushing the button should put it in sleep, not shut down or hibernate.

This might be nothing. I don’t have time to really check it out, but I might be doing something differently (i.e. unplugging it before/after it goes to sleep). Might put this in its own thread.

Windows 11 Pro on 11th Gen Intel Core i7-1165G7 model. BIOS was v3.10 when Windows 11 Pro 22H2 was pushed via Windows Update.

After upgrading to 22H2 I started receiving the following error repeatedly – even with no USB devices plugged in. It would also show up when no expansion modules were inserted in the laptop. The left two expansion slots would also only work for charging – Windows wouldn’t recognize a USB device plugged into them.

I downgraded BIOS to v3.07 and all the USB power surge issues went away.


On my 1260P mainboard the 22H2 update required resulted in display problems and required a display driver reinstall. On my 1165G7 mainboard the update rolled back the WiFi Bluetooth and TrackPad Drivers, possibly more. I just reinstalled all drivers using the Framework driver package. It also wiped out all my custom power profiles.

1 Like

I just got it, I got the mid tier 11th gen mainboard with a gen4 SSD, no issues so far

1 Like

@REM thanks for this - I’ve had exactly the same issue. Can you let me know where you got the 3.07 BIOS package from? I need it as a temporary fix and can’t find it on the Framework website.

@bmhj I found the 3.07 download link on this page: BIOS 3.07 + Windows 10 and (11 Alpha) driver bundle

1 Like

The fix really should come from Framework’s BIOS update… (rollback is only a workaround at this point as v3.07 doesn’t have any security fixes from Insyde)

The 11th gen has been having USB port power issues since day 1.

Power-related issues are all over the place with this laptop.

@REM Thanks - that resolved it for me as well. I hope it might also restore the microphone to full working order - that hasn’t been working either.

@Second_Coming This is the first time I’ve encountered problems and I share the concern about the security fixes, but I can’t work properly without the expansion ports so a workaround it’ll have to be. It’d be great if my emails sent to Framework’s support address didn’t keep getting marked as spam and returned to me :face_with_symbols_over_mouth:

Consider yourself lucky.

Some early indicators of USB-C power related issues back in 2021:

Mind you, though, I’m not even sure if Windows 11 is sufficiently good / stable enough either. It seems to be having wake from sleep issue with 12th gen Framework laptops…

1 Like

Anecdotally, I exclusively hibernate my 11th Gen system, and have uptimes measured in weeks. That’s not write the same as sleep though.

Ok, so no one is hitting the BSOD like I am with Win11 22H2? If so, fix? I’m going to try backing the BIOS back down to 3.07 as recommended.

Downgraded to BIOS 3.07 and all is good. No more BSOD on Win11 22H2. Do we know why? or what in >3.07 is causing the issue?


Posted that too soon. Still getting BSOD with fresh install… No problem with Linux, so I don’t think it’s a hardware issue.