USB-A Yubikeys do not work in USB-A but works fine with a USB-A-to-USB-C dongle in a USB-C

I have two USB-A Yubikey Nanos that work fine in other machines. When trying to use one in either of my Framework’s USB-A modules, they simply do not work. Their LEDs will flicker briefly, but that’s it. No OTP generation, no recognition of them as a keyboard, nothing.

When I use either with a USB-A->USB-C dongle and plug into a Framework USB-C module, they work fine.

A search of the forums didn’t help. I’m using stock Ubuntu.

EDIT: Also tried full size USB-A Yubikeys and none of them work with the USB-A modules.

Is this a known issue? A search of the forums didn’t seem to return anything for me.


I’ve got several of the USBA sticks, and one of the Nano’s and it works fine for me in Fedora 34. I have my USBA port on the right front. The Nano does need to be inserted all the way in but it seems to be fine for me.

1 Like

Well this is just weird. I had my USB-A module in the left back. Pulled the whole module (not just the Yubikey) and put it in right front (replacing a USB-C module) and the thing worked.

Moved the module back to its original spot (left back) and it now works there, too.

I’ve been farting about with Yubikeys and modules this since last night before posting out of desperation. Have no clue what happened but it seems to be working now.


Cool. Sounds like perhaps the port just wasn’t inserted fully. Sometimes it’s good to run around the bus once. :slight_smile: Love my Yubikey’s and couldn’t live without them.


I truly am at a loss. I tried several different modules and slot combinations last night & today and only the USB-C keys or the A keys with the C dongle worked. It was only when I moved the USB-A module with the key in it that it stayed lit up and worked.
Whatever happened, it seems to be working now. Even in the other USB-A module.

In any case, thanks for your help!

1 Like