Windows 11 Touchpad doesn't disable while typing

Running Windows 11 current on all Windows Updates on 12th Gen Intel. I installed the driver pack Framework_Laptop_12th_Gen_Intel_Core_driver_bundle_W11_2022_07_26

The touchpad doesn’t disable when typing, and it’s maddening.

I have a dual boot with Ubuntu 22.04 LTS and there the touchpad work as expected! It turns off while I type.

From googling it seems like it’s Windows default behavior to disable the touchpad while typing but it’s not happening. The disable while mouse enabled does work.

Curious because I am running WIndows 11 on my 12th Gen as well and it works.

Do you know if you have the option to turn the cursor off while typing enabled? I know it is doesn’t seem relevant, I’m just curious.

Yeah I played with that, it was on when I initially looked at that but it doesn’t seem to make a difference on or off.

Does the mouse cursor disappear when you start typing?

Try reinstalling (from a fresh download) the driver bundle. If the trackpad driver isn’t properly installed, the laptop sees it as a PS/2 keyboard and mouse so it doesn’t disable the trackpad.

(Credit to DHowett for this answer I 100% stole it from him)


The mouse cursor doesn’t disappear and I can move it while typing

Tried reinstalling the drivers, same behavior

I didn’t realize there was a driver bundle we needed to seek out. Where do I download that from?

1 Like

Thank you!

What is your touchpad sensitivity set to?
(Same option for Windows 11)

Most sensitive completely disables palm rejection, aka not disabling the touchpad while typing!

Ok so when I initially played with it, before I posted this article, it was set to “Most Sensitive” and I now when I went back I saw I had left it at medium.
It’s on medium and still able to see and move cursor while typing

1 Like