Woke up to a dead laptop please help

I woke up to a dead laptop that wont even load the bios, the post code it gives is GGRGGGGGRRGG and after orange light its all green. Can you guys help?

Edit: missed the third red light

The ML 1220 CMOS battery, when fully charged only lasts about 3 weeks when fully charged and it requires a min of 1 hour a day of being plugged in.

There are many posts on this, if you can’t find I’ll look for a link.


You may have found this already, but in case you didn’t: it’s guide to interpreting the flashed code.

However, if the board is confused due to a depleted CMOS battery, I’m not sure the flashed codes are trustworthy.

At what point can we actually ask for a permanent fix / some kind of a recall? Can we even just start with asking if this question can be asked?

A fix of what? The OP’s issue doesn’t define a problem only notes one, that may be unique to their setup and use.

To whatever you seem to think is related in your first reply to this thread.

according to the post code, it appears that you have an issue with VCCIN_AUX, Fan Detection, and CPU reaching S0 state. I would recommend contacting support, so that they can help you if you are having hardware issues.


So, my laptop was working fine(it was having the bug where it needed to be plugged into power on, but I updated the firmware and BIOS and it seemed ok). It has been sitting in my bag for about a month, and now will not power on, nor will it charge(charger connects but no light comes on). I tried reseating the battery but that did not work. Has anyone had this issue to this extent?

EDIT: And yes, I made sure the charger works; it charges my tablet just fine.

What is this CMOS battery exactly for? To power the internal clock? Why does it last only 3 weeks? What does deplet that battery that fast? Can it be replaced?

Did you follow Fully Resetting the Mainboard State - Framework Guides completely? It asks you to disconnect BOTH the main battery and the CMOS coin cell and leave the board like that for a couple of minutes, to ensure a full reset.

If doing that solves your problem then: yes, other people have experienced this. If not, then you may have encountered an even worse problem/defect.

It’s to support RTC and CMOS

It does a lot more than keep the clock ‘on time’ that the RTC (Real Time Clock) which is not a part of CMOS. The CMOS keeps settings from the BIOS ‘alive’

As for replacing: It is rechargeable so it requires on average a hour a day plugged in. At 17mAh it can last 21 days so ensure a) you have it fully charged, so leave it plugged in for a day (17 hours +) and then ensure you use it plugged in for some 8 hours a week.

Just to clarify as @Nils indicates, the process can require a full reset. I had mentioned this in my original reply but asked that your post be moved here where the issue has been discused.

If you want more info on the ML 1220 you can read.

since this morning my laptop does not start (worked yesterday) even if I connect the charger (official Framework Charger). Neither the LED below the start button or the charging LED turns on so I am a bit out of ideas rn.

Picture of internals if it helps:

The usual method is to disconnect the battery plug and CMOS battery for a couple of seconds and then reconnect them. The charging light should start flashing red and then you can charge the laptop again. If this is 11th Gen of course. This is not supposed to be an issue with 12th Gen boards. That is, if it’s the issue of the CMOS battery drain.