11th Gen BIOS 3.07 + Windows 10 and (11 Alpha) driver bundle

I experience a similar thing on my Macbook when using Al Dente (an app to set a charging threshold). I suspect it’s just some sort of inaccuracy or rounding error. No big deal.

I’m curious about the specific differences between Windows 10 and Windows 11 driver bundles. I have been using the Windows 10 drivers with Windows 11 Pro without much issue. Only thing I would complain about is weird sleep/wake cycles. Specifically when the laptop is closed and sleeping, plugging in power wakes it up.

1 Like

I use BatteryBar Pro under Windows 10. I let my battery run down a bit and then put it on charge after setting 80% in the BIOS. The app is now stationary at 80.6% so rounding that makes 81%.

Also when monitoring lithium ion battery capacities it can be quite difficult to be accurate when the battery is between 20 and 80 percent charge because of how the voltage output works in them. Your system might be smart enough to follow it as it degrades or have manufacturing differences, it won’t be perfect.


Just updated to latest bios and Windows 11 Driver Bundle on Windows 11, touchpad is working in a limited capacity now. No longer can resize windows or move Windows around. I uninstalled the trackpad via device manager, rebooted and it’s working fine now.

I am attempting to update my bios using the method described in this post. I can boot into the PE environment and run the updater, however after prompting me to not unplug the computer it shows an error message “The BIOS image to be updated is invalid for Secure Flash or onboard BIOS does not support Secure Flash.”

I have re-enabled Secure Boot in an attempt to fix this issue, but it was unsuccessful.

I see that @Fraoch has encountered this issue before but I did not see a solution or an indication of later success.

Anyone know how to work around this issue?

Christmas must have come early by a couple of days! This is great for us desk-bound folk. Now to test the 0.39 Ghz issue to confirm it has also been fixed.

I do wish I could change the battery charge threshold within Windows without having to reboot in BIOS.


I’m working on this!

NOTE: This is not an official or sanctioned Framework project, etc. etc. disclaimers apply.


I just updated BIOS to 3.07 and then ran the driver update (Windows 10).

Now Bluetooth is disabled, it was running fine before the driver update.

There’s no Bluetooth icon in the notification tray, no on/off toggle in settings, no listing in Device Manager… any suggestions?

I would try loading the driver pack again or downloading the Intel Driver and Support Assistant. I use this to keep all of my Intel drivers up to date.

Tools and Utilities (intel.com)

Updated to the new bios and so far so good. Set my battery charge threshold to 80% so I’ll see how well that works. Would be nice to have the option to change it within Windows, but not an issue for me personally.

I’m using Windows 11 Pro

I’m using the Intel Driver and Support Assistant to keep those drivers up to date so I’ll hold on the driver bundle for now unless there is a need to. Ran the Windows 10 bundle when I got the laptop and didn’t have problems. Not sure if the Windows 11 bundle changes things or not.

I already tried reinstalling the driver pack, also tried the 10/29/2021 driver pack, and have the Intel Driver Assistant running. The system is still acting like there’s no Bluetooth adapter installed.

I noticed this in Device Manager, might that be the culprit? “Unknown USB Device (Device Descriptor Request Failed)”

Installed 3.07 and reinstalled Arch with KDE and battery life is either improved or more accurate.

+/- 6 hours with 84% left (Though I’m only updating the system now, so not exactly using it heavily at the moment)

Can this wizardry be used to poll and/or set things that relate or pertain to the keyboard, such as Capslock or, say, the fn lock status :wink:?

Installed, no issues!

Some notes, mostly related to Linux:

  • Windows installed its own bootloader again and locked out my Linux GRUB bootloader. Fixed easily enough, I just set boot order to “Last” then went into boot order and de-selected the Windows bootloader.
  • the Windows driver installation did not affect the fingerprint reader (duh - the Windows 10 driver bundle only contains a display update) so my fingerprint reader still works in Linux
  • I set the battery charging threshold to 80% and when I connect the charger with the battery at 100% there’s a blinking amber LED on the charging side. I presume this is normal, i.e. “battery is above charging threshold, I see the charger but will not charge”. OS indicates “fully charged, 100%” but does not show “charging”. Again, this seems like expected behaviour now.


I hope one day to update the firmware fully in Linux. :wink:


@Fraoch, Installed Win11 driver bundle and Bios… No know issues here either… POP! VM still works the same as before.

@pvp, did by any chance you have a dock or anything connected when you updated the drivers? Also, did you uninstall the Unknown USB from the device manager to see if it re-installs?

Just one thing that I think would be good to bring up: when I set a charge limit, it took me a while to figure out that I had to press enter and then type in a value instead of using F5/F6 to change the battery charge limit.

1 Like

No dock etc., just the stock USB-C power adapter.

I did uninstall the Unknown USB device, restarted, re-installed the drivers, in various combinations with no luck. Thanks for all the suggestions.

Good news is, I had the idea that my VPN software (Sonicwall and PIA) might be part of it, so I uninstalled that and Bluetooth reappeared again. I installed the current FW drivers and so far so good!

So it seems there may be some conflict between the software VPN network adapters that’s bugging out the Bluetooth? Mysterious…

Thank you for getting this into this version!

Now waiting (not so) patiently for this to land in lvfs-testing channel, as there is no way I am letting windows anywhere near my Framework!


Can you writeup exactly what you did, EC addresses, etc? I would love to make a script that would change this easily for us linux users, especially with a “one time charge to 100% now” action…