11th Gen BIOS 3.07 + Windows 10 and (11 Alpha) driver bundle

I already tried reinstalling the driver pack, also tried the 10/29/2021 driver pack, and have the Intel Driver Assistant running. The system is still acting like there’s no Bluetooth adapter installed.

I noticed this in Device Manager, might that be the culprit? “Unknown USB Device (Device Descriptor Request Failed)”

Installed 3.07 and reinstalled Arch with KDE and battery life is either improved or more accurate.

+/- 6 hours with 84% left (Though I’m only updating the system now, so not exactly using it heavily at the moment)

Can this wizardry be used to poll and/or set things that relate or pertain to the keyboard, such as Capslock or, say, the fn lock status :wink:?

Installed, no issues!

Some notes, mostly related to Linux:

  • Windows installed its own bootloader again and locked out my Linux GRUB bootloader. Fixed easily enough, I just set boot order to “Last” then went into boot order and de-selected the Windows bootloader.
  • the Windows driver installation did not affect the fingerprint reader (duh - the Windows 10 driver bundle only contains a display update) so my fingerprint reader still works in Linux
  • I set the battery charging threshold to 80% and when I connect the charger with the battery at 100% there’s a blinking amber LED on the charging side. I presume this is normal, i.e. “battery is above charging threshold, I see the charger but will not charge”. OS indicates “fully charged, 100%” but does not show “charging”. Again, this seems like expected behaviour now.


I hope one day to update the firmware fully in Linux. :wink:


@Fraoch, Installed Win11 driver bundle and Bios… No know issues here either… POP! VM still works the same as before.

@pvp, did by any chance you have a dock or anything connected when you updated the drivers? Also, did you uninstall the Unknown USB from the device manager to see if it re-installs?

Just one thing that I think would be good to bring up: when I set a charge limit, it took me a while to figure out that I had to press enter and then type in a value instead of using F5/F6 to change the battery charge limit.

1 Like

No dock etc., just the stock USB-C power adapter.

I did uninstall the Unknown USB device, restarted, re-installed the drivers, in various combinations with no luck. Thanks for all the suggestions.

Good news is, I had the idea that my VPN software (Sonicwall and PIA) might be part of it, so I uninstalled that and Bluetooth reappeared again. I installed the current FW drivers and so far so good!

So it seems there may be some conflict between the software VPN network adapters that’s bugging out the Bluetooth? Mysterious…

Thank you for getting this into this version!

Now waiting (not so) patiently for this to land in lvfs-testing channel, as there is no way I am letting windows anywhere near my Framework!


Can you writeup exactly what you did, EC addresses, etc? I would love to make a script that would change this easily for us linux users, especially with a “one time charge to 100% now” action…


Is it safe to jump BIOS versions, or would it be better to upgrade them one version up at a time? Also, where can I check my BIOS version? Is it the InsydeH20 version number?

Update: Yep, I figured out that it’s the InsydeH20 version number, and I currently have 3.02.

It doesn’t looks like it’s using the standard CrOS EC fan features.

Still looking into this.

Write-up pending! :slight_smile:


I know the Framework team is working all out just to keep up, but…

It appears that a significant portion of Framework users are running linux. If that’s the case, I would think making BIOS updates linux-friendly should be a relatively high priority, from a customer service and business standpoint.

Having to use an ugly Windows hack to replace the BIOS on a linux system is asking quite a bit from users. Especially when the shipped BIOS is problematic and requires updating.


@Richard_Tango-Lowy I’d argue that most people who use linux on a framework have bought the DIY edition and don’t mind hacking around a bit to make things work. Since most of them probably also had to install the wifi card themselves, i’d say they are quite patient as well. That being said, a (near) simultaneous push to lvfs-testing would be nice, I agree.


While I enjoyed assembling my laptop, it only took about 15 minutes. I run a business and use my computer for real work. Keeping it functioning normally (e.g., not breaking the battery) isn’t something I should need to deal with downloading another OS for. That’s why the linux community has fwupdate.

Not beating on the Framework folks here. Just pointing out that BIOS support is rather fundamental–it’s not like whether or not the fingerprint reader works.

So I installed the driver bundle and the new BIOS today. Both appear to be working great so far, only two things:

  1. It also wrecked GRUB for me, I couldn’t boot Gentoo after updating the firmware. Fortunately, the fix was super easy - all I had to do was grab a USB, mount my installation, and rerun grub-install and grub-mkconfig, and everything works perfectly again. For any other Linux users considering the update, just make sure you have access to a recovery medium when you update, or else you could potentially find yourself stranded.

  2. The light on the left side of the Framework changed in behavior. It used to be a steady white while the laptop was on, now it blinks red, on and off. I haven’t actually noticed any problems so far, but I thought it was worth mentioning anyway.


Install went fine for me, however whenever my bios gets updated it sets the boot order (in the bios) to auto, which always sets Windows to boot. I have to set the boot order to First or Last and then change the primary to be Linux so I can boot Linux or Windows via GRUB.

1 Like

We are in the process of publishing this through LVFS as well. We are doing some validation on the embargo channel and will release an update to the testing channel soon. We want to get this out as soon as possible.


I was never able to resolve this. I rewrote my Windows 10 install onto Ventoy, copying it over from a VM. I documented this:

Works fine this way.

I tried again, this time booting from an actual Windows installer and using Shift+F10 to get a command prompt window. I then ran the install from a separate flash drive. Unfortunately I still ran into this problem. Is there a BIOS setting I need to change in order for this installation to be possible?

I toggled Secure Boot to no effect. Maybe it has something to do with the presence/absense of the Windows boot loader but I’m not sure how its presence can be detected from within the OS.

The message seems to allude to UEFI capsule updates not allowed. Some BIOSes have a setting for this. Framework’s does not.

You seem to be on Linux. Sit tight, LVFS updates are coming soon.

1 Like

How large is your EFI partition? Do you know how much is available?

1 Like