11th Gen BIOS 3.09 Beta release

@Ricardo Based on my testing, your concern should not be a problem. As if the battery runs out, and power is attached then the system will charge.

I edited my original post, and mentioned that this is recoverable by unplugging AC when the system is off and then plugging it in again after 1 minute, and the system will commence charging again.

Why this recovery method works, is we fully power off the EC and other system power rails 1 minute after the system turns off when on battery, which resets some of the charging logic. So after this you can plug in AC, and the system will charge normally.

So this is pretty easy to recover from, and I do not see any behavior that would prevent the laptop from recovering from not charging.

@junaruga we will release a new version 3.10, so you will be able to update through LVFS, etc.

We are working on a fix for this today, but it will most likely take a few days to do validation, so I would not expect an update until next week.


All right! Thanks for that. As a future task, if we manage the bios version with “X.YY” (major, minor version), it is easy to run out until 3.99. The “X.YY.ZZ” or “X.YY-beta1” can be the solution.

1 Like

So this will only work if the battery is ‘dead’ ??

@amoun the workaround will work at any state of charge.

1 Like

Not even sure why minor version is zero-padded 2-digit to begin with…otherwise, we could go for 3.100 and beyond.

@junaruga bios version naming has to follow the SMBIOS bios information spec. Which allows for a major/minor release version of one byte each. We don’t want to break any standards with other versioning schemas. Systems like LVFS use this to determine what version the bios is using, and if it can be updated or now.
See page 31 of.


So we could go up to 255 then, if needed.

What does the major version of 3 signify though? e.g. Why didn’t we start with 1?

Just tried it. Works and is very cool. Thanks for letting me know.

1 Like

Successful update from 3.07 to 3.09 using fwupdmgr on EndeavourOS (arch) based. Machine ran VERY hot during the update itself. It was hot enough as to be uncomfortable to hold from underneath, and so I pointed the desk fan directly into the underside intake ports. This is probably something that should be addressed for future BIOS releases.

As expected, rEFInd bootloader was not available in BIOS boot order selections directly after the update. Using F3 key on a subsequent boot, I was able to navigate to and boot from my refind_x86.efi on my boot partition. Reran refind-install binary and everything was back to normal. The NVRAM erasure thing is an annoyance that I would also like to see addressed, but not a critical show stopper if you are prepared for it.

Secure boot, disk encryption, etc are not in use so nothing to report there.

Just realised this:
Windows → No instruction
Linux → Lengthy detailed instruction

I’m not sure which needs more work.


  • OK running on battery
  • Power down
  • Wait at least a minute
  • Plug in ‘mains’
  • Battery should charge


  • Battery doesn’t charge until I power up the laptop

Tried four times :frowning:


Yeah, last night I tried waiting a few minutes before putting it on the charger, and that didn’t help.


Unfortunately I can confirm what @amoun and @tim300 are reporting.

If I shutdown my i5 11th gen with 3.09 BIOS:

  • While charging, it continues charging after shutdown (slightly fewer amps but still north of 40W drawn from USB-PD source), but

  • With charging not in use at time of shutdown or interrupted after shutdown, normal speed charging will not resume at any point in time when re-inserted, on either side of the laptop

While “not charging”, the orange indicator light does light. However, my USB power meter says either 12V or 20V, but only .02 to .06A (approximately 1W) is drawn from known good USB-PD sources while the laptop is fully shutdown and charging was ever interrupted for ~4 sec or more.

UPDATE: the 1W does end up going into the battery. So it does charge while shutdown, just at 1/40th the speed of normal. Ugh.


I agree that the content can be improved.

As someone who was not familiar with what “EFI Shell” or “LVFS update” meant it took me a minute to understand that the Linux section describes two different ways of getting the update… and not one very long single procedure.

1 Like

Not sure if this is BIOS 3.09 related, but I noticed something strange with the power button LED today. I had left the laptop plugged in overnight in sleep mode with the lid closed, and when I opened it today, the power button LED was blinking as if the laptop were still in sleep mode. Everything worked completely normally, but even putting the laptop to sleep and resuming again didn’t change this. The LED only went back to normal after a full reboot, and I haven’t been able to reproduce this behavior since. This is not really an issue since the effect was purely cosmetic, but I thought I should mention it in case anyone else has this or it’s a regression with 3.09.

1 Like

it’s a BIOS update, it’s linux, and we’re talking about a one-year-old product. LVFS has been introduced and it’ll probably be stable soon and it will be “the recommended way”

Today it failed to charge while powered on with the lid closed in s2idle. It was around 60% when I put it on the charger, and 56% with the solid orange LED when I opened it up two hours later. I don’t know what to make of that.

My average power use has dropped by about 2W since I updated from 3.07 to 3.09. I have no idea why, but I’m not complaining. No issues with charging, though I usually hybrid-sleep, so haven’t tried charging the the laptop powered off.

Running Manjaro Linux with kernel 5.15.53 on an 11th Gen Batch 5.

This is ongoing. Now with the lid open, I’m seeing the system repeatedly switch back and forth between charging and discharging, stuck around 53%. Is this a coincidental hardware failure, or 3.09?

What if you rollback to 3.07? …assuming all your MOSFETs are doing OK…