11th Gen Intel Core BIOS 3.10 Release

All, I cannot prove that my current problem is BIOS 3.10 caused but I’m having trouble figuring out what else it might me.

No WiFi! My system appears to have rebooted at some point after the update. I am confident wifi was working after the update. However, now it is not. I reapplied the update, just to be sure, but that changed nothing.

Is there possibly driver update for wifi that is involved?

I know I’m not using actual data to say why I no longer have wifi, other than the fact of it. This is damned annoying and not a little inconvenient.

Thoughts (not prayers) or suggestions appreciated. Thanks

Um, followup: all fixed. No idea why the WiFi went out but a throwback memory led me to the Windows Device Manager which a) recognized the hardware but saw a problem and b) to my amazement seemed to successfully update the driver and that was that.

It is not every day that I can give MicroSquash a shoutout but today is one of those days.

1 Like

I have had a similar thing happen where, for totally unclear reasons, neither Linux nor Windows can see the Wifi module—and the problem resolves itself (again, for unclear reasons) after not too much time (maybe a couple restarts? I really have no idea…). This has only happened twice and I have no way of reproducing it so there hasn’t been much for me to report to anyone, but at least now I can at least add a “+1”.

Is there any indication that BIOS 3.10 addresses the slow battery discharge issue when the Framwork computer is powered down?

This is discussed in the release notes for 3.09, which this update supersedes: BIOS 3.09 Beta release

1 Like

Is anyone else having major issues getting fwupd to actually do anything?

I can’t seem to get mine to do anything useful. It’ll download an update, reboot into the fwupd splash, then reboot again to the OS, without actually having updated anything. No errors, but equally completely failing to be useful.

1 Like

@Crystalyne What fwupd command are you using? And what linux distro do you use?

Working command

sudo fwupdmgr update

Fedora 36 Workstation, with the command you said.

@Crystalyne Did you make this change?

DisableCapsuleUpdateOnDisk=true in /etc/fwupd/uefi_capsule.conf

1 Like

Yeah, that’s been set.

@Crystalyne If you are using stock fedora (gnome) you can try gnome-firmware.

Use it to verify the download and/or redownload. If it is verified you can try to upgrade through gnome-firmware.

1 Like

Hey folks, any idea on how to install the BIOS update if you don’t have a battery (e.g. Frameworks Creators program members)?

yep, that’s exactly what I tried to describe here.

This actually was the first thing I tried before giving up and going to Terminal. Unfortunately, same results.

Yup. Seems to be exactly the issue I’m having too.

@Crystalyne and @Jason_Hottelet - I apologize if I missed it, but how large is your EFI partition, and how much free space do you have in yet?

Mine’s 100MB, with ~50MB free. I did have to do some cleaning out of the EFI partition as LVFS stupidly doesn’t clean up after itself if an update fails.

Just followed the LVFS guide above on Linux (Fedora) and it worked great!

1 Like

629 MB — 577 MB free

Weirdly enough, the available BIOS update just showed up in GNOME software right after I used it to do the latest system updates (kernel, pipewire etc.). After hitting “install” from there instead of in the terminal as before, it worked and I am now on 3.10

5 Likes

No issues here, except fwupdmgr still sees my current BIOS version wrong and I had to pass --allow-older to get it to do the update: after having updated to 3.10 fwupdmgr get-devices now reports my current version as 784 (which is the decimal equivalent of 0x310, following the pattern I’ve been seeing).

This is just a vague annoyance but I am curious as to why it’s happening.