[SOLVED] Latest Bios Version via LVFS (Fedora 37)

I tried to update my bios using LVFS and I’m not sure if it worked (the main problem for me is I have a stand-alone mainboard with no battery attached). When I run: sudo dmidecode -s bios-version I get: 03.17, however the bios update screen said the update failed. I was wondering if someone could confirm what the latest bios version is. From the post here: https://knowledgebase.frame.work/en_us/framework-laptop-bios-releases-S1dMQt6F I thought the latests bios version was 3.10 . After running the update I noticed that WiFi does not show up, so I want to confirm I updated to the correct version.

Edit: WiFi is fine, I’m just an idiot. I didn’t notice that there is a bios setting to disable wifi/bluetooth and I had it disabled after the update.

3.17 is the beta, you can downgrade if you desire. I’d run the update again to ensure that everything went well if it registered as failed the first time.

1 Like

@GhostLegion Thanks for the info! I re-ran the update and it succeeded. The issue turned out to be the left PD controller wasn’t updated (since I has power plugged into the left side originally). Everything seems to be working fine now.


Delighted to hear this has been resolved.