12th Gen Intel Core BIOS 3.08 Release

12th Gen Intel Core BIOS 3.08 Release

Jan 9 2024

Please note that if you update to 3.06 or higher, you will not be able to downgrade to version lower than 3.06, as it will cause left side ports to stop functioning correctly.

You can check your current BIOS version following the steps here to determine if you are on the latest release.




Edit: 2024-05-01 - Updated link to 3.08b version which fixes an install issue on some batch 1 mainboards.

  1. Run the .msi.
  2. If prompted to trust the Framework driver signature, click agree.
  3. Click yes to reboot.
  4. Wait for all 3 firmware progress bars to complete as the installer will install 1 or 3 different firmware updates and then reboot into Windows.


Please note that for this platform LVFS will not update the CSME firmware. so we only recommend updating using the EFI updater. This is a limitation of LVFS which does not ship the binary blobs from Intel necessary to update the CSME.

Linux/Other/UEFI Shell update

We have released a new version of the EFI shell update which we consider Alpha until we get additional community feedback, It is linked in 12th Gen Intel Core BIOS 3.08 Release - #371 by Kieran_Levin

Note that if you use the EFI shell update with Windows, you should suspend Bitlocker if enabled before updating using the EFI updater.

Instructions for EFI shell update:

  1. Extract contents of zip folder to a FAT32 formatted USB drive. Cleanly unmount the drive before physically removing it, otherwise the BIOS update may not function correctly.
  2. Disable secure boot in BIOS.
  3. Boot your system while pressing F12 and boot from the thumb drive.
  4. Let startup.nsh run automatically.
  5. Follow the instructions to install the update.

Updating a Mainboard outside of a laptop

This release supports standalone updates without a battery attached only when updating using the EFI shell method only.

Security Fixes

CVE Note
CVE-2023-40238 LogoFAIL
CVE-2023-22612 SMM Memory Corruption
CVE-2023-22615 SMM Arbitrary Code Execution
CVE-2023-22614 SMM Memory Corruption


  1. Add EC host command to check privacy switch status
  2. Add support for new high capacity 61Wh battery
  3. Update PD firmware to version v0.1.2C
  4. Update Intel CSME firmware to
  5. Update Intel Microcode to m_80_906a3_00000429
  6. Optimize PS2 emulation of touchpad (hybrid HID descriptor)
  7. Adjust power button behavior so the system will be powered off within 10 seconds of holding the power button.


  1. Standalone mode installation.
  2. Adjust critical temperature thresholds to allow the laptop to power on at higher ambient temperatures.
  3. Remove critical battery shutdown when adapter is attached. This will allow the system to power on when the battery is below 2% and charging.
  4. Fix: Plugging in a USB-A device multiple times would eventually not be recognized anymore
  5. Fix: Sometimes a USB-C device would not reconnect after reboot
  6. Optimize Windows Firmware Update process to prevent retimer23 FW upgrade fail in multi firmware update.
  7. Fix OCP (Overcurrent Protection) on Type-C ports not triggering in some cases
  8. Reduce power consumption when DisplayPort/HDMI Expansion cards are used
  9. Improve Type-C port status reporting via UCSI
  10. Fix: Reading charge limit overwrites charge limit. Fixed by Dustin Howett: Avoid resetting charge_max_level during CHG_LIMIT_GET_LIMIT by DHowett · Pull Request #7 · FrameworkComputer/EmbeddedController · GitHub
  11. Fix EC failing to boot when compiled with GCC11. This was only seen by users who compile their own EC. As our previous binary releases did not use that compiler.
    Fixed by Dustin Howett: mchp: Remove undefined behavior in espi msvw handlers by DHowett · Pull Request #22 · FrameworkComputer/EmbeddedController · GitHub
  12. Add ACPI Mutext method in UCSI message in/out process
  13. Fix race-condition that would cause EC to get stuck in rare circumstances (LFW WDT)

Component Versions

This BIOS update is a bundle of updates to multiple embedded components in the system.

Not all of them use the same version number.

BIOS 3.08 3.06
SI c.0.75.10 c.0.66.71 Updated
TXT Updated
Intel CSME Updated
Microcode 4.29 4.1d Updated
GOP 21.0.1061 21.0.1046 Same
EC 4ea1c89 Varies Updated
PD 0.1.2C 0.1.21 Updated

Known Issues



All the Windows installer will tell me is “The installer can only be run on Framework Laptop 12 Gen Intel Core Mainboards”.

I have a Batch 1 1260p board, running the 3.06 Beta. Are you filtering sth. wrong out? Or is your detection stumbling across some Windows isolation feature?

1 Like

Can you share your “system information” summary page?


1 Like

Sure. You mean the MSInfo screen?

(Edit: changed image to one with wider columns so it does not cut off the lines)

@Kieran_Levin Fyi, running the updates manually works (unpacking the msi, executing ME update from within Windows, installing .inf firmware updates and rebooting.) All versions seem on what they are supposed to be


Updated through the EFI shell, everything went fine.
Thanks for the update.


Thank you! I just updated from Windows and so far everything looks good. It did take a bit longer to apply the update than I was expecting, but no errors encountered.


Updated on Linux Fedora 39. No problems once I enabled boot from USB in the BIOS :slight_smile:


The update failed at the first attempt. There was a redirection error in the middle of the update. The usb c ports were not functioning, so the update refused to continue. Had to remove the ssd to make the ports work again, then the update continued.

Had the same issue with the 3.06 update. Yes the drive was definitely cleanly unmounted before attempting the upgrade. These laptops are definitely not the easiest.

1 Like

Thank you for the release! It’s also great to see contributions from Dustin Howett, outside of the company Framework!


Knowing what model drive you are using might be a helpful piece of information.


Currently ADATA SX8200PNP 1TB, during 3.06 upgrade last time it had a Kingston FURY Renegade 1TB.


Thank you!

Looks like the update did work here, i7-1280p.
At least, at some point the laptop bootet to Windows again.

I didn’t see anything because the lid was closed and there was nothing displayed on the external monitors.
So can’t report more than: It works.


Updated from stock 3.04(?) BIOS. Got a gnarly surprise. I was using a rear port to charge the system, and somewhere after about 4 items being flashed it gave me a message about not being able to redirect a file and a script error on line 116.

The system would not charge from the rear left port at that point, and trying to boot the flash drive again left me with a ‘CONNECT YOUR CHARGER’ message. I moved the USB-C adapter up front and charged from there. After booting off of my USB drive again and maybe 3 or 4 reboots, the system finally completed the process, 5 out of 5 steps. I shut the system down, moved the ports back where I had them, and then booted normally. The operating system (Fedora) reported that the laptop was charging again from the back left port, and at this point everything seems to be normal-ish.

So, if you get a weird message like that, don’t panic. Move your ports up front and try again.

Thank you for the update and the clear instructions! Just successfully ran the EFI shell update (Fedora 39 user updating from 3.06 bios) with no immediate issues.

I just tried plugging and unplugging a USB-A thumb drive several times both mounted and unmounted and it was recognized every time! This used to reliably cause an issue that I would remedy by removing and reinstalling the USB-A expansion module.

HDMI and DisplayPort behavior is still weird but appears to be improved. I have earlier versions of both cards and they’re both behaving better according to powertop. It still seems to change depending on which side I plug them in, seeming to prefer the side opposite the power button, but overall draw seems lower at first glance even with the older cards.


Thanks for this! I was still on 3.04 as well and I was getting the same error but on line 97 during my installation and I’m still trying to get it to work. Did you have any issues with none of your ports accepting power? I’m going to keep trying swapping ports around but I think something got screwed up during one of my attempts.


Unplugging the SSD as @Username009 suggested seemed to fix the issue along with moving the power adapter around. I have a Crucial CT500P2SSD8 SSD.

1 Like

I had the same issue. Whatever the first firmware that was pushed did, it appeared to cause my ports to stop working. I powered off, removed my ports, waited about 30 sec, reinstalled my ports and tried again. The update resumed at the second firmware and completed without issue.

I also had the same issue, that the update failed. I think it was on line 116. I had the stock 3.05 installed.

My device is an i5-1240P with 32 GB 3200 MHz ram and a Samsung SSD 980 PRO 1TB.

The hint from @Username009 to remove the ssd worked, I think. But I also removed the ram, battery, cmos battery and ram, to restore the ability to charge the laptop again. Normal usage of the ports, like the USB and headphone jack extension cards were not affected by the broken update. The possible reason why this “fixed” this issue can be seen on my second edit of this post.

Although this is a beta release things like this should not happen and a “normal” user might think that this bricked their laptop.

Before the update I reset the UEFI to the default configuration. This is something I always do before UEFI updates.

It looks like the reason for the “CONNECT YOUR CHARGER” warning after the failed update was that the laptop is charged to 100%. The laptop disables charging if the laptops battery is fully charged. So it cannot detect if there is a charger connected and thereby this warning gets displayed. By turning it off and removing the battery etc. It dropped to below 100% and enabled the charging again. I think @Kieran_Levin should add a notice to the thread that the laptop should not be fully charged if you try to update the UEFI. I think it should be started with a charging state of around 90% to prevent this issue from happening.


Had the same problem. I just unplugged my external displays.

Thanks for the MSInfo screen, this narrowed down the issue.
Can you try updating with the following and see if it fixes your issue?