12th Gen Intel Core BIOS 3.06 Beta

It took 6(!!!) reboots for me until it was done.

1 Like

I had issues with updating Retimer firmware possibly related to self encrypting SSD (SED/OPAL with PBA).

Steps:

  • started update using LVFS (Linux) + reboot
  • first updates/reboots went fine (BIOS,PD, …)

Retimer Update failed with “Create directory failed!” + Rust panic

Afterwards left USB ports on both sides stopped working!

Screenshot of error:

I tried to update multiple times using LVFS and also USB flash drive method. Retimer update always failed, left ports stayed disfunctional and fwupdmgr continued to offer retimer update.

Fix/workaround: I removed the NVME drive and did the update again using USB flash drive method - this time it worked first try and left usb ports started to work again.

I think that maybe retimer update somehow tries to read partition table of the internal SSD which fails because the drive is not unlocked (OPAL PBA / pre boot authorization).

But if that assumption is correct, I think this should be considered a bug. Don’t think the firmware update process should be influenced by the configuration of the nvme drive.

6 Likes

3.05 was a lot nicer to my battery

After attempting fwupdmgr I bit the bullet and did the USB method as the retimer didn’t update. I got up to 100% charge during the update, maybe the uefi version of fwupd has the same bug where you need to be plugged in and charging… who knows.

Anyhow, I was able to get my system down to < 5 W and < 100J draw reported by powertop before, now I’m seeing around double that. Maybe it idle’s down to 8.x W / 160J draw sometimes. This is on a 64Gig / 4TB / i1280P host with every power setting I can find, including esif_ufd and a custom minimized kernel. I’m going to boot Windows up and try resetting whatever else I can. If there’s any suggestions I’m all ear’s. I really like’d the nearly 10hours battery life I was able to get when fully tuned, perhaps barely 4.5 now. :frowning:

It seems the thunderbolt NHI devices are now in the mix from what powertop indicate’s for devices drawing power, even when not plugged into anything.

From what I can tell, the

3 Likes

Just here to confirm what @Ktwo mentioned: 3.05 indeed seems to be nicer on battery.
From what I can see in powertop (linux, kernel 6.0.9) this is mostly due to the processor almost never reaching C10 state anymore. (On 3.05 I managed to get the system down to about 3,5-4,5 W, now it is 6,5W)
On 3.05 I saw the CPU staying in C10 for about 80-95% of the time when the machine was sitting Idle with just powertop open (in a terminal window on an Ubuntu Gnome desktop and de-selecting the window to stop the cursor from blinking). On 3.06 it only shows C10 for about 3-8% of the time, instead the CPU now spends the majority of its time in C2.

The HDMI card does seem to play nicer; on 3.05 it added about 1W of power draw as soon as I inserted it, now it seems to add a lot less, but how much is harder to tell due to the higher draw of the CPU.

@Ktwo @Hans_van_Schoot very interesting, I am actually seeing an improvement. Using Fedora 37 Gnome, 64GB RAM, SK Hynix P41 2TB Nvme, I was previously lucky to get down to 5.3w or so, it was usually sitting at 5.8w. Now with the new BIOS I am getting down to 3.53w after 1 minute using only Powertop, with Firefox, Evolution, and Powertop running it settles down to 4.54w - 4.83w. I am definitely hitting C10. I use tlp for power optimizatrion, and thermald with dptfxtract for thermal optimization. My tlp conf is fairly straight forward as regards battery power, turboboost is off no other tweaks. I generally run with bluetooth off as well, with wifi on. This is the state for the above power draws. Overall I am seeing it reach C10 quicker as well, and this looks like a 0.8w on average improvement for me. I should also add I am using all usb-c expansion cards.

2 Likes

Happy to report that I am on 3.06 with Ubuntu. I used LVFS and what Kieren said here about making sure the drive is properly unmounted seemed to factor in.

It wasn’t and I lost the ability to charge the battery until the battery died and the system reset. After that I was able to update, and, yes, it took a lot of reboots.

All good though and I am grateful to Framework for taking care of the folks not running Windows as well as the Windows folks.

Great job and thank you!

@nadb interesting, and good to know that the bios update should not be to blame here then. Are you running kernel 6.0.7 ? (checked what Fedora 37 should be using on distrowatch). My 6.0.9 is from the ubuntu mainline reo, but I’m seeing the same behaviour on the 5.17.X OEM kernel in Ubuntu.
My Framework is rocking a 1260P, with 2x16GB RAM and a 1TB Samsung PM9A1 SSD. Currently running with only 2x USB-C, although adding the USB-A and HDMI does not seem to add much with the new bios. My TLP config is almost fully default, and I’m also using thermald, but did not have dptfxtract installed.

Whoop whoop! thank you for the hint! after installing dpftxtract, I’m back in C10 for about 55-75% of the time, and C8 for another 10-25%. This drops power usage back to 3-4 W
Adding the USB-A card back into the laptop adds about 0,25-0,35 W draw from the battery, the HDMI card adds about 0,15 W (sampling times of about 1 or 2 minutes, so not high precision data!)

1 Like

@Hans_van_Schoot I am actually on kernel 6.0.15 right now. My machine is also an i7-1260p. Happy to see that your power usage has dropped into comparable ranges. I am actually excited to do an extended battery usage test this weekend to see what my new average is. Previously I was getting 8.5-10 hours with my usual browser, mail client, music player, and terminal (or multiple terminals) workload. My guess is I will see something closer to the upper end of that range now.

fwupdmgr seems to have successfully updated the BIOS. But the update for Retimer23 does not seems to fail. Running fwupdmgr update does the reboot, boots into framework firmware updater for a second (shows the Framework logo and fwupdmgr efi version at the top left) but the laptop immediately shuts down afterwards.

fwupdmgr get-history currently shows this in the corresponding firmware update stanza:

Update Error: failed to run update on reboot

Not entirely sure what to do about this…

I don’t have secure boot enabled either.

overall not too bad using the Linux EFI shell method to update. a bit of feedback on my experience as it wasn’t the smoothest:

first flash attempt is similar to another user:

line 97 for me.

I’ve 3x USB-C & HDMI modules. HDMI in lower left, and USBC in the others. I used the lower right USBC for first flash.
retried, same line97 issue, moved to upper right USBC module; no change.
I did this exact same process the first time to prep the USB stick: i wiped the existing USB drive, reformat with fat32, copied the required files & unmounted. I shutdown laptop (rather than reboot i did first attempt). USB stick still in the upper right port, the flash sucessfully completed.

I’m now on 3.06.

After the update, my USBC dock was only passing PD. USB & display was inactive but simply re-plugging the dock cable into laptop got things fully working again (upper left port if it matters).

final thought: while i will use LVFS in the future, could there be a dedicated tag/sub-forum that we could subscribe to for UEFI updates (and thus email notifications!)? i mearly stumbled on this 12gen 3.06 release thread via a reddit thread last night so i’m a week late to the party :slight_smile:

Well this is a beta. I’m not sure broadcasting it makes much sense, in that there could be bugs, etc.

I had the same error as you. It was because of the mounting issues Kieran mentioned in his response above.

I know for me personally, I’m sticking to the LVFS method.

Seeing similar issues reported by @Swop , @Ray519, and others. Steps followed:

  1. Ran MSI installer
  2. Reboot
  3. Realize after 30sec or so that my fans are roaring and nothing is on the external monitor:
  • opened the lid
  • First progress bar was at 95% or so, then
  • the laptop rebooted twice in fairly quick succession, first showing a mostly (~60%) completed progress bar, then reboot, then just flashing up another blank (no green) progress bar before rebooting back into windows

After the update, I received the error message that the 23 retimer still needed to be updated, needed another reboot. I rebooted, but no effect, just saw the blank progress bar flash up then back into windows.

I see errors in Device Manager:
image

Properties dialog shows the same Code 10 error that @Swop reported.

  1. I then re-ran the update msi, which proceeded to reboot, but just flashes the incomplete (no green) progress bar up on the screen then immediately reboots back into windows again.
  2. Ran the EFI update, which was made more complex by the USB drive not being recognized as a bootable device in the right-front port. Once I swapped the modules, it was recognized in the right-rear port.
  3. EFI update appeared to run fully, but still seeing the above errors in device manager.

Another oddity: the USB-C module that power was plugged into during the first flashing process seems to be borked. That module specifically will not allow charging (no light when power is connected). Behaviour is the module, not the port, as a different module in the same port works fine, and that module does not show a power light in any port. The module still recognizes connected peripherals but won’t allow charging.

Update: forgot to mention that I tried both the 30-second power button hold and the shutdown-unplug-2mins-then-reboot tips, but no changes.

2 Likes

Just upgraded using fwupd without a hitch (aside from some USB weirdness which went away after a reboot). Noticed some output that I haven’t seen before which bypasses my systemd.show_status=0 kernel parameter since I prefer a “silent” boot:

Driver "idxd" was unable to register with bus_type "dsa" because the bus was not initialized.

^ may be related to using the linux-clear kernel but has not shown up since the firmware upgrade

and

tpm tpm0: [Firmware Bug]: TPM interrupt not working, polling instead.

These don’t seem to be critical at all, just throwing it out there to see if there are any known solutions. I don’t use TPM but was thinking about implementing Secure Boot and TPM2-TOTP with signed images… does this mean it is currently borked?

These may just be kernel issues, but are new to me post-3.06 update.

I had the same error at Line 97 when I tried. Did a full cfdisk/mkfs.fat and rewriting the files but that didn’t help.

I ended up switching to LVFS to do the upgrade using the config changes @Kieran_Levin listed, which was mostly successful. For some reason like @Fraoch I have the same issue with it wanting to update “UEFI Device Firmware (207 → 310)” again…

When I run fwupdmgr get-updates this is the status info:

Devices with no available firmware updates: 
 • PCIe SSD
 • 0000:00:1f.5
 • Fingerprint Sensor
Devices with the latest available firmware version:
 • System Firmware
 • UEFI Device Firmware
 • UEFI dbx
________________________________________________

Devices that were not updated correctly:

 • UEFI Device Firmware (207 → 310)

Devices that have been updated successfully:

 • System Firmware (0.0.3.4 → 0.0.3.6)
 • UEFI Device Firmware (207 → 310)
 • UEFI dbx (33 → 217)

(I submitted an uploaded report w/ full details via fwupdmgr, so hopefully that helps…)

I’m not a fwupdmgr super-user, but I installed GNOME Firmware to double check and It appears that I have two “Framework UEFI Device Firmware” items, one that is GUID a9c91b0c-c0b8-463d-a7da-a5d6ec646333 and is listed as v310 now and was successful, and one that is GUID ba2e4e6e-3b0c-4f25-8a59-4c553fc86ea2 that is v207 and still needs to be upgrade (is this each side?)

I have 1 x USB-C and 1 x USB-A on each side, and I had my AC plugged in on the left side, so maybe I’ll flip it and try to update again and see if that helps…

UPDATE: yep, flipping the USB-C power onto the other side seems to have been the issue. Now both sides are showing v310.

5 Likes

Hi @lhl, I took a quick look, I do see two separate eateries for UEFI Device Firmware with the GUID’s listed. For me both are on version 310. Like I mentioned earlier in the thread, I had no issue doing the update a second time for one of these devices.
No clue why they both weren’t updated at the same time, would love to get some insight on it.

2 Likes

I had no problems upgrading from 3.05 to 3.06 using the EFI image on a microSD (and rebooting the required 5 or 6 times).

All is working well (Linux).

The only (important) detail, is that one should not use the F3 menu to choose the boot method: it seems to work but it ends up throwing an error. Instead, the F12 menu is the right solution! By using F12, no error.

2 Likes

The computer I bought in 2023 will come with the new bios?

1 Like

the installation was successful, but with problems. Here is my history:

  • The installation was successful. However, I also had the faulty device (retimer) in the device manager
    o Hard turn off the device (power button longer than 30 seconds) demonstrated the installation at the next start and climbed the error.

  • Now, no display on the USB-C or HDMI port worked anymore.
    o In the BIOS I selected “Battery disconnect” and left the device without power supply for a few hours. In this state, the device cannot be turned on.
    o At the next start my external display also worked again.

1 Like

I got the same error


This device cannot start. (Code 10)

Indicates a revision number encountered or specified is not one known by the service. It may be a more recent revision than the service is aware of.


Firmware failed to update during the last attempt.

Last Attempt Version: 136
Last Attempt Date: 3/1/2023 21:39:06
Last Attempt Status: 0xC0000058

I also use the Lenovo Thunderbolt 3 Graphics Dock as my TB3 device, left Type-C port is not function. Right Type-C port can charge but no any other functions (No USB, Ethernet, GPU…)

2 Likes

Update:
I created the UEFI Shell USB drive. Poweroff the laptop for somewhile. Unplugged my SSD so it run and boot only from the USB drive.
After the automated update installation, then poewroff and plugged my SSD again.
First boot: TB3 dock can partially functions on both left and right Type-C ports. (Can charge, Ethernet works. eGPU not fully work.)
Second boot: Everything works completely fine.

2 Likes