12th Gen Intel Core BIOS 3.06 Beta

Tried the windows installer, timers updated just fine however upon checking the main BIOS, the firmware was not able to start. Waited until all installers finished, restarted twice, but the main BIOS failed to update from 3.04 to 3.06. Tried to roll back firmware, but unsuccessful. Firmware in BIOS shows 3.04. Any tips on how to roll back to 3.04? Right side ports only support USB 2.0 as mentioned in notes? Would a clean windows re-install take me back to 3.04?


Update: I reset windows and kept my apps. Upon startup, I went to device manager, then firmware, then clicked on the 12th Gen BIOS option below the timers with a hazard icon. It then proceeded to allow to me to restart my computer, where 3.06 was successfully installed.

1 Like

So, a report on USB-A funkiness from using the 3.06 beta BIOS - my USB-A ports seem to be a bit finicky now (I’ve had this happen with a mouse receiver and a hardware key) on both sides of the laptop (2 different USB-A expansion modules). After suspend/resume (S0ix), the USB-A port will not detect anything plugged in until I pop the expansion card out and reseat it (and then it works as normal).

I am running on Arch Linux (6.1.2-arch1-1) and I’ve had this issue on both sides and am running the updated v310 firmware for the retimer (ba2e4e6e-3b0c-4f25-8a59-4c553fc86ea2 and a9c91b0c-c0b8-463d-a7da-a5d6ec646333 on 310).


Windows install worked as described in the instructions. USB-C ports (both sides) not recognizing TB4 USB hub (Intpw Model: ID558). The laptop will not boot up with the hub connected. once it does and the hub connected, DP works but is reported as not compatible. RJ45 not connecting to router and any USB devices do not connect. Funny that the DP port would work and the rest would not?
Unit will not go to sleep.

1 Like

I initially used the fwupd method, and an initial reboot did happen and perform at least some of the update - BIOS, one of the retimers, maybe more. But on checking fwupd afterwards, an error report was sent and one of the retimers just wouldn’t update - I was repeatedly prompted, but no amount of switching power between ports or swapping USB-C modules around helped.

I used the USB EFI in the end and that was a flawless experience.

1 Like

I had nearly the same experience as @Dan_Walker;

  • lvfs method failed (repeatedly) on Retimer23, other components seem to have upgraded fine.
  • USB UEFI shell way reported all OK after a number of reboots, as expected
  • but fwupdmgr update still wanted to Upgrade UEFI Device Firmware from 207 to 310?
  • power off, remove AC, wait 2 minutes; that finally made it work.

(repeatedly == multiple runs of fwupdmgr update and the associated reboots. I did try both with secboot on and off, at least twice each, I did do the 30 seconds powerswitch dance during two of the tries, I did try with new boot device priority auto and first)

I’ve updated both the WD nvme and the BIOS firmware to it’s latest versions.

$ sudo dmidecode -s bios-version
$ cat /sys/class/nvme/nvme0/firmware_rev

Edit: I’m running the kernel:

$ uname -rmo
6.1.3_1 x86_64 GNU/Linux

I also have the following inside my /etc/default/grub:

GRUB_CMDLINE_LINUX_DEFAULT="loglevel=4 pcie_aspm=off nvme_core.default_ps_max_latency_us=0 nvme.noacpi=1 mem_sleep_default=deep"

Let’s see if something changes on the random disconnects of my nvme on (means: not available after) suspend.

So far, my NVME did disconnect randomly under no load whatsoever 3 times, luckily no fs corruption yet.

Until this problem is solved I cannot move my private workplace to the framework laptop.

1 Like

I have discovered that the powering the Laptop utilizing the PD port on the Hub was the culprit. Powering the Laptop from the left side USB-C port and having the Hub use the right side port fixed the issues with the Hub. The laptop will not sleep while the DP (on the Hub) is active, does otherwise.

1 Like

The update via USB stick worked for me, from 3.0.5 to 3.0.6, 12th Gen, Fedora 36 w/6.0.18 kernel. I haven’t tested the battery, as I’m almost always plugged into a powered dock.

1 Like

Finally got around to this!

Thanks for this, I did this and it worked perfectly. Well it rebooted twice and the second time the Framework logo screen stayed up for a very long time with nothing else being shown, but when it rebooted after that all was normal.

Verified with GNOME Firmware (very nice BTW) that both “Framework UEFI Device Firmware/UEFI ESRT device” entries showed 310 and had unique UUIDs, along with “Framework System Firmware” at and “UEFI dbx” at 267.

All done.

1 Like

I got a boot loop after trying to update from windows.

My internal hd only has linux on it, and I boot windows (10) from a Framework 1T usbc module.

I booted into windows, downloaded and started the update. It rebooted into the updater with the green progress bar.

Now that’s all it does is reboot to that same green progress bar over and over forever. It appears to be actually running the update each time. It takes about a minute to run each time and gives no error messages or any indication that anything might be wrong. But when it restarts at the end, it just reruns the same thing again.

It seems to be ignoring the bios boot order and the F12 key menu selection. No matter what I select for boot order in the bios, or at the F12 menu, it still always boots to that installer if the usbc drive is plugged in. I haven’t tried every possible combination of options in the bios yet like disabling a device vs just changing the order. I have to eject the usbc module to get the machine to boot from the nvme.

Along the way, at least the F12 key no longer hangs the machine!

But when I do get it to boot from the nvme it boots normally (into linux).

I also tried powering all the way off, not just letting it warm restart itself.

If I put the usbc drive mback in and boot from it, in all cases when trying to boot from the usbc, all it does is run that “please wait while we install a system update”.

I also just tried running the battery down to 80% and booting from the usbc again. No change. I let it boot loop itself for about 6 loops just in case that bit about 3 consecutive progressbars meant to expect 3 of these loops.

So it seems to have borked the bootloader on the usbc drive to run itself at boot, and then failed to unbork it when done.

Any thoughts on a failed efi upgrade Frame.Work Failed bios update with blink code - YouTube.
Looks like the blink code is for no battery or trackpad.

Installed on mine through the Windows MSI updater and am seeing the same issues with Retimers23 as others. The left rear port works for charging but not for Thunderbolt, the left front port does not work at all, right side ports appear to be fine.

Tried the 2 minutes power off and 30 second power button hold-down and neither one appeared to resolve the problem with Retimers23. At some point the message in Device Manager changed from “your computer needs to restart to install the update” to “the device cannot start” and it no longer offers me a reboot prompt. Not sure if I should uninstall and reinstall the updater package to try to get it to go again or not.

UPDATE: I uninstalled the errored Retimers 23 device, reinstalled the MSI, rebooted, and this time the firmware update took. Computers!


Ran the install Msi on Windows 11 Pro,

Restarted and had the 23 time error.
restarted again and it went away.

HDMI module and usb c/thunderbolt no work to my dock until i did the 2 minute power off with the battery disabled. That enabled hdmi and thunderbolt

BUT i still am unable to get video over usb c to monitor (27UP850N-W)
have tested 3 cables and all the same response (charge, and make laptop reads something plugged in… but don’t broadcast video) and for giggles i tried the 3 cables in my work laptop (14 inch m1 pro macbook) and all three broadcast video

i have just performed the update using LVFS testing, on Debian bookworm, and it worked without a flaw. it cycled through the BIOS two or three times, but was otherwise mostly automated. I am hoping to do more power usage testing now to see if it improved on my previous results…


Just an addendum,

left computer off for 2 days (had to go into office yesterday)
Module setup-
Back Left- USB C
Front Left - USB C
Back Right - HDMI
Front Right - Usb A

This now seems to work…
the front left didnt work but a replug did it…not sure wht cvhanegd maybe the battery drain did it.

Will keep an eye but figured I owed an update

I did an update on ubuntu via fwupdmgr and it worked.

There were lots of warnings that I can’t downgrade ore the left side USB ports won’t support anything fast (like a display, Thuderbold etc).
However the end result is with the new version the left side USB C ports only support slow USB speeds but no connected display or anything like that.
So would downgrading solve this or should I just wait for 3.07 ?

Try plugging your usb-c charger in on the left side, assuming it is on the right, and double check fwupdmgr that it is fully updated. An additional reboot may be necessary as well. The Framework has two thunderbolt controllers one on each side. Some users have experienced a similar issue earlier in the thread.


Very preliminary results seem to show better or similar power usage of expansion cards while idle. I’ll post detailed findings here once I am done with the suspend tests, which take much longer to process (so: next week, most likely). For now see powerstat-306 - anarcat for my result dump…


How s battery duration with this BIOS update. Is it any better than the original ?
I get 5Hours of battery unplugged at the coffee shop with original BIOS.
Would love to get 6 hours straight away from a plug.