12th Gen Intel Core BIOS 3.06 Beta

In case anyone else experiences this… As mentioned above, you have to be connected to power to run this update. However, if you are not connected to power when you try to run it the first time, it reboots without telling you that it didn’t succeed. And then, re-running the MSI does not do anything, even if you are plugged in, unless you right click and run “repair install”. After that, the install worked just fine.


3.06 seems to have messed my 1260P laptop up. USB ports are finicky (almost never detects them to boot, doesn’t seem to matter if A or C or which port), Arch installer USB freezes after “triggering uevents” every single time.

I was also getting freezes at the LUKS unlock screen (always freezes before I could finish typing my password). I was able to install Windows 11, and it boots, but my setup requires Linux. Anything that would trigger a reboot hangs (even saving BIOS settings).

Attempting to run the MSI gets stuck when it should reboot and revs the fans up. I think the initial flash went bad via LVFS, and redoing it doesn’t seem to help (not sure if it just skips what it thinks is already updated successfully or something)

I would be willing to downgrade to 3.05, issues with the left side ports being stuck at USB 2 and all, to get rid of the rest of these issues, but I couldn’t find a link to the previous BIOS.


@fw91235543 Have you submitted a support request? I would if you haven’t already.

1 Like

I have a recent support request in now, hoping there’s just a way to force reflash and get things back to a more reliable state.

1 Like

@fw91235543 Have you done a motherboard reset? It might be enough to make it work correctly again.

1 Like

Does anybody know what the timeframe for the release of the new BIOS is? Also would Beta BIOS be able to download the final release? Or are you stuck on beta 3.06?


Looks like something went wrong during my install. Tried using the MSI installer. Like others ran in to the Retimer 23 not working. Rebooted a couple times, with no solution. Found out the ports on the left side weren’t working so I prepared the EFI usb. Bios did not see the USB so I booted up back into windows to format usb drive. Noticed the power led was not lit and the machine locked up while formatting the drive. Shut down the machine using the power button and now it won’t turn on and only the left side ports are working, instead. Does any one know what happened?


@prepaidpyramid For whatever reason I had to do 2 resets, but it seems to be working fine now.


Good day folks.

I juste received a lenovo thunderbolt 4 dock.
It was wonky (ethernet wasnt working eventough interface was up) so i updated the bios to 3.06 via fwmgr
Now the dock isnt even received as a thunderbolt device (the device is seen as disconnected eventough i’m receiving power from it). Nothing in dmesg.
Did i miss something stupid?

Many thanks

Edit : against all i read that makes sense to me, it works on the left port, but not on the right. Isnt this supposed to be the opposite…?
Edit 2 : also boltctl sees it as an USB4 device instead of thunderbolt 4?
Edit 3 : i also have the usb a card dying on second insertion on usb3 device on the right port. but curiously, as opposite to him, front left is fine


@Baptiste_Rajaut Have you enabled boltd or similar service?
In order to mitigate DMA attacks, recent implementations of the thunderbolt protocol include an authorization layer, so maybe the 3.05 was not aware of that and the 3.06 is.
I don’t know exactly how that plays out for your distro, but on mine I had to install boltd and the corresponding init service (I’m not using systemd, but you probably are, so you are looking for a way to enable bolt through systemd).
For reference, here is what the Arch Wiki contains:

Edit: oops, you were saying that you’re using boltctl, so that should already cover the authorization part of the protocol.

By the way, USB4 is not exactly the same as thunderbolt 4, but at least it is based on thunderbolt 3. So maybe it’ll match your needs.

(BTW I’ve just noticed this blog page, from another member of this forum, which is a fabulous dive into the features of the different USB and thunderbolt protocols.)


HI there,
Any update on a release date for the stable release of the 1st bios update ?
My laptop is pretty stable on Linux Ubuntu 22.04 since I received it in September.
But I am looking forward to even more stability, and in the past 10 years, bios update have always been a very important thing for robust ans stable operation.

Especially I am doing OBS video recording under linux, and you get in all kind of small bugs that summed up makes thing difficult.
For example my RODE usb C mic will stop the boot process when connected at boot ! And I need always to plug it two times to have it work. So its presumabely a mix of Bios/ ubuntu / rode firmeware.


Having real problems here. Started the UEFI update for Linux. It seemed to update a couple of steps then got to a script error. I reset and now it asks me to plug in my power adaptor (which is plugged in and which I’ve tried on different sides). So now my laptop is no longer charging. Not good at all



@Alex_Lennon Try a low power charger, like with a USB-A to USBC cable. One that isn’t USB-PD.


Doesn’t work either unfortunately


@Alex_Lennon That should have worked. I had the same issue. What is the specs of the power adapter you are using? See where it says PD was disabled? A non-USB PD charger should work.


I’ve sorted it out. I enabled battery disconnect in the BIOS. It shutdown for a few power key presses and when it came up something must have cleared out and the USC C charger is charging (yay)

That enabled me to go through and complete the update process although I seemed to have to go through it a number of times.



Having to remove and reinsert the USB-A cards randomly is really annoying. Any update on that?

1 Like

My bootloader is borked on my Windows drive sice a month, or maybe it’s the usbc port itself… but hey at least we can buy SSD’s for SteamDecks.


trying to update my bios but failled

the windows installer don’t work (it reboot but nothing after. it boot like normal

i try with lvfs but it say nothing to update

so i tried usb and it work but not for the bios
it failed at the end 5 out of 5

tried two or three more time and now it work

1 Like

I was able to fix my boot loop by mounting the efi partition in linux and deleting the capsule files and isflash.bin

… which I had to find by just kind of looking around at random for stuff that just kinda seemed like it was maybe related to an updater… and then there’s the buffoonery where the power must be plugged in but not at 100% ??? really?..and creating a boot loop is bad enough but then having no directions to cover that possibility… come on guys wth is this nonsense? This goes beyond “it says beta”

This is my feedback / report on this “beta”. At least it didn’t kill my dog.