12th Gen Intel Core BIOS 3.06 Beta

I’ve been resisting chiming in here, but this hits the nail on the head for me. I haven’t tried the beta update yet; after seeing the initial reports, I decided there was no way I was going to use my daily-driver on this experiment, given all the super bad outcomes people seem to be experiencing. Successive posts here have validated this decision for me.

I’m frankly very disappointed. This is barely alpha-quality; calling it beta is just simply not accurate. It’s been nearly 2 months since the “beta” release, and I haven’t heard a peep from anyone on the Framework team in this thread about the problems people have been having, nor have I seen an update on if or when a new beta release will come out (that addresses all the issues reported here). Even if we got a new beta, I’d still be very hesitant to try it out. And if they somehow do a final release, I will definitely be waiting several months before installing it.

(Regardless, this update doesn’t seem to fix the aggressive CPU throttling issues I and many others have seen, so I don’t even really see a benefit to updating…)


That’s probably quite wise for anyone without the experience needed to be able to recover from the kinds of bugs likely to be present in a beta-quality firmware release.

Complaing about a beta release having bugs however is disingenuous, because that’s the whole point of a beta release - to find known and unknown bugs, so they can be fixed:

A beta phase generally begins when the software is feature complete but likely to contain several known or unknown bugs.

If anyone is not prepared or equipped to deal with buggy firmware, don’t install it.


Please don’t put words in my mouth. I never said I didn’t expect bugs. What I didn’t expect were bugs this severe, that, in my opinion, should only be present in alpha quality software.

For the record, I do have the experience and skills needed to recover from (most of?) these sorts of bugs, but my problem is with the uncertainty Framework has introduced here. I don’t have confidence that I won’t be hit with something bad enough to put my laptop out of commission for days or more. And that’s my point: the kind of bug that would do that should not be in “beta-quality” software. And it adds insult to injury that the usual option when bugs are bad – downgrade to the most recent known-good version – isn’t an option here.

Further, if Framework considers this “beta quality”, I am skeptical of their ability to eventually give us a high-quality final release. Not to mention that it seems like their approach to community beta testing seems pretty bad: toss a release over the wall and fail to even (publicly) acknowledge the feedback that comes in.


I did in fact deal with it. So, what is the argument again exactly? Simply, don’t say anything ever?

It is perfectly valid to judge a thing on the facts.
It’s perfectly correct to observe that something is broken and say “this is broken”.

Seperately, there is no excuse I can see for this level of problems where aside from my boot loop, people are reporting that their usbc ports actually lose functionality, and this problem goes unaddressed for so long after being reported, and there is no downgrade option. None of that is excused by “beta”.

Framework does not have to rig the firmware so that it can’t be downgraded, and they could at least communicate that they are actually even trying to do anything about the broken usbc ports that can’t be used for their original functions any more. If one of my usbc ports could no longer be used for a monitor I would consider that an immediate warranty issue and mail the whole machine back if they didn’t fix it via software. That’s frankly ridiculous to create that situation and provide no path back out of it.

And I don’t see why my boot-loop went unresponded for so long. They didn’t even ask for more details or suggest how to repair it or provide any sort of guide to the internals of the updater so that the beta tester could attempt to fix it themselves. I only posted here and didn’t submit a support ticket, because in fact I can “handle it” and figured that I would figure something out sooner or later, and it was only a usb drive that I rarely need to boot into, not my main os on the nvme. That all just explains why I didn’t scream bloody murder into the normal support channel. But that is a totally seperate issue from why they didn’t hear a report of a boot loop and jump ALL OVER THAT to figure out how it could even happen and figure out what to tell the user to get them going again, even if only for the self serving cynical PR reason of not looking bad in a public forum, let alone for the sincere reason of caring about their own integrity.

You can’t have it both ways. You can’t say “don’t install a beta if you can’t deal with it” and also withhold the means to “deal with it” by making the software upgrade-only and provide no documentation of the internals.

And yet, despite all that, I, the one who is the one making the complaint you’re attempting to criticize, did in the end deal with it anyway. So, no matter which way you want to try to slice it, your comment is invalid on all levels.


It seems to have fixed the lock up on pressing F12 during boot.

from @kelnos :
" It’s been nearly 2 months since the “beta” release"
And we got no further update. Thats what griping me. I had to update to use the lenovo tb4 and i’m facing the same issue as @rcm . I dont mind having some issues there and there but we didnt get a hotpatch, a minor fix or something. I’m confused.

1 Like

Yea. This issue is really aggravating.

Hi Everyone,
We are working on a new update to 3.06 to try and address the issues that a number of users are experiencing.
Given that users are not able to update successfully to the new version on the first try, we do not want to move this release out of beta.

This updater moved from using the our bios vendor updater tool, to capsule based updates due to the vendor updater tool not supporting retimer firmware updates which are required for thunderbolt certification.

We are currently tracking the following issues:

  1. When using the windows updater, the update is not always applied on reboot. We think this may be happening when people have their battery fully charged, causing the battery status to discharging/idle.
  2. EFI shell updater: fail with a script error. This is caused by not cleanly unmounting the usb drive the update is on when it was created. The UEFI filesystem driver will not allow writing to a drive that is is not properly unmounted. We plan to add a check before starting the update process to make sure the drive is writable.
  3. EFI shell updater: During the update process the system will reboot and portions of the update will not run successfully due to the drive not being recognized by the bios after the reboot, causing the system to boot into the OS on the SSD. We are still looking at a mitigation for this, but if you still want to ensure your update is successful make sure you get to the last update screen. And if not reboot, press F12 for the boot menu and select your thumb drive to continue the update process. You may need to unplug/replug your usb drive in the F12 boot menu to be recognized.
  4. After finishing the update, some high speed functions may not work on one side of the laptop. This seems to be due to the PD/retimer not resetting correctly during the retimer update, causing all DP/USB3 functions to not work. The current mitigation is to power off the laptop, remove AC, wait 2 minutes and then reboot. This will fully power off the retimer and PD controllers and reset their state.
  5. When updating in Linux with LVFS, one user experienced a boot loop. We suspect this may be due to the battery charge status mentioned previously. We would suggest booting into the bios, and unplugging the battery for 10 minutes, then plugging in an adapter, and rebooting to see if the capsule update needs battery charging status to update properly.

Thank you @Kieran_Levin


@Kieran_Levin any word on why it’s sometimes necessary to reset USB-A cards in order to get them working again?


@Kieran_Levin thanks for the update!

Can we get a lower charge limit, pretty please?

Currently it jumps between 79 and 80% and keeps sending charge and stop charge events.


Thank you @Kieran_Levin

Happy to test (Linux with LVFS) a further beta once available.


I updated this BIOS a few days ago, everything seems to be fine, even solved the problem that my laptop will reboot when wake from sleep… until just now it restarted the BIOS update itself after woke up from sleep, What’s going on?

1 Like

I finally got a moment to open my Framework and reset the motherboard state.

So far, my USB ports are behaving much more predictably.

Fingers crossed.

Is this a one-and-done fix or something that will need to be performed occasionally until a more appropriate fix is discovered?

I am using Pop OS on framework and previously had everything working properly, however it looks like beta bios currently has brightness controls not work and not even showing up in software. Is there a timeframe for fixes to beta firmware?

Ugh nope…the motherboard state reset worked a bit but went to plug in my USB3 nvme enclosure this morning and the slot wouldn’t respond. I had to pull the USB-A card out and reinsert it. Annoying.

1 Like

I know a few people mentioned this issue already but I’ll give a comment on my experience. I tried to update the firmware with the usb key method. I hit the “Script Error” shown in the image above. The usb key was in a left side port (not sure that matters). I tried to restart the process but the EFI shell updater wouldn’t recognise the power was connected (I tried several different ports). I let the battery run down a bit to about 80% but it still didn’t recognise the USB cable as a power source. Also the little LED on the side didn’t come on. (I was a bit worried it was bricked at this point.) I turned off the power for about 10 mins and then cold booted. This seemed to fix the power issue, and the updating process could restart. This time it completed fully, and the BIOS is reported as 3.06.

This is the only real issue I’ve had so far. Apart from that, loving the laptop, and the support and community around it :slight_smile:


Posting for visibility, I also have the issue in which I have to re-seat my USB-A cards upon boot if I want them to work.


@Kieran_Levin when is this going to be out of beta?


Beta? This isn’t even alpha, and the fact it wasn’t pulled after one almost-bricking is abhorrent.