12th Gen Intel Core BIOS 3.08 Release

might not even browse these community pages, nor be on discord and be unaware of any bios updates. the average computer user is annoyed when a system reboots multiple times and all scary white characters appear and multiple progressbars.

EDIT !!! SHA1 I took was for 3.06, now its for 3.08.
Framework_Laptop_12th_Gen_Intel_Core_3.08_EFI.zip SHA1:317771e616be990ff3c54b24f9864d41dbea8d23
is still on the FW servers.

Thank you for double tripple checking


@Matt_Hartley Thank you so much for your candid reply. It really does mean a lot.

Looking forward to you guys crushing this release, in due time :slight_smile:


Just wanted to report a success with the 3.08 Beta EFI upgrade on my 13 inch Intel.

I’m well aware that it has been removed for the moment, however, I have had a 61kWh battery waiting to be installed for months now so I really did want to do the update to enable full support for that, and took the risk.

Nothing unusual - disabled secure UEFI boot in existing BIOS; booted from USB-A stick formatted FAT with the update unzipped to it; watched and waited while it went through all the steps; booted back into Fedora 39; restarted to re-enable secure UEFI boot.

1 Like

I’m likely going to be doing the same thing. I have a 61Wh battery coming and only have Fedora 39 installed. Don’t want to reformat to install windows.

Worst comes to worst, I remove the SSD as others have said they have been doing


I installed this today via EFI method and got the line 97 error. I had the power plugged in on the same side as my flashdrive when I got the error.

Moving power to the opposite side and rebooting fixed the issue for me. I did not have to remove my SSD.


You might want to check your download here. I just downloaded the file (for clarity, it’s still on the servers but Framework say you shouldn’t use it) again which shows up with a SHA1 of 317771e616be990ff3c54b24f9864d41dbea8d23, this also matches the file I downloaded Jan 11 2024 (my post in this thread) which I still have.

For posterity, the SHA256 of the file is:

ddb2ef62f589e5c972d577e2e44b6ac2d7d040767189dfb4bcd04aa5d93751e6 *Framework_Laptop_12th_Gen_Intel_Core_3.08_EFI.zip

Upgrading using the EFI on USB-Stick method worked fine for me. SHA256SUM ddb2ef62f589e5c972d577e2e44b6ac2d7d040767189dfb4bcd04aa5d93751e6

  • SYS CONFIG: i5-1240P
  • RAM: 2 Sticks of Crucial 16GB
  • SSD: WD Black SN770 1TB
  • Wi-Fi: Intel AX10NGW (stock).
  • External Devices/Other: USB-C Hub (Charger, LAN, Display, Display USB-Hub with keyboard and mouse)
  • EXPANSION CARD TYPES: On both sides: 1 USB-C (back), 1 USB-A (front)
  • BIOS VERSION: 3.06
  • OS VERSION: Arch, fully updated
  • FAIL RATIO: 0%. Worked on first try
  • STEP TO REPRODUCE: EFI Shell via USB drive
  • EXTERNAL DEVICE MODE or NAME: For USB flash drives, Generic or the brand.

I confirm those hashes!
sha256: ddb2ef62f589e5c972d577e2e44b6ac2d7d040767189dfb4bcd04aa5d93751e6


The link to 3.08b above resolved “The Installer can only be un on Framework Laptop 12 Gen Intel Mainboards”. I had a Batch 2 1280p board on 3.06 Beta. Now 3.08 Beta.


Update to 3.0.8 (via Windows 10) was successful.

However, now with Linux, entering “deep” suspend (in the /sys/power/mem_sleep sense) consistently soft bricks the device. Once in this state, a mainboard reset is required.

If you use Linux, I would steer clear of 3.0.8 until this is resolved.


Strange. I updated a few weeks ago, but I don’t see that issue. Using deep sleep (not s2idle), Debian testing, kernel 6.6.13. No problems with sleep here.

1 Like

Interesting! It repros consistently for me with the Fedora-Workstation-Live-x86_64-39-1.5.iso (without installing; running off a USB stick). I was triggering deep suspend with something like:

# Do not run the following commands.
echo deep > /sys/power/mem_sleep
echo mem /sys/power/state

I’ve got a case open and have been discussing with the support team.


I have the opposite problem. On Debian with BIOS 3.05 and 3.08, the laptop would sometimes never come out of s2idle (I’d have to power the machine off with a 10-second power button press). The “deep” suspend has consistently worked.


Batch 1 , i7-1260p. Experiencing disconnects with a thunderbolt 3 Egpu. Running the 3.08b release.


Hi there. The BIOS seems pretty tested now.
Any information on a release candidat ?


After around one and a half months with BIOS 3.08, I haven’t encountered the following problems (seen on BIOS 3.06) anymore:

  • “disappearing” of the USB-A expansion card after plugging a device in more than two or three times
  • non-working function keys (brightness control, media keys, etc) in Linux (seen occasionally after uptimes > 3 weeks, used to require a complete shutdown to get the function keys working properly again)
  • no tap-to-click in Haiku with PS/2 emulation enabled after rebooting from another operating system

No change:

  • in Haiku, touchpad still works better after a cold boot (and only with PS/2 emulation)

New (but only once so far):

  • sudden and complete power-off (no shutdown) during full-screen remote-ing into another computer on Linux while connected to power and battery at 80 % (limit set in BIOS) - black screen, LED of power button off, no power indicator light between expansion cards - power indicator light came back after plugging the USB-C power cable out and in again, pressing the power-button resulted in some colorful blinking of the power indicator light (not the full failure sequence) before the laptop just started again
1 Like
  • FAILURE SKU# and SYS SERIAL NUMBER: Framework FRANGACP04, S/N via PM if needed
  • SYS CONFIG: Intel Core i5-1240P
  • RAM: 2* 8192 MB PC25600 DDR4 SDRAM - Crucial Technology CT8G4SFRA32A.M8FRS (1330 MHz, 19-19-19-43)
  • SSD: WD Black SN850 NVMe 500GB (FW: 615400WD)
  • Wi-Fi: Intel Wi-Fi 6E AX210
  • External Devices/Other: Charger (45W) plugged in (left rear)
  • EXPANSION CARD TYPES: 2x USB-C (left rear, right front), 2x USB-A (left front, right rear)
  • BIOS VERSION: Coming from 3.04
  • DRIVER PACKAGE VERSION: Initiallly released version (are there any newer??) with all updates coming in via Windows-Update
  • OS VERSION: Update performed on Win11 23H2 (3155) using 3.08b-MSI.
    System configured as dual boot with Debian 12, Win is encrypted using Bitlocker (with PIN only, no TPM), Debian with LUKS.
  • FAIL RATIO: One run, 100% success
  • STEP TO REPRODUCE: not applicable
  • OBSERVED RESULT: success
  • EXPECTED RESULT: success
  • ISSUE RECOVERY METHOD: not applicable
  • EXTERNAL DEVICE MODE or NAME: not applicable

A month now, let’s get the party started. :sweat_smile:

1 Like

Same for me. 12th gen currently running 3.06. msi refuses to run saying it requires a 12th gen framework.

Within hours of me reporting this, FW actually built a 3.08b revision of the installer that fixed this broken check. It is in this thread a few posts down from my initial report.

FW simply failed to mention this fixed installer anywhere in their own opener or update the link to the fixed installer…

1 Like