12th Gen Intel Core BIOS 3.08 Release

Thank you for the update and the clear instructions! Just successfully ran the EFI shell update (Fedora 39 user updating from 3.06 bios) with no immediate issues.

I just tried plugging and unplugging a USB-A thumb drive several times both mounted and unmounted and it was recognized every time! This used to reliably cause an issue that I would remedy by removing and reinstalling the USB-A expansion module.

HDMI and DisplayPort behavior is still weird but appears to be improved. I have earlier versions of both cards and they’re both behaving better according to powertop. It still seems to change depending on which side I plug them in, seeming to prefer the side opposite the power button, but overall draw seems lower at first glance even with the older cards.


Thanks for this! I was still on 3.04 as well and I was getting the same error but on line 97 during my installation and I’m still trying to get it to work. Did you have any issues with none of your ports accepting power? I’m going to keep trying swapping ports around but I think something got screwed up during one of my attempts.


Unplugging the SSD as @Username009 suggested seemed to fix the issue along with moving the power adapter around. I have a Crucial CT500P2SSD8 SSD.

1 Like

I had the same issue. Whatever the first firmware that was pushed did, it appeared to cause my ports to stop working. I powered off, removed my ports, waited about 30 sec, reinstalled my ports and tried again. The update resumed at the second firmware and completed without issue.

I also had the same issue, that the update failed. I think it was on line 116. I had the stock 3.05 installed.

My device is an i5-1240P with 32 GB 3200 MHz ram and a Samsung SSD 980 PRO 1TB.

The hint from @Username009 to remove the ssd worked, I think. But I also removed the ram, battery, cmos battery and ram, to restore the ability to charge the laptop again. Normal usage of the ports, like the USB and headphone jack extension cards were not affected by the broken update. The possible reason why this “fixed” this issue can be seen on my second edit of this post.

Although this is a beta release things like this should not happen and a “normal” user might think that this bricked their laptop.

Before the update I reset the UEFI to the default configuration. This is something I always do before UEFI updates.

It looks like the reason for the “CONNECT YOUR CHARGER” warning after the failed update was that the laptop is charged to 100%. The laptop disables charging if the laptops battery is fully charged. So it cannot detect if there is a charger connected and thereby this warning gets displayed. By turning it off and removing the battery etc. It dropped to below 100% and enabled the charging again. I think @Kieran_Levin should add a notice to the thread that the laptop should not be fully charged if you try to update the UEFI. I think it should be started with a charging state of around 90% to prevent this issue from happening.


Had the same problem. I just unplugged my external displays.

Thanks for the MSInfo screen, this narrowed down the issue.
Can you try updating with the following and see if it fixes your issue?


Yes, this one runs as expected.

Soo, bug or unusual settings on my machine?

Edit: Btw, because I unpacked the MSI and installed the parts manually, Windows recognized that the BIOS and ReTimer firmwares were up-to-date so did nothing with those, but the ME update that runs directly during the installer executed a 2nd time including the actual flashing.
So seems behavior is not entirely consistent, because it neither does nothing if already updated, but it also does not reinstall all parts in case somebody wanted to do that for some reason.

Edit2: yes the installer seems to explicitly call the ME-Updater with the argument to force updates even if the same version is already installed.

1 Like

If you get the “CONNECT YOUR CHARGER” message, I think all you need to do is power down the laptop, unplug it, and wait for a few minutes.

I suggest leaving it unplugged and powered off for a while before you try something more drastic like taking it apart.


It is possible that like the previous update the laptop needs to be showing as charging, and that for this purpose it is wise to drain the battery below 100% to ensure that charging is actually happening.

This does not appear in the new instructions and it might be possible it applies to non LVFS updates.

Lastly during my successful update there were several extended blank screen instances … as always I was patient with it … others might not be and these extended blank screen instances should be noted as expected behavior in the instruction set.

I think I may have bricked my laptop. It is just booting to a black screen with keyboard lights on. What can be done? I don’t see a framework logo or anything?

I restarted it and now it just sits at the black screen. Anything can be done?

Updated from 3.06
The MSI in the first post did not work (“The installer can only be run on Framework Laptop 12 gen…”) but the fix provided (3.08b) installed correctly. I believe this is also a batch 1 or 2 FW 13 gen 12 laptop.
I have yet to experience any obvious regressions; I will post again if I find any.

My battery was fully charged when I applied the update (Windows 11 Pro).

That’s the issue, possibly: when the battery is at 100%, the laptop will actually stop charging for certain periods. For some reason that state is apparently indistinguishable from “not plugged in”, which might trigger the BIOS updater to refuse to do its work.

So the recommendation is that you actually let the battery discharge down to 90% or whatever, plug it in, and then run the updater. That way the state will always be “charging” for the duration.

For me there was no issue with the update.

Also, it always reports as charging (plugged in) here (in Windows), even when the battery is fully charged at 100 % (according to Windows).

1 Like

Huh, interesting. Linux here. Right now it is indeed showing as fully charged and plugged in. But every now and then it switches to 100%/discharging for a little while, before going back to fully charged and plugged in.

I’ve read about this phenomenon elsewhere on the forums, so I think it’s behaving as designed, even though I’ve never seen this behavior on any other laptop.

1 Like

yeah, I’ve read the same somewhere here in the forums, but I never saw this behavior on my Framework laptop.

Something bad happened with mine. I have lost the ability to charge from any USB port.

I run Fedora Silverblue/Kinoite, disabled SecureBoot before flashing. I booted with the USB drive, it ran until this:
Flashing completed successfully. Host command 0x3E01 inform ED Flash (2)

Unable to redirect file.
Script error Status: Invalid Param (line number 116)
FS1:\framework-firmware-update\firmware> _
[end clip]

It stuck to that prompt and shut down when I touched the power button.

Now, when I boot the USB drive, it goes into a screen with “ATTACH POWER SUPPLY” in the middle. I tested booting with the charger plugged into each port, but it does not recognize the power supply (tried two Apple, one Anker, all used with this machine before).

I can boot into the OS and it doesn’t recognize the charger being connected either any more.

Now what?

Yes, that could actually be the reason. Mine was also charged to 100%. From what I remember it did not charge after the update failed, even if it got under 100%. So there might be more to this issue.

Good luck

1 Like