12th Gen Intel Core BIOS 3.08 Release

Yes, this one runs as expected.

Soo, bug or unusual settings on my machine?

Edit: Btw, because I unpacked the MSI and installed the parts manually, Windows recognized that the BIOS and ReTimer firmwares were up-to-date so did nothing with those, but the ME update that runs directly during the installer executed a 2nd time including the actual flashing.
So seems behavior is not entirely consistent, because it neither does nothing if already updated, but it also does not reinstall all parts in case somebody wanted to do that for some reason.

Edit2: yes the installer seems to explicitly call the ME-Updater with the argument to force updates even if the same version is already installed.

1 Like

If you get the “CONNECT YOUR CHARGER” message, I think all you need to do is power down the laptop, unplug it, and wait for a few minutes.

I suggest leaving it unplugged and powered off for a while before you try something more drastic like taking it apart.

2 Likes

It is possible that like the previous update the laptop needs to be showing as charging, and that for this purpose it is wise to drain the battery below 100% to ensure that charging is actually happening.

This does not appear in the new instructions and it might be possible it applies to non LVFS updates.

Lastly during my successful update there were several extended blank screen instances … as always I was patient with it … others might not be and these extended blank screen instances should be noted as expected behavior in the instruction set.

I think I may have bricked my laptop. It is just booting to a black screen with keyboard lights on. What can be done? I don’t see a framework logo or anything?

I restarted it and now it just sits at the black screen. Anything can be done?

Updated from 3.06
The MSI in the first post did not work (“The installer can only be run on Framework Laptop 12 gen…”) but the fix provided (3.08b) installed correctly. I believe this is also a batch 1 or 2 FW 13 gen 12 laptop.
I have yet to experience any obvious regressions; I will post again if I find any.

My battery was fully charged when I applied the update (Windows 11 Pro).

That’s the issue, possibly: when the battery is at 100%, the laptop will actually stop charging for certain periods. For some reason that state is apparently indistinguishable from “not plugged in”, which might trigger the BIOS updater to refuse to do its work.

So the recommendation is that you actually let the battery discharge down to 90% or whatever, plug it in, and then run the updater. That way the state will always be “charging” for the duration.

For me there was no issue with the update.

Also, it always reports as charging (plugged in) here (in Windows), even when the battery is fully charged at 100 % (according to Windows).

1 Like

Huh, interesting. Linux here. Right now it is indeed showing as fully charged and plugged in. But every now and then it switches to 100%/discharging for a little while, before going back to fully charged and plugged in.

I’ve read about this phenomenon elsewhere on the forums, so I think it’s behaving as designed, even though I’ve never seen this behavior on any other laptop.

1 Like

yeah, I’ve read the same somewhere here in the forums, but I never saw this behavior on my Framework laptop.

Something bad happened with mine. I have lost the ability to charge from any USB port.

I run Fedora Silverblue/Kinoite, disabled SecureBoot before flashing. I booted with the USB drive, it ran until this:
[clip]
Flashing completed successfully. Host command 0x3E01 inform ED Flash (2)

Unable to redirect file.
Script error Status: Invalid Param (line number 116)
FS1:\framework-firmware-update\firmware> _
[end clip]

It stuck to that prompt and shut down when I touched the power button.

Now, when I boot the USB drive, it goes into a screen with “ATTACH POWER SUPPLY” in the middle. I tested booting with the charger plugged into each port, but it does not recognize the power supply (tried two Apple, one Anker, all used with this machine before).

I can boot into the OS and it doesn’t recognize the charger being connected either any more.

Now what?

Yes, that could actually be the reason. Mine was also charged to 100%. From what I remember it did not charge after the update failed, even if it got under 100%. So there might be more to this issue.

Good luck

1 Like

Yea, this is my current strategy. Also can’t find the screwdriver.

I would contact support; you’re likely to get a more prompt response and some personalized help that way.

1 Like

You might also just try:

… before you go to the trouble of opening up the laptop and removing components.

Updated from 3.05 to 3.08 this morning via the usb-stick method. It took 3-5 minutes to complete and worked out well. I’ve removed all unnecessary cards before updating (e.g. HDMI), started with a ~70% charge level and let it do its thing without interfering.
My System: i7-1260P, 1TB SN850X, 32GB Corsair RAM

EDIT: Connecting a USB-C dock with two monitors works as expected

installation went smooth using EFI installer but display through type-c is not recognized after update (fedora kde 39)

EDIT:
also connecting HDMI is not working for me.

So i can’t revert… and can’t use any external monitor… please release fix asap :pray:

1 Like

Just updated from 3.06 to 3.08 with the UEFI Shell updater. Everything worked flawless and system booted up normally.

CPU: Intel i5-1240P
RAM: Corsair 32GB (2x 16GB) 3200 MT/s
Storage: Samsung SSD 980 Pro 500GB