12th Gen Intel Core BIOS 3.08 Release

Is there currently any way to install this update without windows?

I’ve been having issues with excessive thermal throttling on 3.06 lately, and I’d love to see if this fixes it.

1 Like

I’m having exactly the same problem as you. My Framework is i7-1280P from batch 2. I’m also on 3.06 beta.
Can you elaborate how to install the BIOS after unpacking? EFI installer is not accessible now and LVFS is not updating everything so my only way is Windows installer :wink:


I could. But look for Kierans response a few posts down. FW linked 3.08b beta installer that works, so that would probably be better for you. Although I have no idea why FW did not update the main link after multiple people reported that solving the problem.

1 Like

It worked. Thanks!

I’ve been having issues with excessive thermal throttling on 3.06 lately, and I’d love to see if this fixes it.

I’ve had excessive throttling on all versions, including factory. This new update doesn’t help.

Bummer, I won’t rush to install this beta then. Thanks for letting me know

I don’t think that there is a issue with the new BIOS/ME/Retimer/… versions, because this would also lead to the windows updater being removed. I think, the biggest issue is, that the ME won’t get updated with the EFI updater and people think, they are uptodate now, which they are not.

The Linux update path is the one without ME, but otherwise uses the same capsule system where the BIOS essentially self-Updates.
And apparently, FW cannot update the ME from a capsule, but requires a separate updater executable.

The EFI update includes the ME. The update tool for it is even called the same (FwUpdLcl), just with .efi extension instead of .exe. Difference is, the EFI update also updates the other firmwares seemingly with separate update tools and not the capsule system.

Fix #4 “Plugging in a USB-A device multiple times would eventually not be recognized anymore” seems to have worked for me.

My 1 USBA port has worked reliably since this update was released.

1 Like
  • FAILURE SKU# and SYS SERIAL NUMBER: FRANDACP04, I’ll have to grab the serial number later since I don’t know how to see it from within Windows
  • SYS CONFIG: Intel i5-1240P
  • RAM: 2 x 16GB Kingston 3200MT/s
  • SSD: 2TB SK Hynix P41 Platinum
  • Wi-Fi: Rando ATH9K card
  • External Devices/Other: Anything attached? If so, what and how? If not, please indicate.
  • BIOS VERSION: 3.06
  • DRIVER PACKAGE VERSION: I don’t think I had updated the drivers yet. This was a fresh install of Win 11.
  • OS VERSION: Windows 11
  • FAIL RATIO: 0%
  • EXTERNAL DEVICE MODE or NAME: I don’t recall there being any external devices attached. Could’ve had a 32GB Lexar USB attached or my CoolerMaster EG200 attached but I don’t think so

Why is there only two people in this thread trying to hold FW accountable?

1 Like

Probably because the topic title says “Beta Release”.


Because I’ve done so elsewhere and continue to do so elsewhere. This thread has not yet gotten to the point where I feel the need to make statements in that vein yet. I’m waiting to see what Framework does next. This is a beta release and unlike 3.06 which did not age gracefully, we shall see when this moves to final release or what the process looks like. Once I see more I’ll make a judgement call then.


I really hope they push their efi release again (I got it tho, and worked fine). And yeah, hope it gets to release at some point. soon.


I was going to forgo any further inquiries until 28 days since release. As far as I am concerned they have another week before I am going to push for a roadmap, or a cleaned up beta, or a final, depending on what information is provided. My update was successful on the first attempt, and I think if we can narrow down external factors most of the update issues would go away…i.e. were you docked at the time, were you using anything but usb-c expansion cards, etc. or whatever they have discovered from the info provided here.


Accountable for what?
Framework is one of the first vendors to fix LogoFail!
I’d also like to have more details about the plans with the EFI updater, but it is like it is. If there is silence for more than 2 weeks, I’ll probably start complaining.


@Kieran_Levin @Matt_Hartley
Following up again on this. (12th Gen Intel Core BIOS 3.08 Beta Release - #162 by Perry_Flaugh)

I’m mostly curious about where things stand with this release and where we should set expectations. I completely understand that there have already been some issues with this beta you are working through.

I’m perfectly fine waiting on this to be done right. But I think level-setting expectations, even if just in general, (“we are close to having this shipped.” vs “lets circle back in 3 months, we cant ship like this and we need more time”) would be beneficial in keeping this thread from devolving.


I updated via the EFI updater (including ME) and everything worked fine.
Can somebody please confirm the PCR0 sha256 hash?


On Linux you can get the hash as root with

tpm2_pcrread sha256:0

(Yes, I used tpm2_quote to sign the pcr values to protect against a sophisticated LogoFail attack, I just don’t know if this is the correct hash)

1 Like

I get a whole different hash. starts with 0x2B81496C…
im a bit unfamiliar with what these hashes mean, and what they should be. These may depend on your specific 12th gen cpu, and maybe configuration maybe?

1 Like

Thank you. Interesting. The PCR0 contains the hash (sha256 in this case) of the core system firmware executable code. PCR1 contains the platform-config, which usually changes based on the CPU/RAM/etc. I have the i5-1240P version. Have you also updated the ME?