AMD Batch 8 Guild

Had my first DPC_WATCHDOG_VIOLATION already. BSOD’d during normal use, just doing writing in my browser. Moused over some text with.tbe trackpad and everything froze.
Sent in a support ticket already.

What do you mean? It runs perfectly on mine, with the default settings, the only (expected) problem is the screen resolution and I’m still deciding if I want to run at 100% scaling and default font size (which is workable, albeit kinda small), 100% scaling and increased font size (not ideal as it is a non default setting) or 125-150% scaling (which leads to blurry legacy apps).

1 Like

They’re expecting to deliver mine in the next 3 hours or so, I am very excited to finally get my hands on this thing!


Fedex seem to take the most indirect route possible
From Taiwan to the UK

Taiwan - Angels city Philippines - Guangzhou China - New Delhi - Dubai - Charles de Gaulle France - Stansted UK - 2 different sorting hubs in the UK

Now out for delivery visiting 7 countries :rofl:

France was pretty close to Germany. Why did it go back to China? :smiling_face_with_tear:

Still expected to be delivered on Tuesday, Dec 5th. So here I am, hoping it will really work out.

The customs were digitally processed in France before it was sent from China

Edit to add: it was never in France, it was still in China the whole time :slight_smile:

1 Like

I’m part of the batch 10 crew also in the UK. From the point it was shipped, how many days was it to get to being out for delivery in UK? Trying to get a sense of the shipping timeline. Seems like it’s about 4 to 5 days which is pretty quick but wanting to sense check.

  • I use a custom built mesa with some additional build options. Building it (Mesa v23.2.x) with LLVM/Clang v17 is failing. I tried building it with v16 but that is breaking rusticl.

  • I’m running into the following error when trying to add a fingerprint. There might already be a fix for it around the forum, just haven’t looked yet.

  • The latest Nextcloud client has a Nautilus integration: Nextcloud shares shown twice bug.

  • The Dash to Dock gnome extension has a Show Applications bug.

  • Ran into a bit of issue while replacing ffmpeg-free with ffmpeg. I’ve been able to resolve it.

  • One time when the laptop woke up from suspend, the whole screen was white. I haven’t looked into it any further but restarting the laptop fixed it. Not sure if it is related to the graphical artifacts issue.

Some of the issues might not be directly related to Fedora, just from third party packages. I’ve an Intel NUC with Fedora 38 where I’m not running into these issues, given it has older versions for some of these packages.

Overall the system is stable for me. Me saying seems a bit unpolished might have been a bit harsh.

Yeah, that’s a known issue with the fingerprint reader firmware (and not Fedora). Of course, there’s the part where match-on-chip Goodix fingerprint readers (used in many laptops) are questionably secure as well (and I think this does apply to the Framework?), so whether you’d want to use one at all is also worth considering.

(Now that I’m thinking about it, let me make a separate thread on fingerprint reader security.)

1 Like

So delivery time was this morning between 8:30-12:00 (mind you most of packages are delivered late afternoon, this caught me by surprise). I had to take my son to school and the short time I was gone, they had already came :pensive:…now it’s scheduled for tomorrow. :man_facepalming:t3::person_shrugging:t2:

Exact same time for me. It’s typically right at 12 but I’m not budging until it arrives.

I guess it’s okay. A part of me is excited to try the new hardware but I honestly don’t want to perform the switch out until my classes are done this semester, especially with the varying experiences others have had. My 11th gen is baked in at this point and reliable.

Shipped on 29th November
Delivered 4th December

1 Like



I’ve spent the last couple of hours getting set up, I can honestly say this thing is brilliant.

I installed Fedora and set up the development project I’m working on, which is web stuff with Docker, and I haven’t heard the fan yet. Fantastic.

The expansion cards are surprisingly tough to get out though.

1 Like

For real. Not worried about losing one for sure.
Didn’t realize how big the esc and del keys are as well.


Not bad temp wise. 7840

1 Like

Damn the UPS is not happy with that base lol, you using any mods?

Got mine set up! A few quick thoughts:

  • Installation was mostly a breeze, with one excepption:
  • A wire was out of place near the lower left corner of the screen, causing the “bump” at the bottom of the bezel to not fit right. It caught each time I opened and closed the lid and was starting to rip itself off of the rest of the bezel. I have the wire straightened out now, but I think the bezel got a little damaged in the process of figuring it out.
  • Only the bottom ~half of the touchpad is clickable when tap-to-click is disabled. Kind of a disappointment. (I’ve gotten spoiled by my work macbook’s touchpad.)
  • I hit a security problem when trying to install NixOS, going to circle back to that
  • For my Windows partition, after installing the framework driver bundle, I rebooted and ran AMD’s driver tool, and it found a few more things to install.
  • Overall, I’m very happy with it :slight_smile:

Received my laptop this morning. The included screwdriver bit is indeed too soft, glad I have a ifixit set with me. Otherwise the setup process is really smooth. Installed NixOS, got around 5w on idle and 10w on light use with default configuration, not bad, but can use some optimizations.