AMD Batch 8 Guild

just received the laptop and completed the assembly. it lit up on the first boot. Currently installing OS. very excited!!! Hope everyone gets their laptop soon!

DIY 7840U
RAM: G-Skills RIPJAWS 5600 32GB
Storage: WB SN850X 2TB


Received mine a day earlier than expected. Typing this comment using my Ryzen 5 Framework 13!

Setup went without a hitch! Surprisingly easy to assemble and boot.


Previous batches have appeared to go in bulk to Frankfurt, and then the pallet load gets broken down and distributed from there all around Europe and the UK.

1 Like

As I suspected, my shipment is in Anchorage right now in normal import/customs waiting to be cleared. Espected arrival date is Monday.

Mine sitting in Anchorage as well. Interestingly aftership has not been able to find my shipment, but it works on the FedEx site. No ETA for me.

I had that problem at first but it seemed like Aftership finally updated to a current status.

arrived! it’s great!

7840U, 32gb (2x16) DDR5-5600, Lexar NM790 4TB SSD

FYI - DIY setup was easy, except it was kaput the first time I tried - screen would stay black, fan would gradually ramp up, with nothing to show even after 5+ mins waiting. I tried swapping some things in and out (2x RAM modules, the SSD, the expansion bays) and checking all the connectors were in, with no joy. Eventually I removed everything I’d added - back to no RAM, no SSD, no expansion modules - and it then worked, the screen would show ‘no boot device’. I then added things back one at a time, checking each step that it booted, all good! I then installed Fedora 39 KDE spin from a USB-C stick without issues.

the hardware is really nice. the design isn’t much to look at - but the build is great, the matte 3:2 screen is excellent, the keyboard and touchpad are great, etc.

everything has been working well out of the box so far with Fedora 39 with KDE Plasma spin, except the wifi will randomly drop out. No networks available, turning wifi on/off or airplane mode on/off doesn’t help, just restarting fixes it. I’ll see if I can find a fix, if not I guess I’ll try a support ticket.


Finally got my card charged and my laptop shipped 12 hours later. They really are picking the pace. Now for the wait. ETA December 6th for me.


So is this batch shipping with ver. 3.03 bios or do we need to update it?

Mine is arriving at some point today and I am anxiously awaiting it’s arrival…

It arrived :partying_face:

Really hoping the packaging did a good job though…


Pretty sure it has updated BIOS

My AMD mainboard arrived an hour ago. The old i5-mainboard was quickly replaced, the WIFI module too, the 32 GB RAM inserted, screwed in, switched on, and it worked! It went like a charm - a little fiddly at times perhaps, but no real problem even for an amateur like me.

And the old new Framework laptop now also runs like a charm! Love it! :smiling_face_with_three_hearts:

Played with the new laptop a good bit last night, was running everything great! The build quality on this is really good!! The only issue I had during the install was two small things,

  1. took me a minute to realize one ram goes in upside down the other right side up. The notch is so close to the middle on this ram its hard to tell and the little black flaps Framework puts on top makes it hard to see where it slots in… not a big deal just a small thing.

  2. The screen bezel was a bit awkward to get on, the alignment on the bottom was a little tricky, but my recommendation is start at the bottom then work your way up. Again nothing major, just a little finicky.

Once it was all built though the laptop took about 20-30 seconds to first post, was wondering if I did something wrong because it took so long, but it came up and has been running great ever since!! I reluctantly installed Windows 11 on it and immediately proceeded to remove all their crapware like O365, OneDrive and the dreaded Co-Pilot, which you cant really uninstall only disable… DAMN YOU MS, stop forcing your crapware on us!!!

FYI the latest bios, 3.03 is on this device. No need to update that.

All that said, I am really impressed, this feel like on solid and heavy piece of aluminum! I fired up a couple games even on it and they worked pretty well. Really love the AMD APUs!! Looking forward to the years to come with the Framework 13 (Well until the Framework 16 comes out, then my wife gets this one).


Mine has an updated one.

1 Like

The only issue I ran in to was that my router was not detected so I cannot install / update all the windows drivers then the framework ones.

I read something about it being if you have an older version of the windows installer that it could happen, but I just have the one that is available on the microsoft website when creating a iso bootable usb.

Don’t suppose anyone has any tips?

Should I install the framework bundle now in order to get wifi??

Really wishing I had bought the rj45 expansion card too now!

But otherwise everything went smoothly and I am excited to get going with this little beast.

**Update - installed the framework driver bundle which gave me wifi. Updating windows now and everything seems to be going well.

1 Like

First impressions: It feels solid, keyboard is nice, hinge is a little bit resonating when touched, but completely okay, screen is beautiful.

The only thing that was really annoying was that the preinstalled SSD screw was way too tight and not removable with the Framework screwdriver. I was very careful, but the bit of the screwdriver is apparently very soft and just became round.

And I couldn’t apply more downforce as the mainboard started to flex. Finally got it out using a proper screwdriver from Wera (used a TX6 bit as Torx 5 seemed too loose).

Other than that setup was relatively easy, I haven’t tested much yet, but no complaints.


@Jonathan_Haas Seems like I’ve seen this before. Hope I don’t have an issue. Mine will be here Monday.

On another note really dumb question. How do you quote and reply to another post? I’ve got VPN, ad blockers and uBlock origin all turned off and I still don’t see it on my desktop or phone.

Select the text you want to quote like I did with your post and a little popup appears that says quote…click it and it does the rest.


Select the text to which you want to reply to.


Shipment was just released from Import clearance. Come on Monday!