AMD Batch 8 Guild

Got mine today too and I had the exact same problem. I don’t think there ended up being any damage but I was pretty worried about that catching on opening.

I’ll echo the issue with the included screwdriver not being sufficient. Way too soft. I have the same screwdriver that worked great. That NVME screw was on tight.


Thanks, I figured it was something like that. But then I decided that NixOS was more likely to play nice with an existing Windows install than Windows was with an existing Linux install, so I decided to do Windows first.

Like 100, that’s the FPS though, the zoom mod causes that, even on my desktop, Factorio was not made to render full detail at that zoom level.
Speakers on this thing are far better than the grills implied. GJ FW
A NOTE ON THOSE TEMPS: That was done in the middle of installing everything and setting this laptop up, running that same base again I didn’t even hit 70* for the 5 mins I let it run

Got my new motherboard last week to upgrade an older laptop. Immediately had issues with what appears to be display signal corruption. Emailed support about the issue including details like the issue goes away when I swap back to the original 11th Gen Intel board. Support replied today saying they can replace the monitor if it’s under warranty. I don’t think they even read the email because the issue is clearly something to do with the new board.

At this rate of reply from support it could take weeks or months to get to an RMA. Hopefully the support staff will scale with the number of new customers. Right now it’s pretty bad. I would include a ticket number or something in case someone reads this that can address the issue, but there’s nothing to uniquely identify support requests visible to users. :person_shrugging:

Got mine yesterday, exactly as estimated! If I’d had it shipped to home, it might even have come a day or two early.

Super easy to put together, and so nice! I’m coming from an XPS 15 so it’s light and small compared to what I’m used to. I do have a crunchy spacebar, but haven’t tracked down what’s going on with that yet - feels like maybe some dust in the switch?


Fiddled around with power-profiles-daemon and epp profiles, now I’m getting 4.3w on idle. Seems that p-p-d would only use ACPI platform profile when it’s available, not touching epp. Don’t know what’s the interaction between these two.

Edit: according to [TRACKING] PPD changes have no effect after suspend on AMD until reboot - #8 by Justin_Weiss, they should be able to work together.

Noticed a small bubble forming at the bottom center of the screen, not really noticeable unless looking from a certain angle, hope it does not deteriorate over time. Guess It’s due to the temperature changes in Boston.

Edit: through the magic of removing the bezel and applying a gentle force, it almost fixes itself, now it’s barely visible even if deliberately staring at it.

Just got my new AMD board and WiFi card :partying_face:

I was reluctant to do the upgrade until after the semester but I just did it. Fairly easy switch out to be honest. Got my existing Windows switched over to the new hardware with no hiccups and the driver bundle installed. I still want to visit AMD’s website and update drivers for processor/graphics chip. After that and some Windows updates, I’ll put together my Windows environment with apps and virtualization. I probably won’t bother with dual booting Linux until the end of next week.

1 Like

I have had two DPC_WATCHDOG_VIOLATIONS BSODs on my prebuilt 7840U Windows 11.

This was after Framework’s 3.03 firmware and driver package was installed. Between first and second BSOD I went to AMD’s website and did the autodetect driver install, so that didn’t resolve it either.

Opening a support ticket :frowning: This is a replacement device for another laptop (non-Framework) that was randomly BSODing.

@NickCao I suppose the good thing here is that if there’s a screen fault and you need to RMA it, it’s a simple replacement process and doesn’t need a whole new machine sending out.

1 Like

Luckily have not had a BSOD here yet. DIY 7840/win11 pro

What hardware & software are you using it with? Any games or older applications?

I think I was able to tie my own BSODs to when I tried playing Deus Ex: Mankind Divided out of nostalgia. That game is known for BSODs when very specific settings aren’t set and there’s more than 4 cores assigned to it. I have since changed settings accordingly and seemingly alleviated myself of the issue.

One was on battery, one was plugged in. Only common denominator I can identify is Firefox was running at the time. The first time I was running Remote Desktop/WSL 2.0/Handbrake as well, the second time was simply browsing the web on battery.

I am trying the Power Plan → Advanced settings → PCIE power savings to moderate option referenced in another thread. Random hard freezes fw13 amd7840u win11 - #32 by sgilderd

Just got my board today an did the upgrade. I installed Windows and Fedora (dual boot) and so far everything is working flawlessly.

After I installed Windows, I loaded up the bundle drivers and then double checked my bios. After that I went to AMD and updated my chipset driver. All other Windows updates took place and everything is running smooth. As far as Linux, Fedora is installed but I’ve yet to use it much and haven’t installed any apps on it.

I’ll keep running it through the paces and post anything here if I run into problems but I’m keeping my fingers crossed as I’m typing this because I know so many others have had problems.

Turns out I spoke too quickly.

Well for me today will be the day I put the machine through its paces so hopefully my mileage is different. When I updated the drivers I avoided using Adrenaline, just updated the driver by itself. Used AMDs product search for the CPU and it brought me to a page with the drivers.

I chose the autodetect option.

1 Like

My laptop showed up today and I’ve spent the past couple of hours getting it set up. This will be a linux only device and for now I have installed Fedora 39 KDE. I tend to tinker a lot so this might end up changing a few times before I settle. :slight_smile:

So far everything has been smooth and I’m impressed with the build quality and display. Coming from a refurbished Dell Lattitude E7440, the Framework is a major upgrade!

1 Like

two days in and the bottom left side of my trackpad is significantly lower than the right.
Everything still works, but boy is it noticeable. Probably have to open a ticket with FW on this one, I haven’t taken off the input cover since putting it together, and it was level when I got it.

Received my Ryzen 7840 DIY as estimated (on Monday), but didn’t have a chance to play with it till yesterday.

  • Assembly was a breeze (but yes NVME screw was a bit tight, however, FW screwdriver did the job; I was extra careful though)
  • Expansions cards - for me does seem rather hard to get them out.
  • BIOS password setting is perculiar*
  • Setting it up with NixOS
  • Have not heard the fan yet, but I was not pushing my fw either

*Limit to 10 char limit is odd; also strangely BIOS did not recognise my password. I think it did not like ! in the password when I was trying to log in afterwards (although I was too lazy to verify this, so there is a chance I messed up typing it in; would be nice if BIOS actually showed the password when setting it up), so I had to reset BIOS.

1 Like

On top of that it has character restrictions. Oddly, it said must contain at least 1 character. But then followed with must contain at least one capitol letter, one special character, etc. This all needs to be completely removed on next BIOS update.

1 Like