AMD CoolerMaster Case First Boot -- WONT BOOT

I recently received my AMD mainboard and popped it into the Framework CoolerMaster case. I have 32GB (2x16GB) Crucial DDR5-5600 SODIMMS installed and a WD-Blue 1tb drive installed. When plugged into power I get flashing blue and red lights on both sides of the board. I will try to powercycle and the fan will kick in for a few seconds and then sometimes I will get a flash of green white and orange lights on the sides for about 5 seconds and back to the red and blue flashing.

I have seen that others have had a similar problem, but after trying all that they have sugguested, nothing has allowed it to post. Things I have tried:

  1. No NVME drive on boot
  2. Letting the lights go on all night (8 hours) to train RAM
  3. Booting with only one RAM stick in channel 0
  4. Pressing down on the case closed switch before powering on.

I am at a loss of where to go from here to get this to boot.


Have you tried with just one RAM stick in channel 1?

I’m surprised your amd board does fit inside your coolermaster case, as mine didn’t and I had to return.

I did however encounter the same issues as you, and after my return Framework provided these instructions:

I have the exact same issue. Did you manage to solve this somehow?