[SOLVED] AMD 7040 mainboard in printed case, red/blue flashing leds

I’ve recently received my AMD 7040 series mainboard and 32G DDR5 module. I’m attempting to place them in a printed case. The mainboard fits the printed case fine.

My issue is that once I connect a 65W USB-C power supply, I get flashing red and blue led indicators on both sides of the motherboard and nothing on the USB-C (alt-mode) display.

I’ve seen this post:

I’ve tried the suggested solution:

  1. Remove all the expansion cards.
  2. Remove the top cover of your Coolermaster case.
  3. Plug the power adapter directly from any of the expansion slots.
  4. Press the chassis open switch in the center of the main board 10 times, you must press it slowly, so press for 2 seconds. Release, and wait for the red blink on the motherboard LEDs. Press, etc.

No change. Additionally, while the leds are flashing, the heat pipe on the unit gets quite warm, but the fan does not spin. So, I haven’t left the unit powered on for a prolonged period of time.

Try to note down the led blinks.
There should be 22 blinks.
They help diagnose what is wrong.

The display will not work if there is no ram present in the system, or it cannot see the ram.
What is the model number of the ram you have?

The LEDs are a steady pattern of Red then Blue repeating. Watched it for 22 flashes of Red, no change.

The unit was purchased as a kit from Framework. The RAM is listed as DDR-5 5600. And is install in bank 0 (right memory bank).

If it is just flashing red, repeating all the time. That is what the main board does if you plug the usb-c power in, but don’t turn it on. It only flashes red if the mainboard has no laptop midplate installed, which in your case is true. In you case you have a mainboard and the printed case instead of the laptop keyboard, screen etc.
Also, if it was an 22 flashes report, it happens once on power on and that is it. You have to re-power it to get the 22 flashes again.
My guess is that the power on button is not actually working. Maybe a loose connection to the power button. I think there is a power on button on the mainboard.

Hi @Jamin_Collins, Welcome to the community.

The board may not know it is in standalone mode (i.e. naked without all its laptop parts). Did you happen to purchase a Displayport or HDMI dongle? Not all USBC monitors/hubs work the same unfortunately.

It may be trying to show the display; however if there is an issue with the USBC display not understanding the signal coming out of the Framework it will just sit there blank. If you have an HDMI or Displayport adapter you bought with it, you might try that first to see that it is actually outputting video.

Things to try:

  1. Use the Back Left USBC port (ok to use the Framework dongle with USBC) for power, do not connect it at this time.
  2. Try the HDMI/Displayport/USBC on the Back RIGHT USBC port of the machine.
  3. Remove the SSD drive for now. Just have the memory plugged into Slot 0.
  4. Plug the power into the board and wait a good 60 seconds.
  5. Press the power button ONCE, and wait. If the system never “trained the memory” this will take a minute or so.
  6. If you still do not see anything on the display, press the power button ONCE again. (Nothing will probably happen; this is ok)
  7. If the system is still on (LED lit); press and hold the power button for a good 20 seconds. The LED should go out.
  8. Wait 5 seconds after the LED goes out indicating the board is off; now press the power button ONCE and wait.
  9. If none of this works, try moving the memory to the other slot and start over from Step 1 above.

Ideally it will come alive at some point, and mention that it does not know what to do because it has nothing to boot from. Power it down, unplug it, and reinstall your SSD drive along with whatever USB drive you are going to use to install your operating system.

If you do get the system to boot up; go into the BIOS and check that the “standalone mode” is enabled.

As I mentioned previously, there are known issues with USB monitors/hubs out there that do not play nice with devices the same way. Hopefull you have the ability to have video output over Displayport/HDMI and can then figure out what is going on with USBC (alt mode).

If none of this helps, do get in contact with support to help ensure the board and memory are working correctly. Let us know how it turns out.

1 Like

TL;DR: I’ve managed to get the mainboard working the printed case.

First off, the red/blue flashing LEDs are (IMO) overly alarming for what they appear to be indicating. From what I have gathered from posts here, and the eventual change in behavior of the unit, is this LED pattern simply indicates that power has been connected while the main cover is off (or that there is no battery).

So, as odd as it sounds, ignore the flashing LEDs and connect your display and press the power button.

Once you can get the unit booting and displaying output (see items #2 and #3 below) you will likely be met with a screen indicating that there is no battery and that standalone mode is disabled. You can enable it at this point. Doing so will disable the red/blue flashing LEDs.

Second, as recently indicated, not all USB-C display options will display early (or as I like to classify them, core) screens. These include the initial logo display, BIOS/system settings, and pretty much anything else prior to the OS level drivers taking over. Note: eGPU output does not appear to be among those that can (or will) output the initial/core displays.

Third, the time to an initial display (if you have a compatible display device) is quite long 10+ seconds. You’ll have to be very patient.

Fourth, one can not boot most Linux installations without first disabling Secure Boot. Secure Boot can not be disable if any device has attempted booting. One either needs to start the system with no boot devices or mash F2.

Can’t seem to edit the original post title to indicate that this has been resolved.

1 Like