AMD Ryzen 7040 Series BIOS 3.03 and Driver Bundle Release

Not sure where to post this to be most useful to the FrameWork people updating the Knowledge Base: The french Knowledge Base BIOS and driver update article, which is ironically written in English, is not up to date. The driver bundle linked is an old one, and it has no link to the 3.0.3 BIOS, stating: “No New BIOS at this time. The Factory-Installed BIOS (3.03) is the latest version”.

EDIT1: wording
EDIT2: This is actually true for all non-English versions of that article, only the English (US) version is up to date.

1 Like

Yeah, fair enough. But since I already had a couple chargers laying around, I decided against getting another one.

I already added the bug to this thread (since it was introduced by BIOS 3.03) and linked Kieran + you. Am I supposed to create a new thread solely for this issue?

Those who tested 3.03 in beta but who don’t want to opt-in beta releases from LVFS in general may now want to disable the lvfs-testing remote :

fwupdmgr disable-remote lvfs-testing

I actually had a similar problem, but from within Windows 11. While I tried updating the BIOS to 3.0.3 (Beta) the official charger stopped working when Windows rebooted to initialize the FW update. This in turn made the BIOS update fail. The charger I then used (Dell 65W from my XPS 13) worked.

For what it’s worth, there’s a newer AMD GPU driver available for Windows (direct from AMD) as of yesterday. It’s only been a day but this one seems to be a little more stable than the previous one for me, which had crashed 3 or 4 times.

Hi, I can’t get BIOS 3.03 to install via fwupdmgr. It says successfully installed firmware, prompts me to reboot, but then throws EFI Error Code: 03 after reboot.

I’m using Fedora 39 Beta. Already run dnf update. Three USB-C + one USB-A modules attached. Anker 737 PD adapter plugged in. Fingerprint reader already updated / working.

I’ve taken steps to attempt the “Linux/Other/UEFI Shell update” method by unzipping the archive in the root directory of the EFI partition of a Linux Mint installer I have, but I’m uncertain if I should really just drop the unzipped folder into any random EFI partition on any random USB drive I have laying around, regardless of the other files that already exist in the partition. I don’t want to brick my system.

Step 5 states, “Let startup.nsh run automatically,” implying I should either be able to see the file, and select it, or it should just start the update on its own (perhaps after navigating to the directory / partition that contains it?). I can browse the directories in the EFI partition, but I only see .efi files, not the .nsh file.

Any help you can provide would be super appreciated! :slight_smile:

I don’t have my AMD laptop yet, but I’ve done the UEFI shell update method on my 11th gen FW13. I took a blank USB stick, extracted the folder and copied only the files (not even the folder, just the files from the folder) onto the otherwise blank USB drive. Then with the USB drive still connected to the computer I re-booted and used F12 to get into the boot menu. I chose the USB drive and the firmware update ran. When the firmware update finished the system rebooted and I went into the BIOS and confirmed the updated firmware. Removed the USB, exited the BIOS and the system booted normally, with updated firmware. I’ve heard that this method cause issues in some cases, but I had zero issues.

Thanks! I tried this, and made progress. In that it recognized the USD drive, and automatically started the process when I selected it, but then I hit the same roadblock a bunch of other people seem to be getting: Error Code: 21.

I had to have the computer plugged in, but be below 100% full, so the system would recognize that it was charging. I let the computer sit, unplugged until it was at 90% or so, plugged it in and ran the update and it worked. I can’t say for sure if that’s what you are running into, but it’s something to be aware of.

Yeah, I saw that folks were running into this. With some even trying different chargers and/or cables and/or USB-C modules. I only have the one charger that’s rated high enough for this, and perhaps the same for my USB-C cable (all the same brand and variant).

I got my laptop down to 96% and tried it, but still had that error. Perhaps that’s not low enough? I do see the light on the module flicker right before I get the error. Wondering if there’s some interruption there.

I also notice some folks mentioned their light being red. Mine is a whitish-green, if that matters. I have seen the red light before, but haven’t since I started paying attention to it.

Got it down to about 87%, the light’s now red / orange, but still getting error code 21

I’ve now tried a different USB drive and the 1 TB storage module. Neither has worked. I’m at a loss, because I don’t have access to any other chargers / cables, and I’d rather not purchase one hoping it works.

I tried my Anker 537 PowerCore 24K power bank (65 W) and it worked! I was able to do the update. Unlike with my Anker 737 wall wart, which took a 2 or 3 seconds to negotiate(?), the light was immediately solid when using the power bank.

I think, perhaps, we could benefit from the BIOS updater waiting a beat before checking for AC power, or before deciding it’s not available?

Because, if it wasn’t plugged in, we wouldn’t even get to the screen that throws the error code. If I remember correctly.

Chassis intrusion protection doesn’t appear to work for me – I asked on Discord and someone said that the red lights that flash indicate that chassis intrusion has tripped, but the machine happily boots (without asking for the BIOS password) despite having opened the device!

Edit: As I say that, I just got the password prompt on my last test, so I’m going to need to try and reproduce this.

Does anyone know if there is an option to disable AMD PSP?

The intrusion detection switch not meant to prevent you from booting up the laptop, merely to inform you that you’re operating on live circuits.


@mackncheesiest @ClaudiuIO @Rufo_Sanchez @Bumblebee @lengau @Matt_Hartley @Maxr1998
I didn’t see that this charging issue was already being discussed in this thread, I had the same issue and already opened my own thread (with a more detailed analysis) about this here:

According to current information, only chargers with less than 3A should be affected (so 60W and above chargers should work reliably).

As of now, it is unclear if it’s actually related to the BIOS/EC/PD controller firmware up-/downgrade, as the issues are intermittent (sometimes it just works, sometimes it works after a few retries), so reports of chargers working before and not working now may be influenced by other factors like state of charge and it just randomly working / not working.

Though no matter if it was broken or not before, this is something that will have to be fixed in future versions.

(Also, funny how the “Steam Deck charger” seems to be a very common PD PSU that Framework owners seem to have :grinning:)


Well, the audience might overlap quite a bit. At the end of the day the Steam Deck is just another repair-friendly Computer in a slightly different form factor. :wink:

This, and also maybe higher chance of an overlap than some random model Anker or whatever else charger found on Amazon :slight_smile:

So half of my RAM is missing. It only shows 8 of my 16 gig. Does anyone else has the same issue?

Check the physical contacts maybe


@LA-MJ Just did by removing the ram and adding it gain and now it does detect the 16 gb :blush:. Weird…


The memory pin layout for the AMD mainboard will result with one memory chip facing up and one memory chip facing down.

I did the AMD mainboard install (Friday-over weekend). I almost the same mistake with putting the memory on the left side of the mainboard.