AMD Ryzen 7040 Series BIOS 3.03 and Driver Bundle Release

Laptop 13 AMD Ryzen 7040 BIOS 3.03 and driver Release

Oct 24 2023

You can check your current BIOS version following the steps here to determine if you are on the latest release.

Our release process follows 1 week as a community beta, and then if no major issues are found, this will be promoted to the latest stable release.

Driver Release

Please note that if you’re on Windows, with this BIOS release you need to update your driver bundle. Please update your driver bundle first, and then update the BIOS second.

BIOS Release

Windows

Instructions for Windows Installer:

  1. Run the .exe.
  2. Click yes to reboot.
  3. Wait for the firmware progress bar to complete, and then the system will reboot.

Linux/LVFS

Updating via LVFS is available.

You can enable updates from testing by following this guide, Release BIOS section.

LVFS may not update if the battery is 100% charged. LVFS uses the battery status to determine if it is safe to apply updates. However if our battery is at 100% and the charger is off, we set the battery charging status to false. In this case you can discharge your battery a few percent, then plug in AC again and run fwupdmgr update.

Linux/Other/UEFI Shell update

Note that if you use the EFI shell update with Windows, you should suspend Bitlocker if enabled before updating using the EFI updater.

Instructions for EFI shell update:

  1. Extract contents of the zip folder to a FAT32 formatted USB drive. Cleanly unmount the drive before physically removing it, otherwise the BIOS update may not function correctly.
  2. Disable secure boot in BIOS.
  3. Boot your system while pressing F12 and boot from the thumb drive.
  4. Let startup.nsh run automatically.
  5. Follow the instructions to install the update.

Updating a Mainboard outside of a laptop

To update the system firmware when in standalone mode, you must set the BIOS menu Setup Utility → Advanced → Standalone Operation to Enabled.

This release supports standalone updates without a battery attached. After rebooting, please follow the onscreen instructions to update your BIOS when in standalone mode, which will require moving the power source between both sides of the Mainboard to allow PD firmware to update correctly.

Security Fixes

None

Enhancements

Fixes

  1. Update AMD Firmware to fix issues with Linux Kernel 6.5 not booting. This update includes the following Firmware C20MP_PHY_2.14.2, IMU11.1.44.0, PSP_00.2D.00.74 and SMU76.70.0.
  2. Fix power button LED behavior when doing a hard power off.
  3. Update power limit table.
  4. Modify sleep LED behavior.
  5. Revert PD workarounds for display output causing a crash on resume from S4.

Component Versions

This BIOS update is a bundle of updates to multiple embedded components in the system.

Not all of them use the same version number.

BIOS 3.03 Updated
EC 66fc8 Updated
PD 0.0.1C Updated
AMD Firmware PI1002B Updated

Known Issues

None


Oct 31 2023

We’ve moved 3.03 out of Beta and into a released state. Edited by @Matt_Hartley

19 Likes

Nice!!!

That was pretty quick

Congratulations!

1 Like

AMD Ryzen 7040 Series BIOS 3.03 is ready for BETA release .

To recap the details from our recent email to our customers:

With BIOS 3.03 that we plan to ship on Batch 2 and 3 systems, we expect broader support in Linux across different kernel versions. In the meantime on 3.02, certain kernel versions have amdgpu drivers that result in the system hanging.

Note that 7040 Series is still a very new platform and AMD’s open source teams will continue to actively develop and improve Linux kernel driver support beyond the specific firmware fix in 3.03.

Here soon you will see the details and instructions to get 3.03 BETA for testing.

This thread will be the official beta test thread for this BIOS release. I have installed it and tested it myself on multiple laptops successfully.

LVFS support will be provided. Details coming soon. Stay tuned.

28 Likes

Thanks, bud!

1 Like

Did you change the BIOS version format from X.YY (such as 3.03) used in your Intel BIOSes to X.Y.Z (such as 3.0.3) in Framework Laptop 13 AMD Ryzen 7040?

An editor at Phoenix is using the X.YY version for the AMD BIOS in the comment below.

AMD apparently validated the new Framework laptop on Linux but did so on the 3.00 BIOS, only for the 3.01 BIOS to break things and in turn is what was pre-loaded on the reviewer units… AMD Linux folks were responsive in confirming and figuring out the solution. Now I’m just waiting on Framework to provide a new BIOS.

How does the result of the BIOS version printing command below look like on Fedora 39 beta on Framework Laptop 13 AMD Ryzen 7040?

$ sudo dmidecode -s bios-version

Below is my result on Framework Laptop 13 11 gen Intel as a reference for someone who is interested in.

$ sudo dmidecode -s bios-version
03.10
3 Likes

As a reference, here is a comment from Kieran for the 11th gen Intel BIOS version format, and linked BIOS information PDF file.

1 Like

Spoke to those in the know, there was a typo and it is fixed - 3.03

5 Likes

Thank you for confirming it. We are humans making mistakes. :slight_smile: I hope that you will correct the version in your next email to avoid a small confusion for users.

Yep, we just made those changes as well. We’re moving very quickly and there were some typos in text only. Previous email included. New email is set and corrected from the appropriate teams.

1 Like

I can understand you guys moving very quickly. Thank you for editing to fix the typos in the first comment on this thread too. There is one remaining typo.

With BIOS 3.0.3

3 Likes

Fixed. :slight_smile:

4 Likes

Cross quoting from a different thread:

I am one of the batch 1 folk, and I’m happy to run a bunch of tests using a bunch of different kernels and/or kernel patches. As I think I mentioned in the other thread, I compile my own kernels anyway. Testing a variety of kernels is trivial.

… but I can’t do any of that until my Framework actually ships. :stuck_out_tongue_winking_eye:

4 Likes

I have mine and I’d love to get support for more kernels. Is it only 6.5.6 and newer that are supported currently with BIOS 3.02? Do we know which kernel versions 3.03 will support? Do we have any sort of timeline for this BIOS beta being released?

Thank you!

My AMD Framework just arrived so I’d love to give 3.03 a try. Currently running Fedora 39 but after an update it seems to have issues while starting KDE. A systemctl soft-reboot does get it into a usable state, it’s just a bit silly to have to do that. dmesg shows that amdgpu resets, so I’m thinking this is related to that BIOS bug.

I’m seeing a lot of KDE does _____ with the new AMD boards. Very likely involving AMDGPU and the bios as you indicated.

We are very actively working on getting the next BIOS release squared away and once it’s ready for testing, it’ll appear on the forums.

6 Likes

I’m seeing a lot of KDE does _____ with the new AMD boards. Very likely involving AMDGPU and the bios as you indicated.

I’m actually having a similar issue with gnome on Fedora 39 Beta. I need to run systemctl restart gdm after everything boots up before I can actually see the login screen.

I put more on that being a Beta OS rather than on the BIOS! Would love if the upcoming BIOS update was the solution :smiley:

(Happy to trial 3.0.3 as well here!)

Arcolinux worked out of the box but would also prefer to have the newest firmware.

Would also like to be able to specify the amount of VRAM up to 16GB in the BIOS though I’m sure that’s a long shot.

OpenSUSE Tumbleweed is a little goofy. GNOME works as long as you use SDDM.

I’m having issues with fwupd for some reason. It was working 2 days ago, but now it’s timing out. I’ve tried blowing away everything including the uefi/tpm/secure boot- but the it’s still timing out. Maybe between updates? Having this issue in both Fedora 39 and Tumbleweed.

I’m interested in beta testing 3.03!