AMD Ryzen 7040 Series BIOS 3.03 and Driver Bundle Release

Any ETA on the next ubuntu C kernel or bios? Don’t need a date, just wondering if it’s days away or weeks away. Same with the ubuntu kernel fixes, is there anywhere to subscribe about that one? I haven’t seen a thread for it.

I ask because my only problems are really with the freezing of the device getting annoying at times.

I’m having issues with fwupd for some reason. It was working 2 days ago, but now it’s timing out. I’ve tried blowing away everything including the uefi/tpm/secure boot- but the it’s still timing out. Maybe between updates? Having this issue in both Fedora 39 and Tumbleweed.

I’ve had some issues with this on Arch as well, where the fwupd service times out trying to do something with the fingerprint reader. Since I haven’t yet been able to get the fingerprint reader working anyway, I removed the fprintd service, and haven’t had any issues with it since.

I’m also interested in testing 3.03, if we still need testers!

Is it possible to distribute the firmware another way than fwupd? I cannot get the fwupd service to start on my system. It just hangs. I’ve disabled fprintd as others have suggested.

This happened to me.

The only way is to download a free windows iso and then install it. Download the framework windows 11 driver bundle and it will correct the fingerprint firmware.

I’ve experienced similar timeouts with fwupd trying to get the fingerprint sensor working, however adding those 2 lines mentioned at the end of the guide to this file usr/share/fwupd/quirks.d/goodixmoc.quirk actually fixed the issue for me and now I can use the sensor.

I’ve experienced similar timeouts with fwupd trying to get the fingerprint sensor working, however adding those 2 lines mentioned at the end of the guide to this file usr/share/fwupd/quirks.d/goodixmoc.quirk actually fixed the issue for me and now I can use the sensor.

Good callout, I just got fprintd re-enabled and working correctly with GDM and the GNOME lock screen, and fwupd is happy too. Now just patiently waiting for updates to be available there. The sensor works without the quirks file, but the quirks file is needed for fwupd

For everyone playing along at home:


About the fwupd I’ve managed to run it using X11 to avoid the amdgpu timout errors and it worked fine.
I’ve used the live version of Manjaro XFCE for that.


@Peter_Wren on Manjaro have you had any issues with high power drain while sleeping?

I don’t daily drive Manjaro I only used the live version to use fwdupd.

1 Like

I found that using kernel 6.1.0-1023-oem fixed the fwupd not launching issue. Once I got it running I was able to follow this guide to get fprintd working just as wgalen posted.

So just to be clear, we do not have any means to get the 3.03 BIOS and try flashing our AMD devices yet? Do we have any sort of timeline for when the release (beta or otherwise) will be made available?


At this time the BIOS provided to you on your laptops is where we want you at for now. Once we have our next release ready, we will make it known.


It is stated in the knowledgebase that Batch 2 and onwards will ship with BIOS 3.03. We have received word that Batch 2 units have started to ship. Do these units already include 3.03?

Any update on 3.03 for the rest of us? Really trying to see if this will solve some of the issues we have had.


We are focused on getting this done and therefore, remains actively worked on full time (I am sitting on a test release right now, testing it very hard). This is coming, no, I have no ETA at this time.

Now, I use both Ubuntu 22.04.3 using OEM C (and VETTED with uname -r as active) and Fedora 39, on AMD, same BIOS. Even there, you will see some issues, but if you are on an untested Linux distro or on Ubuntu non-LTS, results may be less than great.

For everyone reading this on AMD Ryzen 7040:

Note that 7040 Series is still a very new platform and AMD’s open source teams will continue to actively develop and improve Linux kernel driver support beyond this specific firmware fix. We’ll keep updating our guides to point you to recommended configurations, and we’ve created a Community wiki post (here) with an overview of the latest status.

A reminder:

The version 3.02 BIOS that ships on your laptop has issues with certain kernel versions. This is resolved in 3.03, which will be available as a Beta release soon. In the meantime to get started, you can follow our guides to get set up with distros that work on both 3.02 and 3.03:

  • Fedora 39 Beta - This works “out of the box”, and is the distro we would most recommend at the moment. You can run the beta and update into the release state in mid Oct.

  • Ubuntu 22.04.3 - Follow this guide, make absolutely sure you follow the instructions at step 9 for AMD Ryzen 7040 Series as the default kernel is a very bad time - after following this, verify you loaded the right kernel on reboot with uname -r - the Zenity pop up will likely appear if step 9 is followed but the kernel is wrong.

This will be the last update until I have something new to report. The moment I do, you will be the very first to read it here.


That’s why this is confusing; there was mention that batch 2 would only ship once that was available since that’s what we were promised would come pre-installed but some of out batch are already shipped? Very hyped for getting laptop and don’t mind tinkering around with 3.02 but would love if we had official confirmation that we are in fact NOT waiting for 3.03 afterall, or if we’re getting the beta early shipped to us?

It’s possible that Batch 2 laptops are being flashed with 3.03 out of the factory but the tools for individual users to do it themselves is not yet available. It seems they already have an internal release of 3.03 that they are testing.

That’s what I’m hoping but the last official word was that they wouldn’t do this til november so it’s a confusing situation

Was it November? If I recall correctly, it was somewhere around the end of October.

I think this confirms it: “For final assembly into laptops and pack out, we currently plan to align that to factory-readiness of our next BIOS version, 3.0.3, with shipments starting later in October”. Found in one of the earlier emails they sent out.

AHA okay so I did totally misremember that then, absolutely fantastic then! Sorry for the misunderstanding then

I’m having a weird graphical issue that I can easily repeat on my computer. In Fedora 39 running Gnome (originally found on Arch and switched to confirm it still happened) if I plug in multiple displays open a normal amount of windows then unplug a screen I get white graphical issues and sometimes flashing screens.

Sometimes if I can see enough I can change my screen resolution down really low, then back, and sometimes that fixes the issue. Holding power then rebooting solves it every time. However that does really limit the whole point of having a laptop.

I’m mostly curious, does that seem like the type of issues that would be addressed by a new bios, or would that be more a contact support because maybe my computer is bad? To me, it looks like graphic drivers issues, but I don’t see other posts about it so maybe it’s just me.

1 Like