Arch Linux Hardware Video Acceleration

Is anyone else having trouble getting VA-API / VDPAU working on their machine? From what I’m reading the hardware (i7-1165G7 in this case) is supposed to support it fine.

I’ve followed the guide for setting it up, but I just get:

libva error: /usr/lib/dri/ has no function __vaDriverInit_1_0
vaInitialize failed with error code -1 (unknown libva error),exit

When I run vainfo.

That’s using the intel-media-driver and with LIBVA_DRIVER_NAME=iHD set globally.

I tried with the older libva-intel-driver but got the same error.

I’ve also enabled Early KMS Start after reading that it might be related.

Am I missing anything obvious?

1 Like

Did you read & follow section 1.1?

@Prince_Cooper I believe so. I’ve got both intel-media-driver and linux-firmware installed. That’s the correct driver for this hardware right? What am I missing?

I had a problem like this, which turned out to be a problem with an Arch package. See this for the bug report (now fixed): FS#74330 : [intel-media-driver][intel-gmmlib] init failed - your problem might go away if you update?

@Robert_Ricci I think you’re right. It seems to be working now (according to vainfo) .

With mesa 22.0.1-3 and intel-media-driver 22.3.1-1.

Now to get firefox to actually use the hardware decoding…

@BenVosper Did you find a way to use hardware encoding on firefox?

I know vaapi is woking, checking with vainfo command.

Followed this archwiki to let firefox use vaapi (hardware decoding), but I don’t seem to get it working.

MPV and VLC work with vaapi no problem, check with sudo intel_gpu_top command.