BIOS guide

I know this is an older response, but @warehows123 I noticed you had some problems with your usb ports and charging. I have a i5-1135G7 I duel boot both Win11 and Fedora36, I did the update to 3.10 and I had problems with everything, the battery would still drain while (fully powered off) and if I plugged in anything into the usb ports it would not detect them (usbA) I found an article on here about resetting the bios defaults, not in the bios but by disconnecting both batteries and plugging in the power cable until the red lights flashed. Once I did that, everything is working perfectly, the battery drains ZERO percent over night and all usb ports work perfectly. Hopefully if anyone is having similar issues can follow that guide and it will help them!


I have a 12th gen i5, the menu apears to say Intel ME, and its “password” locked,EDIT: found it. default password is: admin
source: intel MEBx settings

Using the password rules as a guide, i was able to set a new password. thus, not called AMT, its the Intel MEBx menu under the F10 key upon booting.

Intel® ME password must be changed from the default password prior to gaining access to
certain ME options. Intel® ME passwords must be between 8 and 32 characters long, have
at least one upper case character, one lower case character, one number, and a special
character (for example: !, @, #, $, %, ^, &, *).

(sorry for the first one to be blurry)

I updated the BIOS beta version for the 11th gen as 3.17, as I saw the 11th Gen Intel Core BIOS 3.17 Release .

Is it? From the post I understand it is a release We are happy to release BIOS 3.17.

In my understanding, if it is the official version, it is written at Framework Laptop BIOS and Driver Releases (11th Gen Intel® Core™) . But there is no 3.17. This situation happened on version 3.08, 3.09 in the past.

1 Like

I suspect it’s because it’s still in beta, as the title in [RESPONDED] 11th Gen Intel Core BIOS 3.17 Release says… :slight_smile:

1 Like

Note that that thread title was changed from the “… 3.17 Release” to the “… 3.17 Beta” two hours ago by nrp, possibly after this conversation was seen.


Hello all,
I am trying to install Fedora 37 (after several failed Ubuntu 22.04 attempts). Can someone explain to me whether the InsydeH2O “UEFI BIOS” is… UEFI or BIOS?

I think I saw a reply from a Framework employee in another thread where they basically said, yeah, it is confusing – go with UEFI, the “BIOS” tag is just a ‘buzzword’ if you will, or legacy holdover. Is that correct?

According to the Fedora installation guide, this is a key setting that could corrupt your entire installation…!

Yes, it is UEFI. As noted, calling it BIOS is technically incorrect and using it as a “buzzword” is sometimes confusing to some users.

Mind you I have to admit to referring to it as BIOS on occasion, even when posting here recently in the “Fingerprint on Fedora” thread. I’m definitely going to need to stop doing that. Installing in the wrong mode as a result of such a misinterpretation/misunderstanding would most likely end up with needing to do a whole new installation; not a fun prospect for most users.

Regards, yeti.


Thank you Yeti! Glad to have that confirmed.

I just got Fedora to install on the first try! As a software/hardware developer, it might be more suitable for me than Ubuntu. But honestly I’m just happy to have anything that runs! I tested the USB A expansion card with a USB mouse and it worked. Rebooted once, no problems.

I did notice that the screen brightness was jumping up and down. Additionally I will hold off plugging it in for the moment since there are/were some issues with plugging in within two minutes, and I’m not sure what the firmware version is.

In fact, I’m just going to power it off now, leave it off, and see what the battery % is tomorrow morning… should hold at 77% if all is well in firmware-land.

1 Like

I just replied to you in the Introduction thread it seems :laughing:. I put in a comment re integrity checking of the iso file. I have on a few occasions had problems with Ubuntu installers being corrupted. Though if you use a bit-torrent the checks are automatically done. If manually downloading the installer file you should always verify the download with a sha256 checksum. Cheers, yeti.

1 Like

Good to know thank you! Just installed Deluge from the snap store. Cheers Yeti!

Regarding the battery, I booted it up today and it was at 76%. So it had dropped 1% either overnight or during the boot. It’s down to 63% already and I’ve had it on less than half an hour. Assuming a full half hour of use per -14% charge, that’s about three and a half to four hours of battery life, which is not amazing (as forewarned).

edit: at 27% less than two hours after booting! we are on track for a four-hour battery life, tops. Have not attempted the techniques for shaving battery use yet; I want to verify that the OS will charge and boot successfully after a battery drain cycle, as some people have been unable to do that.

Edit: Successfully rebooted after fully draining the battery.

1 Like

:grimacing: :grimacing: :grimacing: best of luck Kris!

1 Like

Thanks William!

At 20% I got a notification that one hour and eighteen minutes of battery life remained. I took a screenshot and the window manager froze, then suddenly started glitching out. Additionally the screen started tearing (dark/purple colors running vertically).

Closing my second firefox window fixed this issue for the moment!

I am really noticing the smaller screen however! Discord as well as Discourse feels cramped.

My last two BIOS updates have resulted in the laptop (11th gen) being in a semi-bricked state. It sits there with screen blank, periodically power cyclic according to the power button light, flashing LED codes on the side LED. If I interpreted them properly, it looked like it was continuously redoing memory retraining.

Doing Fully Resetting the Mainboard State - Framework Guides recovered the machine to full working state both times.

I thought the first time it might have been me interrupting the update somehow (eg thought it was finished but force power cycled it). But on this most recent 3.17 update I left it alone plugged into power for over an hour (I forgot about it) so I assume there was no chance of it having been interrupted.

I have done a number of other BIOS updates with no problems. This most recent time was via LVDS. I don’t remember what I used the last time it ended up in a bad state - might have been LVDS or UEFI shell.

EDIT: Hm, it seems to brick every time it suspends, which is the same behaviour I saw before. I think I’ll need to re-flash it.


Just wanted to have it on record for the Framework team (will send a message, too).
I use a bios password on boot, and for the first month it worked flawlessly. Recently, it still works, but there is significant and random/variable delay between when I press a key and when it registers on screen. I use capital letters in the BIOS password and this sometimes causes them to not register correctly unless I hold the shift key down the whole time from when I press and let go of the letter key until the character entry shows up on the screen. I don’t know why all of a sudden it became unpredictably laggy like this. The rest of the BIOS is a bit laggy too, but I don’t remember if that was always like that or not. It’s not a huge deal; it just takes a bit longer and a pinch of patience to boot up the computer. But something that could be addressed in an update or something.

I found others having the same issue and confirmed the solution in this thread.
:melting_face: :ok_hand: :+1: :pinched_fingers: Took a little digging to find but good to go!


I just checked my BIOS version and I apparently have 3.05

Hi @chrissobel see this thread on the minor bios version difference for 12th Gen Intel mother boards.

I think we might be able to update this page’s first comment with the information about the Framework Laptop Chromebook Edition now. It’s such as the knowledge base page, the BIOS product/vendor/initial version and etc.

Guys who bought the edition, can you report the info on this thread? Thanks.

1 Like

Hey folks, apologies if this is not the right thread to post this on, but does anyone know if there is a way to disable secure boot from within Linux, i.e. edit a BIOS setting via a script?