Can't boot stuck in Fedora Emergency Mode

I was in the midst of using my laptop when the screen went blank. This has happened before but it came back with in a few seconds or after a reboot. When I rebooted this time I was put into emergency mode. Everytime I try rebooting and I have tried using previous kernel versions I still end up in emergency mode.

I’m an absolute Linux noob so I really don’t know what to do with emergency mode. I have run journalctl these warnings show up in the log

ACPI Bios warning (bug): Optional fadt field pm2control block has valid length but zero address: 0x000000000000000/0x1 (28238628/tbfadt-615) (I don’t know if I got all the "0"s)

pci 0000:00.2: can’t derive routing for PCI INT A
pci 0000:00.2: PCI INT A: not connected

BTRFS error (device nvme0n1p3) bad tree block start, mirror 1 want 89916886-40 have 89897861120
BTRFS error (device nvme0n1p3) bad tree block start, mirror 2 want 89912688648 have 89897844736
BTRFS error (device nvme0n1p3) open_ctree failed
Failed to mount sysroot.mount - /systroot

ucsi_acpi USBc000:00: ucsi_handle-connector_change: Get_Connector_Status failed (-5)
ucsi_acpi USBc000:00 possible UCSI driver bug 1
ucsi_acpi USBc000:00: ucsi_handle-connector_change: Get_Connector_Status failed (-22)

When I enter the UEFI setup my harddrive is listed twice. I don’t know why that would be. I used a brand new drive and did a clean install of Fedora 39 using the default partitioning.
I have managed to boot to a livedisk instance of Fedora 39 when I run the disk app I only see one copy of my drive. It’s divided into three partitions (I guess the default Fedora setup) partition one is a 629 mb FAT; partition 2 is a 1.1 GB ext4; and partition 3 is btrfs (it is listed as not mounted). When I try to mount it I get an error "can’t read superblock on /dev/nvme0n1p3 (udisks-error-quark,0)

Fedora Kernel 6.6.7-200.fc:39 x86 64
Framework 13 7640u
Bios 3.03

log entries point to problems with the SSD. When you boot off the live disk (USB stick I assume?), and if it has the smartmontools package in it, you can check the drive using this from the terminal:

sudo smartctl -a /dev/nvme0n1

The output may well show if there’s a problem with the drive.

However I don’t think that the Fedora install ISO contains smartmontools. There’s supposed to be a live ISO image with the package installed which you could flash onto a USB drive, but I’m getting a 502 error from the site atm.

Meanwhile, try re-seating the drive.

Hope others will have better options to suggest.