[RESPONDED] Stuck in emergency mode

Hello. Running fedora 39. Everything has been great for a few weeks, no issues at all. Then last night my track pad stopped registering clicks unless pushing with more pressure. Not sure if that is related to what’s just happened but it crashed in the middle of browsing on Firefox. Now I’m stuck in emergency mode. I’m an actual Linux noob so I have no idea what’s going on here. I ran the journalctl command and there’s some orange and red. I assume that means there’s a problem… I’m not sure how I can dave this lot to show it to anyone. I appeared to be able to boot and install from USB drive but I didn’t want to lose everything that’s on there. Not much honestly just my notes which I’d prefer not to lose but it’s not the end of the world. Lesson learned for backing things up. Really have no idea what to do now so any advice would be much appreciated.


System: AMD Ryzen™ 7 7840U
Storage: WD_BLACK™ SN850X NVMe™- M.2 2280 - 1TB
Memory: DDR5-5600 - 32GB (2 x 16GB)

I tried reseating nvme sdrive with no change.

edit: i have opened a ticket.

Edited the subcategory and the tag of your post so it can reach the right audience :saluting_face:

Thank you :saluting_face:

This is the end but there’s a few more red and orange lines above.

figured i may as well type out the other errors. i wrote them here in order. the red ones are labeled, if they arent labeled then theyre orange.

ACPI BIOS warning (bug) optional FADT field Pm2ControllerBlock has valid length but zero address

SPeculative return stack overflow: IBPB-extending microcode not applied!

speculative return stock overflow warning: see Speculative Return Stack Overflow (SRSO) — The Linux Kernel documentation for mitigation options
pci 0000:00:00.2: cant derive routing for pci int a
pci 0000:00:00.2: pci int a: not connected

i8042: pnp: ps/2 appears to have aux port disabled, if this is incorrect please boot with i8042.nopnp
i8042: warning: keylock active

devive mapper: core config_ima_disable_htable is disabled. duplicate ima measurements will not be recorded in the ima log

integrity: problem loading x.509 certificate -126
integrity: problem loading x.509 certificate -126
integrity: problem loading x.509 certificate -126
/usr/bin/setfont failed with exit status 71.
/usr/bin/setfont failed with exit status 71.

gpt: primary header thinks alt. header is not at the end of the disk.
gpt: 4159671 != 60088319
gpt: alternate gpt header not at the ende of disk
gpt: 4159671 !=60088319
gpt: use gnu parted to correct gpt errors

the rest is in the picture.

Hi @NorrinRadd ,

Can you try running a fresh fedora 39 linux live?
and let’s see if same error, you can also copy your personal files if you ever need to reinstall
disk should show on file manager while using live.

i tried this after a mod suggested it on our sub reddit and unfortunately the drive doesnt appear to be mountable.

I have the support ticket open but need to get this sorted ASAP as I need this for school and the term, of course, started yesterday. I have the following generated by a command the support rep gave me to run. I suppose i could try and copy and paste their contents if someone knows which one we need to look at. At this point I’m trying to determine if ill need a new drive so i can get one on the way as soon as possible so if anyone can confidently say “ya that drive is toast” i can at least get an order placed. if this winds up being something fw replaces i can always use an extra drive so it wouldnt be to much of a loss. Please let me know if any of these files would be helpful. Im not sure how to interpret them.

edit: on second thought, i have a 128gb usb drive that should arrive tomorrow if the coming storm doesnt delay it. I should be able to just run it off that which will buy me some more time.

In your screnshot I see 2 issues. BTRFS errors in the screenshot and GPT errors mentioned by you later on.
If that is the case, usually the disk partition structure is broken. That is not good because you will need to know the partition start/end to restore it before giving btrfs the chance to actually perform a filesystem check.
If I were you, I’d dump fedora and install ubuntu (has proven to be more stable), and use ext4 Filesystem instead of btrfs (ext4 is more stable and way older then btrfs - note I started with xfs, then ext3 etc. and tested them all since end 1992).

1 Like

Hey thank you for the advice. Definitely a but bummed to hear this but I cant really have this happen again at least while I’m working on my masters. I will likely do as you suggest.

edit: or i can just run fedora on ext4 right?

yes - fedora is right.
A little advice here: install yourself a nextcloud instance somewhere, and make sure your masters storage directory is configured in the nextcloud client to be synced to the cloud storage.
alternatively, make sure you always have a backup of your master!

Doing that with my daughters, and that has saved them quite some hassle (then I installed their systems under KDE Neon, and since then they didn´t have issues).

1 Like

yes my lesson has been learned on back ups. I have been researching nextcloud and went down the rabbit hole of self hosting but given my current skill set, im not there yet. Once im back up and running getting set up with a nextcloud provider will be the first thing I do. any suggestions on providers or are you self hosting?

I host everything myself @ home :slight_smile: Website, nextcloud, mail, DNS etc.
Best way to learn how things work :slight_smile:

well hopefully it wont be too long. I look forward to the project i just need to make the time.