Can't update the BIOS (FW16)

I just got a new framework 16 (AMD Ryzen™ 7 7840HS), and I wanted to install on it the new BIOS 3.03 update. (My computer is running Linux Mint Cinnamon Edge). I followed the instructions (Framework Laptop 16 BIOS and Driver Releases) but when after I tapped F12 during startup I didn’t see an option to boot from the thumb drive. What can cause this problem, and how can I fix it?
Thank you

It’s hard to say for sure, but a common problem is just hitting F12 once or twice, and missing the window of opportunity. You might need to “spam” that key – hit it repeatedly, many times, until the menu comes up.

You might also have the BIOS settings set to require Secure Boot, or have some other setting that would prevent you from booting the firmware-update thumb drive.

All I can say for sure is that it can be done, because I did it a couple weeks ago myself.

You can also just use the built in capability of linux.

sudo fwupdmgr get-updates
sudo fwupdmgr download
sudo fwupdmgr update
sudo shutdown now -r -t 0

Upon reboot, it will updat the BIOS. Be patient, it takes a while!

Thank you for the suggestion. I tried the first line in the terminal, and, after asking for my password, it told me that “Command not found” and “Use fwupdmgr --help for help” (I don’t know what the second line means). Do you have any suggestion on how to deal with that? I am using the Mint, not Ubuntu. Does that make a difference?

Thank you.
I spammed the F12 key, and it send me to the menu, but the option to boot from the USB didn’t appear in the menu. I confirmed that Secure Boot is disabled.
Do you remember anything about how it worked for you that might be able to help me?

Ok. So it is not installed. Make sure you install the firmware update utility first:

sudo apt install fwupd fwupd-signed

The commands should work after.

Thank you for your help. I tried what you suggested, and this is what I got. (see attached screenshots). What should I do now?

Yea, I remember, the download is when you use a different repository (I made it when it was still beta - see: Framework Laptop 16 Ryzen 7040 BIOS 3.03 Release and Driver Bundle - #109 by Jorg_Mertin).
Just run:

sudo fwupdmgr update
sudo shutdown now -r -t 0

and when the update went through, reboot the machine.

Ok. I tried that, and this is what I got:

What should I do?
Thank you for helping me

You have to be online to download the BIOS.

I don’t understand. I was connected to the internet.

If you followed the Linux/Other/UEFI Shell update instrutctions of “Framework Laptop 16 BIOS and Driver Releases” page, Framework Laptop 16 BIOS and Driver Releases, the extracted files of the Bios update zip file should appear on the fat32 formatted usb drive as 1 folder and 3 files, is this what you had (there will be a hidden folder if you are also showing hidden files). With TPM set as hidden, in the BIOS, I had the usb drive appear in the Boot choice in the F12 Boot selection.
Select it, and I think the update worked automatically from there.

The “could not resolve host:” is a clear indication that the DNS request failed. Most often this happens when you are not connected to the internet.

If you only had 1 folder on the usb drive named, “Framework_Laptop_16_Amd_Ryzen7040_BIOS_3.03_efi”, then the drive will not appear in the F12 boot devices.
The usb drive must have the extracted contents of the “Framework_Laptop_16_Amd_Ryzen7040_BIOS_3.03_efi” folder visible at the top level of the drive for the drive to be shown in the F12 boot choice for the update to work.

I made sure I was connected to the internet and I tried again. This is what I got this time:

Do you have any idea what the problem is now?
Thanks for your help

Thanks for the tip. They weren’t visible, so I changed that and tried again, but it still didn’t appear in the boot choice. Any idea why?

Have you seen this knowledgebase page, Updating BIOS on Linux? This page seems more informative than the other BIOS download page.
I prepared my usb drive from a windows 10 PC.
If you prepared your usb on a linux OS and didn’t unmount the drive after prepping the usb drive, maybe thats why?
Also, the amount of charge of the battery, maybe it has to be less than 100%?
Also, " Specifically how to disable Secure Boot in the BIOS On AMD Ryzen 7040 Series" on the abovementioned page?

Something is blocking the access to

If you go to that address with a browser, does it open normally to the LVFS web page?

Something is blocking access to the pages (as @inffy mentioned).
The reason I prefere this way - is that it is plain simple compared to all the other error prone methods. You call it, you reboot, it installs, you reboot and done.
And even when I use the Beta version, it simply worked.

I think it was a problem with my internet. I connected to a different internet, wrote:
sudo fwupdmgr get-updates
sudo fwudmgr update
(I didn’t need the shutdown command because when it finished downloading it just asked to restart)
and it updated no problems.
Thank you very much for your help!

1 Like