Charger connect and disconnect in a 2second Loop after wake up from sleep | GaN adaptative mini power

It started with my 14 month Ugreen Gan adaptative mini power 65W charger that I used without a problem with thinkpad E590.
It started to unconnect then reconnect, which is normal behaviour when you plug two device to the multi USB power supply.
Also it does it One time , I guess to adapt the power but then it does it in a LOOP every 2 seconds it disconnect and connect power !
So I ordered an Anker power supply and it does the same thing after wakeup from sleep when I open the lead of my laptop.
It goes away with the anker when I disconnect physically the cable and reconnect, so easy workaround! But I am concerned it might end like the Ugree not working anymore
CURRENT I AM USING :

Previous Ugreen not working anymore with FW but still working with thinkpad E590

1 Like

Check the video.
For the first time I waited 20 seconds while snapping the video and after doing on/off 15 times it stops and just charges ! Usually my workaround is to unplug the power.

Update 30 minutes later it came again, so this time I unplugged the usb C from the laptop and replugged as usuall. I suppose that it will work as every morning now :wink:

1 Like

I still have this power connexion loop in the morning, when back from stanby mode (closing the lead).
I tried to switsh from one port to the other side directely on the motherboard (no dongle) I have the exact same behaviour :

  • power loop on the top left
  • after 15 secondes change to bottom right mother board usb c = power loop too

This morning after trying this I couldn t even get the computer to stop looping. Normally plugging unplugging get it back.
I had to do a complet reboot, now its back.

I have to confirm that but this morning the problem is gone for the first time in 2 monthes !
I updated to kernel 6.0.7 on ubuntu mate 22.04

Still buging. Suprised no one else has this on ubuntu 22.04.
I feel like the HDMI module might increase the phenomenoneā€¦ I had 5o shutdown the computer to get it to charge lately.
Looki g forward to the BIOS update

Hi @Iann_C, this might be tricky to diagnose as I am using the charger provided by Framework exclusively. I tried looking at the video, but it does not appear to be available.

Three questions:

  • Is this to power the Framework only or are you also powering other devices at the same time?

  • Which expansion cards are in use and have you tried all but USB C only?

  • Both of these after market plugs have USB C and USB A connections. At the plug(s), are they connected USB C or with the USB A end?