Clock stuck at .39Ghz

When the laptop is in this state, does it show that it is charging from the adapter? Also what is the side LED on that side of the laptop showing?

Also if you move the charger to a different port on the same side does the clock still drop to a slow speed?
Electrically prochot is designed to throttle the CPU to minimum speed when the system is too hot, or when power events change. So this is tied to the PD controller managing each port. When a port is plugged in or unplugged it should throttle for a few milliseconds and then go back to normal. However if there is an issue with the port it may cause prochot to be low as a safety measure. One issue we have found is that the EMI sticker can sometimes cause this behavior on specific ports.
Have you tried reapplying the EMI sticker as mentioned elsewhere in the thread?

I think it still showed as charging but am not sure. Don’t know about the LED or changing to a new port; if it recurs I’ll try that. I have not done the EMI sticker fix, will do it this weekend and see if things resolve but this is infrequent enough that it will be hard to say for sure.

At what point with an issue like this will the framework team provide a RMA/part replacement? And are shipping & other related costs covered by the warranty?

Hi Cameron, we cover shipping costs and the cost of the replacement module in cases where there is a manufacturing issue on the item. In this case, we haven’t seen a consistently reproducing scenario, and so we want to continue to work with anyone who has seen it occur to find the root cause. If we determine that there is a hardware issue on someone’s mainboard or other module causing the issue, we would do a replacement within the warranty period.

1 Like

This happens to me occasionally. Sometimes I’m playing a game while charging. Framerates would go way down and if I unplug my charger, I’m back in business. However, fan wasn’t at max speed though so perhaps it is overheating by for some reason the fan is not being spun up to it’s maximum speed to cool things down?

Same issue here with two different chargers on two different usb C ports.
Charging the whole time

BD PROCHOT on throttlestop.
Temps in the 40s-50s
Webbrowsing in chrome
BIOS updated to latest.
Room temp 72F
Never has happened on battery.

Log attached. Started log with it at 400mhz. Detached power and reattached at some point which solved the issue for a minute, then it came back.

1 Like

Hey Community,

Does your CPU Frequency suddenly drops when you connect the (PD) power adapter?

I am noticing on windows 10 21H1, in task manager, my frequency drops to 0.3GHz.

Can someone please confirm?



I noticed weird CPU freq drops. But I didn’t have to plug anything (USB C power adapter was already plugged in).


I see several threads got merged into one. What is the consensus on the issue? I have seen a few folks prior to me posting that they can repro the issue, but haven’t seen a resolution yet.

@nrp , has there been a conclusion that I have missed?

The issue is when a 60W PD Charger is plugged in, the CPU frequency drops to 0.39GHz.

NOTE: I am using left-upper slot for USB-C charging.

This is an issue we’re trying to determine the root cause of, so we definitely want any information we can get on it. Could you check if the issue occurs when you plug power into any of the other bays? If it is occurring specifically in one bay, could you try the steps here: An Expansion Card bay on my laptop does not function correctly

1 Like

@nrp , I have thoroughly tested every single slot with two USB-C connectors that I have and all of them are functioning properly.

Now what puzzles me is the fact that everything is now working as expected. This appears to be an intermittent problem, however I am unclear how to reproduce it with 100% success rate.

Steps I have taken to repro it:

Scenario 1 - System is turned off and the power is connected while system is off.

  • Turn system off
  • Connect USB-C in slot $position
  • Connect Power
  • Turn on system
  • Open task manager, monitor CPU Frequency
  • Open Brave and navigate to
  • Shutdown system
  • Change USB-C in slot $position+1, repeat.

Scenario 2 - System is already power on, connect the power adapter

  • Connect USB-C in slot $position
  • Turn system on
  • Connect Power
  • Open task manager, monitor CPU Frequency
  • Connect power
  • Open Brave and navigate to
  • Shutdown system
  • Change USB-C in slot $position+1, repeat.

Scenario 3 - system in sleep/hibernation

  • Connect USB-C in slot $position
  • Turn the system on
  • Open taskmkanager and monitor CPU frequency
  • Open Brave and navigate to
  • Put system to sleep
  • Connect power
  • Wake up system
  • Shutdown system
  • Change USB-C in slot $position+1, repeat.

I cannot get a grasp on what exactly was happening earlier.

Bottom line, the system is great! I wish I could be more useful in troubleshooting it…


Thanks, definitely let us know if it starts to occur again, and what the sequence of steps were when it happens.

1 Like

Thinking now that my thread Ubuntu 21.04 Lagging (particularly touchpad) after a decent amount of uptime? - #7 by John_Flatness is related to this one, I opened up the machine to check those stickers (it’s a Batch 2).

I noticed a couple odd things, and given them I didn’t actually complete the recommended process.

On the left side the top port that seemed to be most at issue had a kind of loosely-attached sticker on it. The bottom one as far as I can see doesn’t have a sticker at all. I haven’t fooled around with these so it must have come like that. Photo follows (it’s a little hard to see on the picture but that top sticker is kind of barely stuck on there):

On the right side, similarly only one of the ports seems to have a sticker, this time it’s the bottom one.

Ultimately all I did was push the top-left sticker down more firmly onto the top of the port and close the laptop back up. Hard to say if that’s had any effect since the problem is kind of unpredictable.

Anyway, is this “2 stickers” situation normal? It doesn’t seem to match the photo or text in the knowledge base article.

1 Like

For me, I’m starting to think it is related to the level of charge. It has been 3/3 times repeatable for between around 74% and 86% battery charge to have the stuck 0.39Ghz clock. For example, if I plug in to charge at 65%, I have no issue until about 74% and the clock goes back to normal above about 86%. I haven’t had trouble above 95% and at 100%. I haven’t explored charge levels below 50% with this issue in mind yet, so no real data on that.

I attached some cpulogs where I start the log, plug in to charge about a minute later and let it run.

1135G7 and 21H1
original BIOS 3.02
S0 modern sleep state disabled, so running S03
I tried fast boot on and off, I looked at the USB-C connectors and all 4 shields are good as described in the knowledgebase. I tried moving the charge connector to all 4 locations and both connector orientations with no change. Never had it happen while running only on battery. It can happen with a cool machine that has been shutdown for hours, or a warm one.

Starting at 70% charge and there is no issue:

Starting at 84% and at 86% the issue is gone and the log continues to 91%:


Hi everyone! My laptop (batch 3 DIY i7-1165G7) has been doing this too. I am running 21H2 with all the newest updates. I updated to BIOS 3.03 (beta) and the beta drivers after the first time it happened. Sadly it just happened again to the point that the whole computer just froze and the clock speed never went up after unplugging the power.
I am using a 65W USB PD charger from RAVPower and this has happened using the top left and top right ports for charging.

It seems to me like @Kyle_Adams is right because all three times that it has happened to me, my battery has been around 75%

EDIT: Just tried it and same thing happens on the other 2 ports


I have to say that if this issue is solved. This laptop would be perfect. Unfortunately, this issue is intermittent when charging. Once it occurs I would then need to disconnect my charger for clock speed to resume to normal. Happens with any port that plug in my charger.

1 Like

@nrp , circling back on this, I am starting to see some consistency in repro steps. Up to 84%, the laptop seems to behave as expected as if there is a pattern, charging from 0-84% is perfectly fine. As soon as it reaches 84%, it reduces the frequency to 0.39GHz and becomes unusable. As the comments mentioned earlier, this appears to be consistent with what I am experiencing as well.

Been all day on zoom calls and as soon as the battery reached 84%, it locked at 0.39GHz, once unplugged the CPU speed went to normal, re-plugged and it again got stuck at 0.39GHz.

I let it run on the battery for most of the day and only connected the charger when it hit 40%. Charging up to 84% is flawless, no issues. Once it hit 84%, 0.39Ghz again.



Chiming in,

I’m also seeing a similar drop in clock speed using a third party (Anker) 65W PD charger. I’ll test other third-party chargers and cables later, but this is definitely something I’m seeing too.

1 Like

Has anyone reported this issue using the Framework charger?


@Enjewneer , interesting observation. I am using Anker, Aukey and PrimeCables PD Chargers 65W.

All three show same behaviour.

1 Like