Clock stuck at .39Ghz

Thinking now that my thread Ubuntu 21.04 Lagging (particularly touchpad) after a decent amount of uptime? - #7 by John_Flatness is related to this one, I opened up the machine to check those stickers (it’s a Batch 2).

I noticed a couple odd things, and given them I didn’t actually complete the recommended process.

On the left side the top port that seemed to be most at issue had a kind of loosely-attached sticker on it. The bottom one as far as I can see doesn’t have a sticker at all. I haven’t fooled around with these so it must have come like that. Photo follows (it’s a little hard to see on the picture but that top sticker is kind of barely stuck on there):

On the right side, similarly only one of the ports seems to have a sticker, this time it’s the bottom one.

Ultimately all I did was push the top-left sticker down more firmly onto the top of the port and close the laptop back up. Hard to say if that’s had any effect since the problem is kind of unpredictable.

Anyway, is this “2 stickers” situation normal? It doesn’t seem to match the photo or text in the knowledge base article.

1 Like

For me, I’m starting to think it is related to the level of charge. It has been 3/3 times repeatable for between around 74% and 86% battery charge to have the stuck 0.39Ghz clock. For example, if I plug in to charge at 65%, I have no issue until about 74% and the clock goes back to normal above about 86%. I haven’t had trouble above 95% and at 100%. I haven’t explored charge levels below 50% with this issue in mind yet, so no real data on that.

I attached some cpulogs where I start the log, plug in to charge about a minute later and let it run.

1135G7 and 21H1
original BIOS 3.02
S0 modern sleep state disabled, so running S03
I tried fast boot on and off, I looked at the USB-C connectors and all 4 shields are good as described in the knowledgebase. I tried moving the charge connector to all 4 locations and both connector orientations with no change. Never had it happen while running only on battery. It can happen with a cool machine that has been shutdown for hours, or a warm one.

Starting at 70% charge and there is no issue:

Starting at 84% and at 86% the issue is gone and the log continues to 91%:


Hi everyone! My laptop (batch 3 DIY i7-1165G7) has been doing this too. I am running 21H2 with all the newest updates. I updated to BIOS 3.03 (beta) and the beta drivers after the first time it happened. Sadly it just happened again to the point that the whole computer just froze and the clock speed never went up after unplugging the power.
I am using a 65W USB PD charger from RAVPower and this has happened using the top left and top right ports for charging.

It seems to me like @Kyle_Adams is right because all three times that it has happened to me, my battery has been around 75%

EDIT: Just tried it and same thing happens on the other 2 ports


I have to say that if this issue is solved. This laptop would be perfect. Unfortunately, this issue is intermittent when charging. Once it occurs I would then need to disconnect my charger for clock speed to resume to normal. Happens with any port that plug in my charger.

1 Like

@nrp , circling back on this, I am starting to see some consistency in repro steps. Up to 84%, the laptop seems to behave as expected as if there is a pattern, charging from 0-84% is perfectly fine. As soon as it reaches 84%, it reduces the frequency to 0.39GHz and becomes unusable. As the comments mentioned earlier, this appears to be consistent with what I am experiencing as well.

Been all day on zoom calls and as soon as the battery reached 84%, it locked at 0.39GHz, once unplugged the CPU speed went to normal, re-plugged and it again got stuck at 0.39GHz.

I let it run on the battery for most of the day and only connected the charger when it hit 40%. Charging up to 84% is flawless, no issues. Once it hit 84%, 0.39Ghz again.



Chiming in,

I’m also seeing a similar drop in clock speed using a third party (Anker) 65W PD charger. I’ll test other third-party chargers and cables later, but this is definitely something I’m seeing too.

1 Like

Has anyone reported this issue using the Framework charger?


@Enjewneer , interesting observation. I am using Anker, Aukey and PrimeCables PD Chargers 65W.

All three show same behaviour.

1 Like

So I just noticed something that may affect this… For some reason my laptop is not going to sleep when connected to the charger. I have not changed any of the power settings from my windows install, but if the laptop is unplugged then it does go to sleep.
Not sure why this is happening to me or if this has anything to do with this issue.

@Rodrigo_Luzuriaga That could be a power setting within Windows or Linux preventing sleep while on charger

1 Like

Edit: Issue starts at 84%, updated original post.

1 Like

@Rodrigo_Luzuriaga Good question. I’m having the issue with the framework charger.


With my tests, it happens to me from 72% to 85%. Before and after those percentages the Ghz go back up.


Probably not necessary, but maybe helpful - Here is a screen recording of it along with a log. Going from 13% to full charge. It happens for me at 74% in this test and the clock begins to recover at 83%. My thought is it has to do with when the charger switches from constant current to constant voltage. It’s very interesting that the clock changes practically at the same time that the percentage display ticks over from 73% to 74% and from 82% to 83%. Could be a coincidence.
Screen recording:



Can anyone reproduce this on linux?


@Kyle_Adams , good sleuthing, I also wanted to note that it sticks around at 1GHz for awhile before it surpasses 2GHz mark, in my case I have to wait until fully charged before it goes back to ‘normal’ clocks.


@shreyasminocha There was someone above who thinks they’re getting this issue in Ubuntu. So it probably isn’t limited to only windows.

1 Like

I’m getting mine soon + will be on arch, so I’ll watch out for this behavior and report anything if I run into it.

@Kyle_Adams, Is there a way you can also log battery temps while charging? Also, what is the ambient temp and humidity of your environment?

@Kyle_Adams, Damn bro… thanks for doing this!