Clock stuck at .39Ghz

Hi @FaultedBeing if you can follow the directions I wrote above using the power gadget it would be a good place to start.

1 Like

Darn, It happened when I had the power gadget running, but not when I had it logging anything. I’ll try to get the log next time but I do have a screen shot of the power gadget’s graphs that cover the period of it dropping to .39 GHz and just when it started to recover.

edit: perhaps it is temperature related? I’m currently idling at low 90s with 40% usage?

@FaultedBeing You using an eGPU? (Just curious since you have nVidia card, I don’t think it has anything to do with our issue though)

@DannyT Yes I am, a 2060 Super. Its worked pretty well so far (with a little tweaking and disregarding this occasional issue (if it is caused by this) :grinning_face_with_smiling_eyes:)

I’d also like to add to my findings, I just ran a benchmark to add some stress to the cpu and see if I could replicate it while logging, and it didn’t drop down to .39 GHz. Although, would there be any reason why the cpu would run hotter when connected to an eGPU rather than not?

I managed to start the log while the computer was at .39Ghz. Actually, it was stuck at .2Ghz this time and a restart was required to fix it.

As I was typing this it happened again, but fixed itself from .39Ghz

Here is a google drive link to a folder of the log of the intel power Gadget, both times started after the issue began (sorry I couldn’t capture before hand)

My clock has gotten stuck at 200MHz a few times on Ubuntu 21.04. A reboot has fixed the issue each time, but powertop shows all cores at 199 or 200MHz. I don’t have many other details yet since I just got the laptop today.

@Kieran_Levin I hit this again and was able to collect an Intel Power Gadget log. In this case it was at .39Ghz when I started the log. Then:

  1. Unplugged USB-C power, saw clock rise to normal speeds.
  2. Plugged it back in, saw clock drop to .39Ghz.
  3. Unplugged again, saw it rise again.

The log: Dropbox - PwrData_2021-9-7-11-49-14.csv - Simplify your life

When the clock is throttled the Intel Power Gadget shows “PROC HOT”, but the “package temp” is only 46c.


ThrottleStop reports “BD PROCHOT”:


This thread suggests that “BD PROCHOT” is from an off-cpu sensor that can signal heat problems from other areas of the laptop. Which explains why this is happening even though the reported package temp is fine.

Just from watching the “BD PROCHOT” indicator, it seems like the throttling only really kicks in when the GPU is reporting it. It’s weird to me that my GPU utilization is at 88+% even when I’m just sitting here in Chrome.

Thanks for the log! Note that the GPU utilization is likely expected, in that the GPU clock frequency is generally running quite low when idling or at desktop. For example, I’m sitting in Chrome with the GPU at ~200 MHz while the CPU is at 4 GHz.

When the laptop is in this state, does it show that it is charging from the adapter? Also what is the side LED on that side of the laptop showing?

Also if you move the charger to a different port on the same side does the clock still drop to a slow speed?
Electrically prochot is designed to throttle the CPU to minimum speed when the system is too hot, or when power events change. So this is tied to the PD controller managing each port. When a port is plugged in or unplugged it should throttle for a few milliseconds and then go back to normal. However if there is an issue with the port it may cause prochot to be low as a safety measure. One issue we have found is that the EMI sticker can sometimes cause this behavior on specific ports.
Have you tried reapplying the EMI sticker as mentioned elsewhere in the thread?

I think it still showed as charging but am not sure. Don’t know about the LED or changing to a new port; if it recurs I’ll try that. I have not done the EMI sticker fix, will do it this weekend and see if things resolve but this is infrequent enough that it will be hard to say for sure.

At what point with an issue like this will the framework team provide a RMA/part replacement? And are shipping & other related costs covered by the warranty?

Hi Cameron, we cover shipping costs and the cost of the replacement module in cases where there is a manufacturing issue on the item. In this case, we haven’t seen a consistently reproducing scenario, and so we want to continue to work with anyone who has seen it occur to find the root cause. If we determine that there is a hardware issue on someone’s mainboard or other module causing the issue, we would do a replacement within the warranty period.

1 Like

This happens to me occasionally. Sometimes I’m playing a game while charging. Framerates would go way down and if I unplug my charger, I’m back in business. However, fan wasn’t at max speed though so perhaps it is overheating by for some reason the fan is not being spun up to it’s maximum speed to cool things down?

Same issue here with two different chargers on two different usb C ports.
Charging the whole time

BD PROCHOT on throttlestop.
Temps in the 40s-50s
Webbrowsing in chrome
BIOS updated to latest.
Room temp 72F
Never has happened on battery.

Log attached. Started log with it at 400mhz. Detached power and reattached at some point which solved the issue for a minute, then it came back.

1 Like

Hey Community,

Does your CPU Frequency suddenly drops when you connect the (PD) power adapter?

I am noticing on windows 10 21H1, in task manager, my frequency drops to 0.3GHz.

Can someone please confirm?



I noticed weird CPU freq drops. But I didn’t have to plug anything (USB C power adapter was already plugged in).


I see several threads got merged into one. What is the consensus on the issue? I have seen a few folks prior to me posting that they can repro the issue, but haven’t seen a resolution yet.

@nrp , has there been a conclusion that I have missed?

The issue is when a 60W PD Charger is plugged in, the CPU frequency drops to 0.39GHz.

NOTE: I am using left-upper slot for USB-C charging.

This is an issue we’re trying to determine the root cause of, so we definitely want any information we can get on it. Could you check if the issue occurs when you plug power into any of the other bays? If it is occurring specifically in one bay, could you try the steps here:

1 Like

@nrp , I have thoroughly tested every single slot with two USB-C connectors that I have and all of them are functioning properly.

Now what puzzles me is the fact that everything is now working as expected. This appears to be an intermittent problem, however I am unclear how to reproduce it with 100% success rate.

Steps I have taken to repro it:

Scenario 1 - System is turned off and the power is connected while system is off.

  • Turn system off
  • Connect USB-C in slot $position
  • Connect Power
  • Turn on system
  • Open task manager, monitor CPU Frequency
  • Open Brave and navigate to
  • Shutdown system
  • Change USB-C in slot $position+1, repeat.

Scenario 2 - System is already power on, connect the power adapter

  • Connect USB-C in slot $position
  • Turn system on
  • Connect Power
  • Open task manager, monitor CPU Frequency
  • Connect power
  • Open Brave and navigate to
  • Shutdown system
  • Change USB-C in slot $position+1, repeat.

Scenario 3 - system in sleep/hibernation

  • Connect USB-C in slot $position
  • Turn the system on
  • Open taskmkanager and monitor CPU frequency
  • Open Brave and navigate to
  • Put system to sleep
  • Connect power
  • Wake up system
  • Shutdown system
  • Change USB-C in slot $position+1, repeat.

I cannot get a grasp on what exactly was happening earlier.

Bottom line, the system is great! I wish I could be more useful in troubleshooting it…


Thanks, definitely let us know if it starts to occur again, and what the sequence of steps were when it happens.

1 Like