Clock stuck at .39Ghz

Warning: Make sure you read and understood the section above. CPU frequency limitation is a safety feature of your BIOS and you should not need to work around it.

If the firmware is telling the OS to downclock there’s probably a reason for it, the point is to figure out what that reason is, not bypass it.

If the people who have had the downclocking issue else can reproduce the results I posted above, check to see if the power supply is what’s caused the problem for them, or if it may be something else that needs to be looked into. If you’re not running linux, you can come up with your own test on windows that follows a reproducible, controlled methodology to test it. I would suggest some kind of benchmarking software that stresses the CPU and produces a measured result, like Geekbench, and some monitoring software to watch temperatures and frequencies as the test takes place, then record your results and post them.

Also, if someone who has not had the downclocking issue can run the tests too, maybe you do have the issue but haven’t noticed it, and also with a weaker power supply to see if it happens to them.

1 Like

What’s the latest on this? Are we still pending investigation to conclude on the root cause the impact of the broader audience here?

ezhik I know it would suck but I feel the best move is just for users to send in the laptops that are effected by this issue and have the actual framework team diagnosis the problem as it could be a hardware issue. They would probably come to an answer much faster than users who may or may not know what they are doing and what to look for or report.


I already went through an RMA, kudos to Framework as it was a painless experience (once again, setting a new standard for other OEMs).

But is that really a resolution? I would rather send in the charger that I am using or buy a separate one for Framework team, than send in the whole system, which I use day in and day out for work and pleasure.

So my laptop is behaving like this:

Using the framework charger.

When plugged in, fully charged, it’s performing worse than when it’s unplugged, on battery.

When it’s unplugged, on battery, it’s performing normally with no clock speed issues.

When plugged in, charging, it’s performing worse than both of the above cases. (throttling to 400mhz then slowly clocking up to 1.8GHz and no higher as the laptop charges, upon plugging in the power cord)

When using a different, stronger charger (90W vs 60W), it’s performing full power in each of those above scenarios.

This isn’t supposed to be how the laptop performs, correct? Should I start an RMA and have the laptop replaced because it or the power supply are defective (or both?) @nrp @Kieran_Levin

Edit: I just tested it with another power supply, so tested 3 power supplies in total. The 90W one works perfectly in all scenarios, the framework one is producing issues, and a 20W one did not cause any issues, and the battery and power adapter were both correctly discharging at the same time and no downclock took place.

Edit 2: When I plug another device into the second port on the 90W power supply, the power gets split between the 2 devices, for example, my phone will charge at 18W and the USB-C PD power mode for the laptop will change to a lower one. Upon doing this, I’ve observed the drop in clock speeds/performance, but it is not as bad as the framework adapter-- clock speeds drop from 3GHz down to 1.9GHz instead of plummeting to 400MHz.


I only just became aware of this yesterday after my laptop unexpectedly slowed to a crawl when charging. Haven’t noticed any issues on battery. I’ve only had time to do some very basic testing but it does seem to be related to charge level, pretty much flips a switch as soon as the battery hits 85% charge; below that, performance is as expected, above that, clocks are stuck around 0.39GHz. Edit: by the time it hits 90% charge performance has partially recovered but still isn’t going much beyond 2GHz, running an all-core workload like Cinebench R23 has clocks pegged around 1.8GHz.

Second edit: at 100% charge, Cincebench R23 clocks sit around 2.8GHz; normally on battery I can achieve around 3.5GHz all-core - granted, that might partially be a thermal issue related to heat from charging.

I don’t have a second USB-C charger floating around to test unfortunately, but I’ll do what I can to help diagnose this and get a log file of the behavior.

Also doesn’t matter which port I use for charging, same behavior in all of them.

Edit 3: quick and definitely not scientific plot of this behavior, the actual shifts in behavior seem to occur around 85% charge (sorry I wasn’t logging before that, but clocks were behaving normally to that point), 91% charge, and 96% charge, or thereabouts. This is mostly idling with a browser open, random blips are from trying different charging ports and running Cinebench briefly. Again I’ll try to be more systematic abou this when I have time.

Edit 4: Can confirm the PROCHOT flag is being thrown until about 97% charge level.


Just to throw my hat in the ring, I am seeing this issue on Arch Linux as well. Everything is fine, unless I am plugged into AC power, and the battery reaches around 83-84% charge. When I reach 84% charge the CPU frequency tanks down to 0.39Ghz ish. It recovers if I unplug the AC power.

1 Like

So I thought maybe this was a windows 11 bug because I just started noticing it after last week’s update. At first when using my 30w PD battery to extend the battery life while gaming and now with the Framework Charger.

I have a batch 3 i5, running windows 11 release preview and Beta bios. So far my troubleshooting steps:

Pulled the Keyboard, EMI shielding looks fine.

Tested all ports with and without my USB C expansion, all ports affected.

Tried different cables with both chargers, no change.

Interestingly enough, the StarTech Thunderbolt 3 dock doesn’t seem to be affected and I get full core clocks when plugged into that. Battery is charging and the normal 30ish watts.

I still have more testing to do at different battery levels but figured I’d check the forums first. Sucks that this seems to be a broad issue.

I’ve read on another thread that if the motherboard is running outside of the case without a battery, that it needs a 100W USB PD adapter to run.

I just started experiencing this issue as well, but I’ve also stopped being able to charge my laptop from the back left port. Made a support ticket about this.

The issue doesn’t happen when I’m on battery, nor when I connect the charger, but it starts happening when I disconnect the charger, at which point all CPUs drop to 200MHz (according to powertop) and I can’t get them to come back up without a reboot.

Thanks everyone for the highly detailed reports on this. This definitely helps us debug what is occurring. This is high on our list of issues to resolve.


My Microsoft Surface Pro 5 and Surface Pro 6 suffered from this as well. 400MHz clock rate while charging. Normal clock rate when on battery.

Fortunately a Microsoft firmware update eventually fixed it so it may not be a hardware issue with the Frameworks.


Let it discharge while idling and then recharge. Haven’t been able to consistently reproduce when this behavior starts other than a few minutes after I start charging. Same as before PROCHOT = YES as soon as the core clocks drop off and remains that way til about 96 or 97% charge where core clocks start to behave more normally again. i5-1135g7, Windows 10. I have both battery and charging set to “Better Performance” for this.


So my issue with both one port not charging and CPU throttling went away in the middle of trying to reproduce things. Here are all of my notes:

  • connected power to back left port, keyboard (NiZ Plum) to front left port, tried turning on computer, kept shutting off during boot
  • disconnected keyboard, computer managed to power on eventually
  • noticed laptop was not charging from back left port, disconnected and tried charging from front left port, which seemed to work
  • found the following pattern
    • booting from battery or with charger connected, cpu clock speed would be normal
    • upon disconnecting the charger (only tried on front left port), the cpu clock speed would get stuck at 200MHz
    • had to reboot to reset clock speed
  • tried connecting keyboard to front left port, laptop shut off and blinked a POST code but couldn’t catch it
  • tried to identify which ports the clock issue happens with, started going around all of them, and the issue stopped happening
  • suddenly could charge from back left port again
  • tried keyboard in all ports, with a usb-a to usb-c cable and a usb-c to usb-c cable. same results with both cables:
    • front left port goes through a cycle of connects/disconnects (viewable in dmesg)
    • all other ports work fine
  • tried usb ports with
    • usb 3.0 flash drive, worked with all ports reliably
    • usb 2.0 logitech wireless receiver, worked with all ports reliably
  • checked EMI shielding on ports just in case, it’s fine (which is expected because I have a Batch 3 machine)
  • current status
    • can’t reproduce charging or clock speed issue with any ports

So here’s one set of data gathered with HWInfo over a charge session from 10% to 98% with the Framework Charger:

During the charging session I just had it playing youtube and maybe some other light browsing.

I’ll do a similar test tonight with the thunderbolt dock that didn’t seem to have the issue.


@computerhac thanks for the results. I think it would work better if you performed a stress test while charging that way the clock frequencies would remain semi constant except for when the bug happens.

Okay not to junk up the forum with useless pics but here’s the one with my thunderbolt dock. The slope around 81% is nearly identical but I don’t experience any clock drops. If I’m feeling froggy I may fire up the ol Siglent this weekend and test ripple.


@Trevin_Corkery it is pretty apparent by the charge rate graph: once the laptop starts requesting less power around 80% the core clock stops favoring 3.25ghz and drops to a 400mhz ceiling. Then the ceiling starts to ramp up as the power level ramps down. It basically looks like a cliff and then stairs going back up.

1 Like

@computerhac You’re right, I do see how crazy the drop is. It honestly looks like it’s the charger that’s at fault here and not the laptop.

I wonder if some of the framework chargers are defective, this also makes me want to buy an anker nano 2 to test it the issue but then again I believe this is happening to a small subset of users.

I would agree but it also happens with my 30w PD charger and battery. its not enough to actually charge the laptop but it keeps it alive for longer under load. I notice the same issue in the same voltage range.

Perhaps not all the charger and not all the laptop is at fault. I’m guessing since the Thunderbolt 3 dock can charge at 100w it has more stable power at 40-60w. it looks like other users have experienced the same results with higher wattage power supplies. Possibly an issue with the PD chip.

Guess we’ll see what they say. I’d hate to RMA it as I just installed a matte screen cover. $30 is $30 xD

1 Like